About this file

This document is an Interface Requirements Document (IRD) that provides the design requirements for the interface between the Surface Movement Radar, Model 4 (SMR4) and the Federal Aviation Administration (FAA) Surface Surveillance System (SSS), which includes both Airport Surface Detection Equipment, Model X (ASDE-X) and Airport Surface Surveillance Capability (ASSC).

The IRD specifies that the SMR4 and the SSS will exchange ASTERIX formatted messages across redundant Local Area Network (LAN) interfaces. It defines the requirements for the ASTERIX message formats, delivery schemes, protocol implementation, network addressing, physical characteristics, and quality assurance provisions. Key requirements include: SMR4 must populate ASTERIX Category 010 messages with target reports, north marks, and operational status; SMR4 must output ASTERIX Category 240 monobit video messages; SMR4 must send ASTERIX Category 253 detailed status and monitoring messages, and the SSS must send ASTERIX Category 253 control messages to the SMR4. The document also specifies verification requirements for the interface during development testing, on-site testing, and site acceptance testing.

View the file

Other files

File Type Posted
SMR4 Attachment J-10 - Key Personnel Requirements Final.pdf PDF
SMR4 Section M - Evaluation Factors For Award Final.pdf PDF
SMR4 Section F - Deliveries or Performance Final.pdf PDF
SMR4 Section L - Instructions to Offerors Final.pdf PDF
SMR4 Attachment J-17 - ASDE-3 SMR Replacement PSP - Extracted from Portfolio Final.pdf PDF
SMR4 Section B - Supplies and Services Final.pdf PDF
SMR4 Section I - Contract Clauses Final.pdf PDF
SMR4 Attachment J-05 - SMR4 Site List_2024-08-26.xlsx XLSX spreadsheet
SMR4 Attachment J-15 - Program Level IBR Guide Final.pdf PDF
SMR4 Attachment J-19 - LMI Requirements Template_Final.xlsx XLSX spreadsheet
SMR4 Section E - Inspection and Acceptance Final.pdf PDF
Attachment L-6 - Cost Price Workbook Final.xlsx XLSX spreadsheet
Attachment L-4 - SMR4 SIR Questions Matrix.xlsx XLSX spreadsheet
SMR4 Attachment J-13 - FAA Asset Identification Process and Procedure Guide Final.pdf PDF
SMR4 Attachment J-09 - SMR4 Program Extract of Applicable Sections - FAA WBS 5.3_v2.pdf PDF
SMR4 Attachment J-16 -Request For Visit Foreign National FAA Form 1600-78 pending.pdf PDF
SMR4 Attachment J-18 - Disclosure of Data-Assertion and Identification (Assertions List).pdf PDF
Attachment L-2 Past Performance Survey Form Final.docx DOCX document
SMR4 Attachment J-11 - Surface Surveillance Program RIO Management SOP Final.pdf PDF
SMR4 Attachment J-06 - GSIP Draft.pdf PDF
Attachment L-1 Past Performance List Final.docx DOCX document
SMR4 Section K - Representations Certifications and Other Statements of Offerors Final.pdf PDF
SMR4 Section H - Special Contracts Requirements Final.pdf PDF
SMR4 Attachment J-07 - SMR4 Technical Requirements Matrix_Final.xlsx XLSX spreadsheet
SMR4 Attachment J-03 - SMR4 SSD Draft.pdf PDF
J-02 SMR4 Attachment - CDRLs and DIDs Matrix_2024-10-24 Final.xlsx XLSX spreadsheet
Attachment L-3 - Business Declaration Form.pdf PDF
Attachment L-5 - FAA SMR-4 RunAcquisitions Vendor User Form.docx DOCX document
SMR4 Attachment J-12 - RIO Identification Worksheet (In Depth) Final.pdf PDF
693KA7-25-R-00001_SMR Section A final.pdf PDF
SMR4 Section C - ASDE-3 SMR Replacement SOW Final.pdf PDF
SMR4 Section G - Contracting Administration Data Final.pdf PDF
SMR4 Section D - Packaging and Marking Final.pdf PDF
J-02 SMR4-DIDs.zip ZIP file
FAA Responses to RFI Vendor Questions (published Nov 20 2023).pdf PDF
Request For Information - SMR 4 (Amendment 1) - published.pdf PDF
Attachment 2 - Draft SIR - Section J - SMR4 SSD (Release).docx DOCX document
Request For Information - SMR 4 - published.pdf PDF
Attachment 3 - Draft SIR - Section J - SMR4 to Surface Surveillance System IRD.v3.1 (Release).docx DOCX document
Attachment 4 - Draft SIR - Section L (Release).docx DOCX document
Attachment 7 - Business Declaration Form.pdf PDF
Attachment 1 - Draft SIR - Section C - ASDE-3 SMR Replacement SOW (Release).docx DOCX document
Attachment 5 - Draft SIR - Section M (Release).docx DOCX document
Attachment 6 - SMR4 Draft SIR Response Matrix.xlsx XLSX spreadsheet
Show all 44

On GovTribe

Work with this file

  • Download the original file
  • Contacts named in this file
  • Similar government files
  • Ask GovTribe AI about this file

Text version

Surface Movement Radar, Model 4 (SMR4) to

Airport Surface Detection Equipment, Model X (ASDE-X) and Airport Surface Surveillance Capability (ASSC)

Interface Requirements Document (IRD)

NAS-IR-nnnnnnnn Revision: 0

DRAFT October 25, 2024

[ANG-B13 to Insert Baseline Date Here] Federal Aviation Administration 600 Independence Avenue, SW

Washington, D.C. 20591

SMR4 to ASDE-X and ASSC SIR 693KA7-25-R-00001 Interface Requirements Document, Revision: 0, NAS-IR-nnnnnnn Surface Movement Radar Model 4 (SMR4) [ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Page ii

Approval Signatures

Name Organization Signature Date

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Page iii

REVISION

Number

DESCRIPTION DATE

0 Baseline version for Screening Information Request (SIR) October 25, 2024

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Page iv

Table of Contents 1 Scope

1.1 Summary

1.2 System Responsibility List

2 Applicable Documents

2.1 Government Documents

2.2 Non-Government Documents

2.3 Document Sources

2.3.1 Electronic Industries Alliance Documents

2.3.2 ANSI/TIA Documents

2.3.3 IEEE Documents

2.3.4 IETF Standard (RFC) Documents

2.3.5 EUROCONTROL Documents

3 Interface Requirements

3.1 General Requirements

3.1.1 Security Requirements

3.2 Functional Requirements

3.2.1 Functional Design Requirements

3.2.2 Application Processes and Message Requirements

3.2.3 Protocol Implementation

3.2.4 Transport Layer Services

3.2.5 Naming and Addressing

3.3 Physical Requirements / Characteristics

3.3.1 Electrical Power and Electronic Characteristics

4 Quality Assurance Provisions

4.1 Responsibility for Verification

4.2 Special Verification Requirements

4.3 Verification Requirements Traceability Matrix

5 Preparation for Delivery

6 Notes

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Page v

6.1 Glossary

6.2 Abbreviations and Acronyms

Appendix A – General ASTERIX Message Formats

A.1 Message Structure

A.1.1 General

A.1.2 Data Field Formats

Appendix B – CRC-32 Algorithm

Appendix C – Verification Requirements Traceability Matrix

List of Figures Figure 1-1: SMR4 to Surface Surveillance System Configuration

Figure 3-1: OSI Seven Layer Model

Figure 3-2: Presentation Layer Data Unit

Figure A-1: ASTERIX Data Block Structure

List of Tables Table 1-1: System Responsibility List

Table 3-1: ASTERIX Message Type by Source

Table 3-2: Data Streams – SMR4 Source

Table 3-3: SMR4 Plot Data

Table 3-4: SMR4 CAT253 Detailed Status Report

Table 3-5: SSS CAT253 Command Examples

Table 3-6: SMR4 CAT010 User Application Profile and Construction

Table 3-7: CAT240 SMR4 Radar Video Transmission UAP

Table 3-8: CAT253 Monitoring and Control Messages UAP

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

1 Scope This Interface Requirements Document (IRD) provides the design requirements for the interface between the Surface Movement Radar, Model 4 (SMR4) and the Federal Aviation Administration (FAA) Surface Surveillance System (SSS), which includes both Airport Surface Detection Equipment, Model X (ASDE-X) and Airport Surface Surveillance Capability (ASSC). This interface uses All Purpose STructured Eurocontrol suRveillance Information eXchange (ASTERIX) formatted messages for all communications.

Changes in the interface require coordination among all recipients.

1.1 Summary

The ASDE-3 Surface Movement Replacement (3SR) program will replace the current ASDE-3 radars in the National Airspace System (NAS) with a newly acquired radar, which is known as SMR4.

ASTERIX messages are exchanged between the systems on two redundant Local Area Network (LAN) interfaces. Figure 1-1 depicts the general architecture of the interface between the SMR4 and the Surface Surveillance System. Both systems are responsible for maintaining the redundant interface link to ensure reliable communications between the systems.

The simplified network interfaces shown are for informational purposes only, as they are not within the scope of this document.

The following statements describe the terms used throughout this Interface Requirements Document:

• “Must” indicates a mandatory requirement.

• “May” and "should" indicate a desirable, but not mandatory function or characteristic.

• Text denoted by “Note” is explanatory and editorial and is not part of the interface requirements.

• “Surface Surveillance System” or “SSS” refers to both ASDE-X and ASSC.

• Appendix C contains a Verification Requirements Traceability Matrix.

• Terms that are capitalized and italicized (e.g., Data Stream, Data Block) within the requirements in this document are defined in the Glossary (Section 6.1). Definitions provided in the Glossary are considered part of the requirements in which the associated term is used.

SMR4

Channel 1

SMR4

Channel 2

(If Equipped)

Maintenance Subsystem

Fusion Subsystem

Network Time Server 1

Network Time Server 2

Multi-lateration Subsystem

Data Distribution Subsystem

Surface Movement Radar, Model 4

(SMR4)

FAA Surface Surveillance System (ASDE-X/ASSC)

LAN 2

LAN 1Switch/ Router 1

Switch/ Router 2

Display Subsystem

In pu t/ O ut pu t ( I/O

Pa ne l P ro ce ss or

C ab in et

Demarcation Point Figure 1-1: SMR4 to Surface Surveillance System Configuration

1.2 System Responsibility List

The following subsystems are affected by this IRD:

Table 1-1: System Responsibility List

System Name

Responsible Program Office

SMR4 Surface Movement Radar, Model 4 AJM-421

ASDE-X Airport Surface Detection Equipment, Model X (ASDE-X) AJM-421

ASSC Airport Surface Surveillance Capability (ASSC) AJM-421

2 Applicable Documents The following documents form a part of this IRD to the extent specified herein. In the event of a conflict between the referenced documents and the contents of this IRD, this IRD will be considered the superseding requirement.

2.1 Government Documents

Ref No Number Description

1 47 CFR Part 15 Code of Federal Regulations Title 47, Telecommunication, Part 15, Radio Frequency Devices

2 FAA-C-1217H Electrical Work, Premises Wiring, November 5, 2018

3 FAA-E-37024 Surface Movement Radar, Model 4 (SMR4) System Specification Document (SSD)

4 FAA-G-2100J Electronic Equipment General Requirements, April 19, 2022

5 FAA-HDBK-004 Federal Aviation Administration Handbook: National Airspace System (NAS) Internet Protocol Suite, September 4, 1997

6 FAA-STD-019E U.S. Department of Transportation, Federal Aviation Administration, Standard, Lightning and Surge Protection, Grounding, Bonding and Shielding Requirements for Facilities and Electronic Equipment, December 2005

7 FAA-STD-025f US Department of Transportation, Federal Aviation Administration Standard, Preparation of Interface Documentation, November 30, 2007

8 FAA-STD-039C U.S. Department of Transportation, Federal Aviation Administration, Standard Practice, National Airspace System (NAS) Open System Architecture and Protocols, August 14, 2003

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Ref No Number Description

9 FAA-STD-042B National Airspace System (NAS) Naming and Addressing Structure for Ground-To-Ground Communication

10 NG 1810.8B FAA William J. Hughes Technical Center Test and Evaluation Policy Order

11 Order 6950.22 Maintenance of Electrical Power and Control Cables, May 8, 12 VVSPT-A2-PDD-013 FAA William J Hughes Technical Center (WJHTC) Test and Evaluation Handbook, Version 3.0, September 24, 2013

13 N/A AMS Test and Evaluation Process Guidelines

2.2 Non-Government Documents

Ref No Name/Number Description

1 IEEE Standard 1100-2005 Recommended Practice for Powering and Grounding Electronic Equipment

2 ANSI/TIA-568-D Commercial Building Telecommunications Cabling Standard

3 EUROCONTROL Part 1, ASTERIX

EUROCONTROL Specification for Surveillance Data Exchange - Part 1 All Purpose Structured EUROCONTROL Surveillance Information Exchange (ASTERIX), EUROCONTROL-SPEC-0149, Edition 2.3, November 12, 2015

4 EUROCONTROL ASTERIX

Cat10, Monosensor Surface Movement Data

EUROCONTROL STANDARD DOCUMENT FOR SURVEILLANCE

DATA EXCHANGE Part 7: Category 010 Transmission of Monosensor Surface Movement Data, SUR.ET1.ST05.2000-STD- 07-01, Edition 1.1, March 2007

6 EUROCONTROL ASTERIX

Cat240, Monobit Video

EUROCONTROL Specification for Surveillance Data Exchange ASTERIX Category 240, Radar Video Transmission, EUROCONTROL-SPEC-0149-240, Edition 1.3, May 13, 2015

7 EUROCONTROL ASTERIX

Cat253, Monitoring & Control

EUROCONTROL Specification for Surveillance Data Exchange ASTERIX Category 253, Remote Monitoring and Control, Edition 11, February 8, 2021

8 IEEE 802.3 CSMA/CD Access Method (Ethernet), 100BASE-T, 1000BASE-T, 9 IETF RFC-768 User Datagram Protocol

10 IETF RFC-791 Internet Protocol Version 4 (IPv4) Specification

11 IETF RFC-826 Ethernet Address Resolution Protocol

12 IETF RFC-950 Internet Standard Subnetting Procedure

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Ref No Name/Number Description

13 IETF RFC-1122 Requirements for Internet Hosts - Communication Layers

15 IETF RFC-2236 Internet Group Management Protocol, Version 2

16 IETF RFC-2464 Transmission of IPv6 Packets over Ethernet Networks

17 IETF RFC-2865 Remote Authentication Dial-In User Service (RADIUS)

18 IETF RFC-4291 IPv6 Addressing Architecture

19 IETF RFC-4443 Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification

20 IETF RFC-4601 Protocol Independent Multicast – Sparse Mode (PIM-SM):

Protocol Specification

21 IETF RFC-5905 Network Time Protocol Version 4: Protocol and Algorithms Specification

22 IETF RFC-8200 Internet Protocol Version 6 (IPv6) Specification

23 NEC NFPA 70 National Electrical Code and Handbook

2.3 Document Sources

2.3.1 Electronic Industries Alliance Documents

Copies of Electronic Industries Alliance (EIA) standards may be obtained through their website at http://www.ecianow.org/.

2.3.2 ANSI/TIA Documents

Copies of American National Standards Institute (ANSI)/Telecommunications Industry Association (TIA) documents may be obtained from the ANSI website at http://www.ansi.org or the TIA website at https://tiaonline.org/.

2.3.3 IEEE Documents

Copies of Institute of Electrical and Electronics Engineers (IEEE) documents may be obtained from IEEE Computer Service, 445 Hoes Lane, P.O. Box 1331, Piscataway, NJ 08855-1331, by calling (800) 701-4333 (in the U.S. and Canada) or (732) 981-0060 (outside of the U.S. and Canada), or through their standards website at http://www.ieee.org/web/standards/home/index.html.

2.3.4 IETF Standard (RFC) Documents

Copies of the Internet Engineering Task Force (IETF) Standard (RFC) documents may be obtained through their website at http://www.rfc-editor.org/rfc-index2.html.

2.3.5 EUROCONTROL Documents

Copies of EUROCONTROL documents may be obtained through their website at https://www.eurocontrol.int/library.

http://www.ecianow.org/ http://www.ansi.org/ https://tiaonline.org/ http://www.ieee.org/web/standards/home/index.html http://www.rfc-editor.org/rfc-index2.html https://www.eurocontrol.int/library

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3 Interface Requirements

3.1 General Requirements

This IRD provides the requirements for the SMR4 interface with the ASDE-X and ASSC systems. Unless otherwise specified, all requirements apply to both the SMR4 and the interfacing ASDE-X and ASSC.

This IRD defines a system to system interface using the transmission of ASTERIX Data using Internet Protocol (IP). Therefore, no human system interface requirements are included. The interface provides a fully redundant physical link between the SMR4 and the Surface Surveillance System, as illustrated in Figure 1-1. The design provides for the following:

• A two-way interface between the SMR4 and the ASDE-X system, or between the SMR4 and the ASSC system for the exchange of Target Data, Status Messages, and Control Messages.

• The data is provided on redundant LANs.

The Input/Output (I/O) panels at the top of the Surface Surveillance System is the point of demarcation between the SMR4 and the Surface Surveillance System. The SMR4 is responsible for all connections and cables up to the I/O panel. The networks are cross connected via direct on-site cable.

The SMR4 system will interface to the Surface Surveillance System redundant LANs. Each system’s online operational channel will send identical data on both LANs. If a standby channel is available, neither system’s standby channel will send data across the interface.

[SMR4-IRD001] ASTERIX messages must be in accordance with the EUROCONTROL Specification for Surveillance Data Exchange - Part 1 All Purpose Structured EUROCONTROL Surveillance Information Exchange (ASTERIX), EUROCONTROL-SPEC-0149, Edition 3.1, November 23, 2021.

[SMR4-IRD002] Surveillance data messages must be formatted as ASTERIX Category 010 Monosensor Surface Movement Data messages (CAT10) in accordance with the EUROCONTROL Category 010 Specification, SUR.ET1.ST05.2000-STD-07-01, Edition 1.1, March 27, 2007.

[SMR4-IRD003] Video messages must be formatted as ASTERIX Category 240 Radar Video Transmission messages (CAT240) in accordance with the EUROCONTROL ASTERIX Category 240 Specification, EUROCONTROL-SPEC-0149-240, Edition 1.3, May 13, 2015.

[SMR4-IRD004] Monitoring and Control Messages must be formatted as ASTERIX Category 253 Remote Monitoring and Control messages (CAT253) in accordance with the EUROCONTROL ASTERIX Category 253 Specification, Edition 11, February 8, 2021.

3.1.1 Security Requirements

Except as listed below, security requirements are defined in the System Specifications for the SMR4, ASDE-X, and ASSC.

[SMR4-IRD005] The Surface Surveillance System must authenticate, authorize, and audit all SMR4 user accounts using an Authentication, Authorization, and Auditing (AAA) Remote Authentication Dial-In User Service (RADIUS) in accordance with RADIUS RFC2865.

3.2 Functional Requirements

3.2.1 Functional Design Requirements

Table 3-1 summarizes the data flow between the SMR4 and the Surface Surveillance System.

Table 3-1: ASTERIX Message Type by Source

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

ASTERIX

Category

Message Type

Source System

Destination Subsystem

SMR4 Interface Message

010 001 SMR4 SSS: Fusion and Maintenance

SMR4 Target Reports

010 002 SMR4 SSS: Fusion and Maintenance

SMR4 North Mark

010 003 SMR4 SSS: Fusion and Maintenance

SMR4 Operational Status Report

240 As Required SMR4 SSS: Display SMR4 Monobit Video

253 As Required SMR4 SSS: Fusion and Maintenance

SMR4 Detailed Status Message

253 As Required SSS SMR4 SSS Control Messages

253 As Required SSS SMR4 SSS Closed Regions

253 As Required SSS SMR4 SSS System Mode Messages

3.2.2 Application Processes and Message Requirements

The SMR4 and the Surface Surveillance System have one or more applications that provide for the transmission and reception of the radar and control messages to the collocated system. The details of each system’s application are within their respective System Design documents.

3.2.2.1 Identification of Each Application Process

[SMR4-IRD006] Destination multicast addresses must be site adaptable for each LAN interface.

[SMR4-IRD007] Transport layer port numbers must be site adaptable for each Data Stream.

[SMR4-IRD008] Data Streams must be transmitted using the delivery scheme shown in Table 3-2.

Table 3-2: Data Streams – SMR4 Source

Data Source

Data Streams ASTERIX Category

Delivery Schemes

SMR4 Surveillance Data Messages 10 Multicast

SMR4 Video Messages 240 Broadcast

SMR4 Monitoring Messages 253 Multicast

SMR4 Control Messages (Replies) 253 Unicast

SSS Monitoring Messages 253 Multicast

SSS Control Messages 253 Unicast

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.2.2.2 Application Process Capability Requirements

The SMR4 and Surface Surveillance System application processes are still held to their respective accuracy, throughput, latency, and availability requirements. The details of each system’s application are within their respective System Design documents.

[SMR4-IRD009] The SMR4 must pass incoming messages with approved source IP addresses, protocols, and destination port numbers.

[SMR4-IRD010] The SMR4 must log occurrences of incoming messages from unapproved source IP addresses, protocols, and destination port numbers.

[SMR4-IRD011] The SMR4 must block incoming Transmission Control Protocol (TCP) connection attempts from unapproved IP addresses and destination port numbers.

[SMR4-IRD012] The SMR4 must log incoming TCP connection attempts from unapproved IP addresses and destination port numbers.

3.2.2.3 Message Content Requirements

3.2.2.3.1 Common ASTERIX Message Requirements

The following requirements apply to all categories of ASTERIX identified in this IRD.

[SMR4-IRD013] ASTERIX Data Blocks must be generated with a site adaptable maximum size of up to 1494 bytes.

Note: The maximum packet size is 1500 bytes. This requirement is for the Application Layer and the Presentation Layer adds 6 bytes for the Sequence Number and CRC-32.

[SMR4-IRD014] The ASTERIX Data Block must be defaulted to a maximum size of 506 bytes.

[SMR4-IRD015] All spare bits in an ASTERIX Record must be set to zero.

[SMR4-IRD016] The applicability of Data Items in an ASTERIX Record record must be in accordance with Table 3-6, Table 3-7, and Table 3-8.

[SMR4-IRD017] ‘Compulsory’ Data Items must be included in every ASTERIX Record.

[SMR4-IRD018] ‘Compulsory if available’ Data Items must be included in an ASTERIX Record when data is available.

[SMR4-IRD019] ‘Not used’ Data Items must be excluded from an ASTERIX Record.

[SMR4-IRD020] Data Items identified in the Field Specification (FSPEC) of each ASTERIX Record which are compliant with ASTERIX Category’s User Application Profile (UAP) must be parsed.

[SMR4-IRD021] All ASTERIX messages must be timestamped with an accuracy of less than or equal to 10 milliseconds relative to Coordinated Universal Time (UTC).

[SMR4-IRD022] The SMR4 must prioritize the order of message transmission using the following prioritization: 1. Cat010 North Marks 2. Cat010 Target Reports 3. Cat010 Operational Status 4. Cat240 Monobit Video 5. Cat253 Detailed Status Report.

3.2.2.3.2 ASTERIX Category 10 Message Requirements

[SMR4-IRD023] The SMR4 must populate ASTERIX Category 010 messages in accordance with Table 3-6.

[SMR4-IRD024] The Surface Surveillance System must receive ASTERIX Category 010 messages in accordance with Table 3-6.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.2.2.3.2.1 SMR4 Target Report

[SMR4-IRD025] The SMR4 must output Target Reports to the Surface Surveillance System as Type 001 ASTERIX Category 010 messages in accordance with Table 3-6.

[SMR4-IRD026] The SMR4 Time of Day for a Target Report must be the time that the antenna is pointed at the calculated target boresight azimuth.

[SMR4-IRD027] The SMR4 must use True North as Local Geographical North for all Target Reports using an azimuth reference.

[SMR4-IRD028] The SMR4 must provide the measured plot position without extrapolation for all Target Reports providing a position.

[SMR4-IRD029] The SMR4 must populate Data Item I010/042 (Position in Cartesian Coordinates) with the measured plot position centroid using Cartesian Coordinates expressed in the Radar Plane in accordance with EUROCONTROL Category 010 Specification, SUR.ET1.ST05.2000-STD-07-01, Edition 1.1, March 27, 2007, paragraph 4.3.2.1.

[SMR4-IRD030] For targets identified as multipath, the SMR4 must set Data Item I010/170 (Track Status) GHO field (Bit 8) to a value of 1, see EUROCONTROL Category 010 Specification, SUR.ET1.ST05.2000-STD- 07-01, Edition 1.1, March 27, 2007.

[SMR4-IRD031] The SMR4 must include the information from Table 3-3 in Data Item I010/SP (Special Purpose) for each target plot and for each primitive associated with the target plot.

Table 3-3: SMR4 Plot Data

Data Purpose Units Mandatory

Probability Probability that this primitive should be associated with the plot. 0-15 No

Range Bounds Range Start and Range End relative to the SMR4 antenna in slant range. Meters Yes

Azimuth Bounds Azimuth Start and Azimuth Stop relative to the SMR4 antenna. 360/216 degrees Yes

Record Number A 26-bit unsigned integer used to identify each primitive. The record number updates with each detection.

N/A Yes

3.2.2.3.2.2 SMR4 North Mark

[SMR4-IRD032] The SMR4 must send a North Mark Message to the Surface Surveillance System each time the antenna boresight passes True North.

[SMR4-IRD033] The SMR4 must output North Marks to the Surface Surveillance System as Type 002 ASTERIX Category 010 messages in accordance with Table 3-6.

[SMR4-IRD034] The SMR4 Time of Day for a North Mark must be the time that the face of the antenna is pointed at True North.

3.2.2.3.2.3 SMR4 Operational Status Report

[SMR4-IRD035] The SMR4 Operational Status Report must be formatted as Type 003 ASTERIX Category 010 Periodic Status Messages in accordance with Table 3-6.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

[SMR4-IRD036] The SMR4 must populate I010/550 (System Status) NOGO Field (bits 7 and 8) based on the overall SMR4 summary state, see EUROCONTROL Category 010 Specification, SUR.ET1.ST05.2000- STD-07-01, Edition 1.1, March 27, 2007.

3.2.2.3.3 ASTERIX Category 240 Message Requirements (SMR4 Monobit Video) [SMR4-IRD037] The SMR4 must output processed Monobit Video to the Surface Surveillance System as ASTERIX Category 240 messages.

[SMR4-IRD038] The SMR4 must populate ASTERIX Category 240 messages in accordance with Table 3-7.

[SMR4-IRD039] The Surface Surveillance System must receive ASTERIX Category 240 messages in accordance with Table 3-7.

3.2.2.3.4 ASTERIX Category 253 Message Requirements

[SMR4-IRD040] ASTERIX Category 253 messages must be populated in accordance with Table 3-8.

[SMR4-IRD041] ASTERIX Category 253 messages must be received in accordance with Table 3-8.

3.2.2.3.4.1 SMR4 Detailed Status Report

[SMR4-IRD042] The SMR4 Detailed Status Report must be formatted as ASTERIX Category 253 messages.

[SMR4-IRD043] At a minimum, the SMR4 detailed Status Report must contain the information indicated in Table 3-4.

Table 3-4: SMR4 CAT253 Detailed Status Report

Status Description

Line Replaceable Unit (LRU) Operational Health of each SMR4 LRU.

Redundant Elements Operational Status of all SMR4 Redundant Element.

System Performance Monitoring Data

All system performance monitoring data. At a minimum, this includes the following items from the SMR4 system specification:

• Transceiver Performance Monitor

• Antenna Performance Monitor

• Processor Performance Monitor

System Performance Tests Results of all SMR4 automated system performance monitoring tests.

Statistics Results of all periodic statistics included in the SMR4 design.

Checksum Calculated executable software checksum.

Interlock Status of each Antenna Subsystem interlock.

Waveguide Switch Position of the Antenna Waveguide Switch.

Playback Mode Indication if the SMR4 is processing live data or is in playback mode.

Target Inhibit Region Checksum Checksum calculated for the Target Inhibit Regions.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.2.2.3.4.2 Surface Surveillance System – System Mode

[SMR4-IRD044] The Surface Surveillance System must send a System Mode message to the SMR4 at a nominal rate of once per second, within a tolerance of ± 0.1 second.

[SMR4-IRD045] The Surface Surveillance System Mode message must be formatted as ASTERIX Category 253 messages.

[SMR4-IRD046] The System Mode message must indicate the current Surface Surveillance System mode of operation as either Operational or Maintenance.

3.2.2.3.4.3 Surface Surveillance System – Command and Control The Surface Surveillance System command and control messages to the SMR4 will be documented in the SMR4 to Surface Surveillance System Interface Control Document (ICD). Table 3-5 includes the minimum subset of commands that are expected to be included in the design. Besides the requirements listed below, any additional control requirements will be included in the ASDE-X and ASSC system specifications (e.g., graphic user interface modifications).

[SMR4-IRD047] The Surface Surveillance System must send command and control messages to the SMR4 as ASTERIX Category 253 messages.

[SMR4-IRD048] The Surface Surveillance System must send Closed Region messages to the SMR4 as ASTERIX Category 253 messages.

[SMR4-IRD049] When the Clear Faults button is selected on the Surface Surveillance System Maintenance Display Terminal, the Surface Surveillance System must send a Clear Faults command to the SMR4 as an ASTERIX Category 253 message.

[SMR4-IRD050] When the System Stop button is selected on the Surface Surveillance System Maintenance Display Terminal, the Surface Surveillance System must send a System Stop command to the SMR4 as an ASTERIX Category 253 message.

[SMR4-IRD051] When the SMR4 receives a command from the Surface Surveillance System, it must send a confirmation formatted as an ASTERIX Category 253 message to the Surface Surveillance System indicating the success or failure of the command.

Table 3-5: SSS CAT253 Command Examples

Command Purpose

Start Antenna Rotation Initiates SMR4 antenna rotation

Stop Antenna Rotation Disables SMR4 antenna rotation

Start Transmit Starts radiation of transmit pulses

Stop Transmit Stops radiation of transmit pulses

System Reset Restarts all applications running on the radar system

System Reboot Reboots all system processors

System Shutdown Disables antenna rotation and power down all radar system components

Processor Reset Restarts the application(s) running on the specified processor

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Processor Reboot Reboots the specified processor

Processor Shutdown Powers down the specified processor

Channel Select Makes the specified channel the online channel and connects it to the Antenna Subsystem

Clear Faults Clear all radar system faults indications

Redundant Element Select

Places the specified Redundant Element online

System Go Initiates antenna rotation, connects the online channel to the Antenna Subsystem, and starts radiating transmit pulses

System Stop Disables antenna rotation and stops radiating transmit pulses

Antenna Select Connects the selected channel to the Antenna Subsystem

Dummy Load Select Connects the selected channel to the dummy load

Manual Array Heater On

When the antenna is equipped with an array heater, this command turns on the heater overriding the automatic controls

Manual Array Heater Off

When the antenna is equipped with an array heater, this command turns off the heater overriding the automatic controls

3.2.2.3.5 User Application Profile and Standard Data Items

ASTERIX messages are allocated to a Standard User Application Profile (UAP) consisting of Data Fields.

Data Fields within an ASTERIX message are associated with a Field Reference Number (FRN) and are populated with Data Items. The UAP can be considered a control table attached to the message assembly/disassembly program resident in the processing system. Some Data Items are Compulsory while others are Optional. At transmission time, not all the Data Fields (Data Items) need be output.

The following tables define the Standard Data Items for ASTERIX Categories 010, 240, and 253. Each Data Item is defined as Compulsory (C), Compulsory if Available (C/A), Optional (O), or Not Used (X) which are defined in Section 6.1.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.2.2.3.5.1 Category 010 (Surface Movement Data) UAP

The Category 010 data sent from the SMR4 to the Surface Surveillance System includes Target Reports, North Marks, and Operational Status. SMR4 Category 010 Surface Movement Data will be formatted as defined in Table 3-6.

Table 3-6: SMR4 CAT010 User Application Profile and Construction

FRN Data Item Ref. No.

Description Criteria for Inclusion:

Compulsory: (C)

Compulsory if Available: (C/A) Optional: (O) Not Used: (X)

Target Report

North Mark

Operational

Status

1 I010/010 Data Source Identifier C C C

2 I010/000 Message Type C (001) C (002) C (003)

3 I010/020 Target Report Descriptor C X X

4 I010/140 Time-of-Day C C C

5 I010/041 Position in WGS-84 Coordinates O X X

6 I010/040 Measured Position in Polar Coordinates O X X

7 I010/042 Position in Cartesian Coordinates C X X

8 I010/200 Calculated Track Velocity in Polar Coordinates O X X

9 I010/202 Calculated Track Velocity in Cartesian Coordinates C X X

10 I010/161 Track Number C X X

11 I010/170 Track Status C X X

12 I010/060 Mode-3/A Code in Octal Representation X X X

13 I010/220 Target Address X X X

14 I010/245 Target Identification X X X

15 I010/250 Mode S MB Data X X X

16 I010/300 Vehicle Fleet Identification X X X

17 I010/090 Flight Level in Binary Representation X X X

18 I010/091 Measured Height X X X

19 I010/270 Target Size & Orientation C1 X X

20 I010/550 System Status X X C

21 I010/310 Pre-Programmed Message X X X

22 I010/500 Standard Deviation of Position O X X

23 I010/280 Presence C X X

24 I010/131 Amplitude of Primary Plot O X X

25 I010/210 Calculated Acceleration O X X

26 Spare X X X

27 I010/SP Special Purpose Field C/A X C/A

28 I010/RE Reserved Expansion Field X X X

• 1I010/270 Orientation is optional.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.2.2.3.5.2 Category 240 (Radar Video Transmission Messages) UAP SMR4 Category 240 Radar Video Transmission Messages must be formatted as defined in Table 3-7.

Table 3-7: CAT240 SMR4 Radar Video Transmission UAP

FRN Data Item Ref. No.

Description Criteria for Inclusion:

Compulsory: (C)

Compulsory if Available: (C/A)

Optional: (O) Not Used: (X)

Video

Summary Message

Video

Message

1 I240/010 Data Source Identifier C C

2 I240/000 Message Type C C

3 I240/020 Video Record Header X C

4 I240/030 Video Summary C X

5 I240/040 Video Header Nano X C/A1

6 I240/041 Video Header Femto X C/A1

7 I240/048 Video Cells Resolution & Data Compression Indicator

X C

8 I240/049 Video Octets & Video Cells Counters X C

9 I240/050 Video Block Low Data Volume X C/A2

10 I240/051 Video Block Medium Data Volume X C/A2

11 I240/052 Video Block High Data Volume X C/A2

12 I240/140 Time-of-Day O O

13 I240/RE Reserved Expansion Field X X

14 I240/SP Special Purpose Field X X

• 1Either Item I240/040 or I240/041 must be present in each Video Message.

• 2Either Item I240/050 or I240/051 or I240/052 must be present in each Video Message.

3.2.2.3.5.3 Category 253 (Monitoring and Control Messages) UAP SMR Category 253 Monitoring and Control messages will be formatted as defined in Table 3-8.

Table 3-8: CAT253 Monitoring and Control Messages UAP

FRN Data Item Ref. No.

Description Criteria for Inclusion:

Compulsory: (C)

Compulsory if Available: (C/A) Optional: (O) Not Used: (X)

Detailed Status Report

Control Message, Closed Region, System Mode Message

SMR4 ASDE-X ASSC

1 I253/010 Data Source Identifier C C C

2 I253/015 Local Data Source Identifier C C C

3 I253/025 Data Destination and Local Identifier C C C

4 I253/030 Source Application Identifier C C C

5 I253/040 Message Type C C C

6 I253/050 Message Sequence ID C/A C/A C/A

7 I253/070 Time of Day C C C

8 I253/035 Data Origin Identifier X X X

9 I253/060 Blocking Information O O O

10 I253/080 Application Data Structure C C C

11 I253/090 Application Data O O O

12 I253/100 Transparent Application Data 1 O O O

13 I253/SP Reserved for SP Indicator X X X

14 I253/RE Reserved for RE Indicator X X X

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.2.2.4 Relationship Among Messages

There are no Relationship Among Messages requirements in this IRD.

3.2.2.5 Quality of Service Requirements

Quality of Service requirements, including accuracy, throughput, latency, and availability requirements are specified within the FAA-E-37024 SMR4 specification.

3.2.2.6 Error Handling Requirements

The following represent requirements of the application error handling for processed Data Units.

[SMR4-IRD052] The Surface Surveillance System must detect degradation in SMR4 data latency using ASTERIX Records that contain a valid Time of Day Data Item.

[SMR4-IRD053] The Surface Surveillance System must discard duplicate packets detected using the Sequence Number embedded in the Data Unit.

[SMR4-IRD054] The Surface Surveillance System must report discontinuity in Sequence numbers in the monitoring of the Surveillance Data not attributed to Surveillance System channel reconfiguration or system cold/warm starts.

Note: If the SMR4 uses multiple channels, the SMR4 does not need to synchronize Sequence Numbers between channels since the Source IP address will be different for each channel.

Discontinuity in sequence numbers can either be from missing or out of order packets.

[SMR4-IRD055] ASTERIX Records must be validated using the CRC-32 embedded in the Data Unit.

[SMR4-IRD056] ASTERIX Records must be validated using the Length contained in the ASTERIX Data Block.

[SMR4-IRD057] Invalid ASTERIX Records must be discarded as determined by the CRC-32 and ASTERIX Data Block Length.

[SMR4-IRD058] The Surface Surveillance System must report discarded ASTERIX Records in the monitoring of the Surveillance Data.

[SMR4-IRD059] ASTERIX Records that contain ‘Not Used’ Data Items must be accepted.

3.2.2.7 Interface Summary Table

Table 3-1 in Section 3.2.1 summarizes the data flow between the SMR4 and the Surface Surveillance System.

3.2.3 Protocol Implementation

The local IP-Based network between the SMR4 and the Surface Surveillance System consists of direct (i.e., point-to-point) LAN connectivity between the two systems and provides IP Services per FAA-STD-039C standard titled: “National Airspace System (NAS) Open System Architecture and Protocols.” The communications protocols allow computers from different vendors, using different operating systems, to exchange data. This data transfer is accomplished over data networks using various protocols. The complete set of protocols necessary for such communication is referred to as a protocol suite. This IRD references requirements to the Open Systems Interconnection (OSI) seven-layer model, as shown in Figure 3-1.

Figure 3-1: OSI Seven Layer Model

3.2.3.1 Application Layer Service

An ASTERIX Record encodes the information of a single Radar Target or a single Service Message. A unique System Identification Code, System Area Code (SIC/SAC) is assigned to each radar site and is utilized in all ASTERIX Records sent on the interface.

The ASTERIX Data Block supports the packing of multiple ASTERIX Records of the same type, per ASTERIX construction rules in the Eurocontrol document, Part 1, All Purpose Structured EUROCONTROL Surveillance Information Exchange (ASTERIX), EUROCONTROL-SPEC-0149, Edition 3.1, November 23, 2021. The Data Unit will only contain one ASTERIX Data Block.

[SMR4-IRD060] The SMR4 must have a site adaptable SIC code for Surveillance Data output on the interface.

[SMR4-IRD061] The entire ASTERIX Record which is compliant with ASTERIX Category’s UAP must be parsed.

[SMR4-IRD062] Each Data Item indicated by the ASTERIX Category’s UAP must be parsed.

[SMR4-IRD063] The Surface Surveillance System must be implemented such that valid ASTERIX formatted messages will not cause a fault.

[SMR4-IRD064] When recording SMR4 Surveillance Data messages, the Surface Surveillance System must record all Data Items in the ASTERIX Record even if the Data Item is not used.

3.2.3.2 Presentation Layer

Each ASTERIX Category packet data is preceded by a 2-byte unsigned sequence number and followed by a 4-byte CRC-32, as illustrated in Figure 3-2. The sequence number is independently incremented for each port and wraps to zero after counting to 65,535.

Figure 3-2: Presentation Layer Data Unit

The Data Unit serves the following functions:

• Applies a unique number to each packet for determining if packets are lost between the SMR4 and the Surface Surveillance System.

• Provides error detection of the application elements that may occur in transmission between the SMR4 and the Surface Surveillance System.

[SMR4-IRD065] ASTERIX Data Blocks must be encapsulated as shown in Figure 3-2.

[SMR4-IRD066] The SMR4 must send the same Data Unit to both redundant Surface Surveillance System LANs.

[SMR4-IRD067] The Surface Surveillance System must monitor the availability of SMR4 data on both of its redundant LANs.

3.2.3.2.1 Packet Sequence Number

[SMR4-IRD068] The SMR4 must maintain a 2-byte unsigned Sequence Number independently for each Data Stream.

[SMR4-IRD069] The SMR4 must increment Sequence Numbers by one independently for each Data Stream.

[SMR4-IRD070] The SMR4 must assign the Sequence Number for each Data Stream to the next ASTERIX Data Block in line for transmission.

[SMR4-IRD071] The SMR4 must wrap the Sequence Number to zero following Sequence Number 65,535.

3.2.3.2.2 CRC-32

[SMR4-IRD072] A 4-byte CRC-32 must be transmitted with each ASTERIX Data Block as illustrated in Figure 3-2.

[SMR4-IRD073] The CRC-32 must be computed as described in Appendix B.

3.2.4 Transport Layer Services

[SMR4-IRD074] User Data Protocol (UDP) must be used for all Data Units on the interface.

[SMR4-IRD075] All transport layer protocols must be implemented in accordance with IETF RFC-1122.

[SMR4-IRD076] UDP for the transport layer must be implemented in accordance with IETF RFC-768 for ASTERIX Categories 010, 240, and 253.

[SMR4-IRD077] The SMR4 must support Internet Protocol Version 4 (IPv4) as a configuration item for the network layer in accordance with IETF RFC-791.

Data Unit

(Presentation Layer)

Application Element (one ASTERIX

Data Block)

CRC-32

(4 bytes)

Transmission Order

Sequence Number (2 bytes)

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

[SMR4-IRD078] The SMR4 hardware must be Internet Protocol Version 6 (IPv6) capable as a configuration item for the network layer in accordance with IETF RFC-8200, as well as IETF RFC-2464, 4291, and 4443.

[SMR4-IRD079] Address Resolution Protocol (ARP) must be implemented in accordance with IETF RFC- 826.

[SMR4-IRD080] Protocol Independent Multicast (PIM) – Sparse Mode must be supported as defined in

IETF RFC-4601.

[SMR4-IRD081] The SMR4 must support IETF RFC-950, Internet Standard Subnetting Procedure.

[SMR4-IRD082] Transport layer protocol must be implemented in accordance with FAA-STD-039C and FAA-STD-042B, with guidance from FAA-HDBK-004.

[SMR4-IRD083] The SMR4 must support IETF RFC-2236, Internet Group Management Protocol, Version 2.

[SMR4-IRD084] The Surface Surveillance System must support IETF RFC-2236, Internet Group Management Protocol, Version 2.

[SMR4-IRD085] The Surface Surveillance System must allow Coordinated Universal Time (UTC) synchronization messages to transition across the Local Area Network interfaces with the SMR4.

[SMR4-IRD086] The Surface Surveillance System must provide Network Time Protocol (NTP) services compliant with IETF RFC-5905 for SMR4 time synchronization.

3.2.5 Naming and Addressing

The Surveillance Data listed in Table 3-1 will be provided across the interface. Figure 1-1 illustrates the fully redundant interface between the SMR4 and the Surface Surveillance System.

If equipped with multiple channels, only one of the SMR4 channels will be online at any given time and only the online channel will transmit data. The online channel will transmit UDP data to both Surface Surveillance System LAN A and Surface Surveillance System LAN B using separate IP addresses, but the same port numbers.

[SMR4-IRD087] The SMR4 hostname(s) must be configurable.

[SMR4-IRD088] The SMR4 must utilize unique IP multicast addresses compatible with the Surface Surveillance System.

[SMR4-IRD089] The SMR4 must utilize unique IP source addresses compatible with the Surface Surveillance System.

[SMR4-IRD090] The SMR4 must provide redundant network paths for the interface with the Surface Surveillance System.

[SMR4-IRD091] All messages from the SMR4 online channel to the Surface Surveillance System must be output simultaneously on both redundant LANs.

[SMR4-IRD092] The SMR4 standby channel must be inhibited from transmitting data on the Surface Surveillance System interface.

3.3 Physical Requirements / Characteristics

The physical requirements for the SMR4 networking hardware are described below.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

3.3.1 Electrical Power and Electronic Characteristics

Ethernet crossover cables are not required for this interface.

[SMR4-IRD093] Electrical connection requirements for this Ethernet interface must be as specified in

IEEE 802.3.

[SMR4-IRD094] The LANs must support auto-negotiation of 100BASE-T and 1000BASE-T protocols as defined in IEEE 802.3 for this interface.

3.3.1.1 Connectors

[SMR4-IRD095] LAN cables at the demarcation points must be terminated with 8-position, 8-contact modular connectors (8P8C T568A pinout using an RJ-45 connector).

[SMR4-IRD096] Ethernet LAN connectors must be wired in accordance with ANSI/TIA-568-D.

[SMR4-IRD097] Ethernet LAN cables must be terminated with Category 6 compliant terminations.

3.3.1.2 Wire/Cable

[SMR4-IRD098] The SMR4 must provide four Ethernet cables to connect the physical interface.

[SMR4-IRD099] All cables located in the plenum area must be plenum rated.

[SMR4-IRD100] The LAN cable provided to the demarcation points must be 8-wire, 4-pair, 100 ohm, 24 American Wire Guage (AWG), Unshielded Twisted Pair (UTP).

[SMR4-IRD101] All cabling must be Category 6 conforming to the specifications of ANSI/TIA-568-D.

[SMR4-IRD102] Each individual LAN cable must be less than 295 feet in length.

[SMR4-IRD103] The total length including any patch cords must be less than 328 feet.

[SMR4-IRD104] Equipment cables must be in accordance with NFPA 70, National Electric Code; FAA- C1217H, Electric Work, Premises Wiring; and FAA Order 6950.22, Maintenance of Electrical Power and Control Cables.

3.3.1.3 Grounding

The requirements in this section only apply to newly installed equipment.

[SMR4-IRD105] All equipment must adhere to FAA-STD-019E, Lightning and Surge Protection, Grounding, Bonding and Shielding Requirements for Facilities and Equipment.

[SMR4-IRD106] All network equipment must adhere to Institute of Electrical and Electronics Engineers (IEEE) Standard 1100-2005, Recommended Practice for Powering and Grounding Electrical Equipment.

3.3.1.4 Fasteners

[SMR4-IRD107] Fasteners must be in accordance with FAA-G-2100J, Section 3.2.1.2.3.

3.3.1.5 Electromagnetic Compatibility

[SMR4-IRD108] Electromagnetic emission and susceptibility of the equipment must be in accordance with 47 CFR Part 15, Code of Federal Regulations, Title 47, Telecommunication, Part 15, Radio Frequency Devices, for Class A digital devices, peripherals, and external switching power supplies.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

4 Quality Assurance Provisions Test and Evaluation will be in accordance with the following documents:

• AMS Test and Evaluation Process Guidelines

• Test and Evaluation (T&E) Handbook VVSPT-A2-PDD-013

• FAA William J. Hughes Technical Center Test and Evaluation Policy Order NG 1810.8A

4.1 Responsibility for Verification

The FAA is responsible for developing and implementing the verification of requirements for each project. The FAA may delegate verification activities to other FAA organizations, independent contractors, and/or the major prime contractor.

4.2 Special Verification Requirements

There are no special verification requirements.

4.3 Verification Requirements Traceability Matrix

Appendix C contains the VRTM which provides verification methods, how each requirement is to be verified and at what stage the verification will occur.

5 Preparation for Delivery This Section is not applicable for this IRD.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

6 Notes

6.1 Glossary

Definitions provided in the Glossary are considered part of the requirements in which the associated term is used.

Term Definition

ASTERIX Data Block Unit of information seen by the application as a discrete entity by its contents. A Data Block contains one or more Record(s) containing data of the same Category.

ASTERIX Data Category Classification of the data in order to permit inter alia (among other things) an easy identification.

ASTERIX Record A collection of transmitted Data Fields of the same Category preceded by a Field Specification field, signaling the presence/absence of the various Data Fields.

Closed Region

A Surface Surveillance System initiated region that indicates the defined area is closed for Target Reporting. Closed region messages sent to the SMR4 include region ID, add or remove designator, number of points, and up to 50 polygon points.

Compulsory The field must be provided unless there is an exception noted in the Data Item details. The Surface Surveillance System uses these fields and must correctly record and parse them.

Compulsory if Available The field must be provided when data is available. The Surface Surveillance System may or may not use these fields but must correctly record and parse them.

CRC32 The CRC32 algorithm generates a unique 32-bit checksum for a given set of data, allowing quick detection of accidental changes or errors in the data.

Data Field Physical implementation for the purpose of communication of Data Item(s), it is associated with a unique Field Reference Number. Refer to EUROCONTROL Part 1, ASTERIX, Section 3.1.4

Data Item The smallest unit of information in each Data Category.

Data Stream Specific sub-message types of ASTERIX data types.

Data Source Identifier An FRN containing the adaptable SIC/SAC of the source of the message.

Data Unit A Presentation Layer element that serves the following functions:

• Delimit application elements or to aggregate for transmission elements of like type.

• Identify application elements.

• Provide error detection of the application elements that may occur in transmission between the SMR4 and the Surface Surveillance System.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Term Definition

Field Reference Number

(FRN)

The number assigned Data Item that indicates an item’s location in the

UAP.

Field Specification (FSPEC) A table of contents, in the form of a bit sequence, where every individual bit signals the presence (i.e., bit set to one) or absence (i.e., bit set to zero) of a well-defined Data Field assigned to it.

Local Geographical North The term “local geographical north” as used in the ASTERIX EUROCONTROL documents is defined as True North.

Not Used The system cannot currently provide the Data Item or will not provide.

Receipt of these fields does not make the ASTERIX Record invalid.

Optional The system may be capable of producing Data Item but controlled by adaptation. When enabled, the system must provide the Data Item when data is available. When disabled, the system does not provide the Data Item. The system may or may not use these fields but must correctly record and parse them.

Service Message A message that conveys data describing the current state of the originating system. May include antenna position, system identification, system equipment status, fault or error conditions, etc.

Surveillance Data Data containing information comprising any combination of targets, system status, service messages, system control commands, or any other data element that might be transferred between the equipment.

Surveillance Data Latency The difference between time of receipt of the Data Unit and Time of Day in the ASTERIX Record.

Target Report A message that conveys information related to a surveillance detection of an object, typically aloft (e.g., a target report would indicate a radar has detected an aircraft).

User Application Profile

(UAP)

The mechanism for assigning Data Items to Data Fields and containing all necessary information which needs to be standardized for the successful encoding and decoding of the messages.

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

6.2 Abbreviations and Acronyms

Acronym Term

3SR ASDE-3 Surface Movement Radar (SMR) Replacement

AAA Authentication, Authorization, and Auditing

ANSI American National Standards Institute

ARP Address Resolution Protocol

ASDE-X Airport Surface Detection Equipment, Model X

ASSC Airport Surface Surveillance Capability

ASTERIX All Purpose STructured Eurocontrol suRveillance Information eXchange

AWG American Wire Gauge

CDRL Contract Data Requirements List

CRC Cyclic Redundancy Check

DT Developmental Test

EIA Electronic Industries Alliance

FAA Federal Aviation Administration

FRN Field Reference Number

FSPEC Field Specification

FX Field Extension

ICD Interface Control Document

ICMPv6 Internet Control Message Protocol for the Internet Protocol Version 6 Specification

IEC International Electrotechnical Commission

IEEE Institute of Electrical and Electronics Engineers

IETF Internet Engineering Task Force

IP Internet Protocol

IPDT In-Plant Development Test

IPv4 Internet Protocol Version 4

IPv6 Internet Protocol Version 6

IRD Interface Requirements Document

ISO International Standards Organization

LAN Local Area Network

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

LEN Length Indicator

LSB Least Significant Bit

MB Message, Comm B

Mode S Mode Select or Mode Select Beacon System Sensor

NAS National Airspace System

NEC National Electrical Code

NFPA National Fire Protection Association

NOGO No Go

OSDT On-Site Development Test

OSI Open Systems Interconnection

PIM Protocol Independent Multicast

PIM-SM Protocol Independent Multicast – Sparse Mode

RADIUS Remote Authentication Dial-In User Service

RFC Request for Comment

SAC System Area Code

SAT Site Acceptance Testing

SIC System Identification Code

SMR4 Surface Movement Radar, Model 4

SSD System Specification Document

SSS Surface Surveillance System

STD Standard

TCP Transmission Control Protocol

TIA Telecommunications Industry Association

UAP User Application Profile

UDP User Data Protocol

UTC Coordinated Universal Time

UTP Unshielded Twisted Pair

VRTM Verification Requirements Traceability Matrix

WJHTC William J. Hughes Technical Center

[ANG-B13 to Insert Baseline Date Here] Section J, Attachment J-4

Appendix A – General ASTERIX Message Formats

A.1 Message Structure The ASTERIX Data Block contains the ASTERIX Data Category (Cat) and Length Indicator (LEN) fields and one or more ASTERIX records (FSPEC and the specified Field Reference Numbers (FRN)) of the same Report type (e.g., Radar Target Report).

A.1.1 General The application data to be transferred consists of an ASTERIX Data Block which includes:

(1) A one-Byte field (Cat) indicating the Data Category for records in…

This is the start of the file's text. The full file is on GovTribe.

File details come from the government source that posted it. Updated .