Exhibit_5_Planned_Systems_to_Consolidate.pdf

PDF 4 MB Posted

Attached to
TFITS Consolidated Systems Integrator (TCSI) Federal contract opportunity
Solicitation number
M67854-14-R-4802
Issued by
United States Marine Corps

About this file

14-R-4802 Exhibit 5

View the file

Other files for this federal contract opportunity

Other files attached to TFITS Consolidated Systems Integrator (TCSI), newest first.
File Type Posted
RFP_M67854-17-R-7802_Amend_00001.docx DOCX document
M67854-14-R-4802_Amend_01.doc DOC document
Exhibit_8_The_SUPPLEMENT_TO_GUIDEBOOK_for_Acquisition_of_Naval_Intensive_Systems_Amend_0001.PDF PDF
M67854-14-R-4802_conformed_Amend_01.doc DOC document
Exhibit_2a__TRAP_Transition_PWS_Amend_0001.docx DOCX document
Exhibit_9_The_Marine_Corps_Systems_Command_Technical_Review_Handbook_Amend_0001.pdf PDF
Attachment_4a__Post_Award_Orientation_and_Planning_PWS_Amend_0001.docx DOCX document
Exhibit_10__Industry_Questions_and_Answers_Amend_0001.xlsx XLSX spreadsheet
Attachment_1_SI_Consolidation_PWS_Amend_0001.docx DOCX document
Exhibit_4d_TRAP_RTM.xls XLS spreadsheet
Exhibit_2c__TRAP_Software_Development_PWS_Amend_0001.docx DOCX document
Exhibit_2b__TRAP_PDSS_PWS_Amend_0001.docx DOCX document
Attachment_7_DD254__Amend_0001.pdf PDF
Attachment_7_DD254_draft_M14-R-4802_Updated.pdf PDF
Attachment_3_TFITS_SI_Overarching_Quality_Assurance_Surveillance_Plan_(QASP)x.docx DOCX document
M67854-14-R-4802_RFP.pdf PDF
Exhibit3f_TFITS_STES.pdf PDF
Exhibit4b_TRAP_Contingency_Plan.docx DOCX document
Exhibit_2c__TRAP_Software_Development_PWS_Final_.docx DOCX document
Attachment_4a_Enclosure_1_DD_2875_SAAR_MC_MCCDC_MCBQ.pdf PDF
Exhibit_3c_TFITS_Performance_Measurement_Plan.pdf PDF
Exhibit_3e_TFITS_Risk_Management_Plan.pdf PDF
Exhibit_3a_TFITS_SEP.pdf PDF
Exhibit_3b_TFITS_CMP.pdf PDF
Attachment_4a_Enclosre_2_LName_FName_Combined_SAAR_9_Sept_2013.pdf PDF
Exhibit_2b__TRAP_PDSS_PWS_Final_.docx DOCX document
Exhibit_2a__TRAP_Transition_PWS_Final_.docx DOCX document
Exhibit_1_Navy_Small_Business_Subcontracting_Plan_Goals.pdf PDF
Attachment_4a__Post_Award_Orientation_and_Planning_PWS_Final.docx DOCX document
Attachment__7_DD254_draft.pdf PDF
Exhibit_7-_Past_Performance_Questionnaire.docx DOCX document
Exhibit_4c_TRAP_SLA.docx DOCX document
Exhibit_3d_TFITS_Requirements_Management_Plan.pdf PDF
Exhibit_6-_Past_Performance_Statement.docx DOCX document
Attachment_1_SI_Consolidation_PWS_Final_.docx DOCX document
Exhibit_4a_TRAP_CITDB.xlsx XLSX spreadsheet
Show all 36

On GovTribe

Work with this file on GovTribe

  • Download the original file
  • Contacts named in this file
  • Similar government files
  • Ask GovTribe AI about this file

Text version

DISTRIBUTION STATEMENT A. Approved for public release.

Reserve Transition and Manpower

Management System

(RTAMMS)

System Description

• Web Based, Mission Assurance Category III System consisting of (3) main modules supporting the Marine

Corps Reserve community:

– Drill Management Module (DMM) automates the allocation, scheduling, and mustering of drills

– Marine Corps Medical Entitlements Data System (MCMEDS) module supports the electronic generation, processing, and tracking of Line of Duty (LOD) determinations and Medical Hold

(MEDHOLD) determinations for injuries that may occur during a drill period or while on Active Duty.

– Inventory Development and Management System (IDMS) module provides inventory management, needs identification and forecasting, prioritization and sourcing, and special population/program management for improved decision support

System Description (cont’d)

• DMM began fielding in March of 2010 and was fully fielded in March of 2011.

• MCMEDS integration began in April of 2011 and was completed in May of 2012.

• IDMS development and integration began in November of 2011 and completed in the spring of 2013.

System Technology

• RTAMMS is written using the Java programming language through the Java Development Kit (JDK) using object oriented techniques.

• Software (Applications)

– JBOSS 6.0

– Redhat 5.4

– IBM Cognos 8 Business Intelligence (BI) Administrator

– IBM Cognos 8 Business Intelligence (BI) Professional Author

• RTAMMS is integrated into the Manpower Information Portal (MIP) and the Manpower Information Technology (MIT) Data Center. The

MIP and MIT Data Center support includes access control, common database, date storage and backups, physical security, and network connectivity

• RTAMMS operates on the Marine Corps Enterprise Network (MCEN) and the Marine Corps Base G-6 Service Network.

Planned RTAMMS Architecture Diagram

RTAMMS System Interface Data Flow Diagram

RTAMMS

Production

Operational Data

Store Enterprise

(ODSE)

Marine Corps Total

Force System

(MCTFS)

Total Force Retention System (TFRS)

TFRS is a web-centric workflow application, which supports the reenlistment and lateral move of Reserve and Active Duty enlisted Marines. There are approximately 800 Career Planners (CP) located throughout the Marine Corps, including Hawaii and overseas locations. TFRS allows the CPS to initiate requests for reenlistment to Headquarters, U.S. Marine Corps (HQMC) for reviewing, routing, approval or disapproval. Once HQMC has made their final decision, the request is returned to the CRS for action.

Total Force Retention System (TFRS) OV1

Marsh Center, MCB Quantico

HQMC,

Reserve

Affairs

HQMC,

Enlisted

Assignments

LAN

Reserve CRS

Active Duty CRS http://images.onesite.com/pigpen.933flz.com/user/firehawkv8/usmc2.jpg

System Description

• Web Based, Mission Assurance Category 3, TFRS is used for the creation, processing, tracking and execution of Reenlistment, Extensions, and Lateral Move

(RELM) requests. This application supports both the

Active duty and Reserve forces.

• TFRS is a fielded system and is in the Post Deployment

Software Support (PDSS) lifecycle phase.

• Over 1000 users who input, review, dispose, and manage information needed to retain (reenlist or extend) or reclassify (lateral move) Marines into different career fields.

System Technology

• Backend database instances are Oracle 11G.

• Presentation layer on application server is .NET

Framework 4.0.

• dotConnect for Oracle, EasyQuery .NET, WebForms .

• All server instances run on Windows Server 2008 r2, 64bit.

System Diagram

Paperless Acquisitions

(SPS, WAWF, EDA, FPDS)

Operational View

System Interface View

Interfaces

Joint Force Requirements Generator II

(JFRG II)

System Description

• Computer based client application that consists of a stand-alone database and application particular software. The software was designed to enable

Operating Forces to import, create, manipulate and export Operational Force Deployment and Sustainment

Requirements as well as to produce ad-hoc and predefined reports.

System Description (cont’d)

• Interfacing systems:

– Joint Operational Planning and Execution System (JOPES). The

Joint repository for Operational Force Requirements. JFRG II imports Force Requirement information from JOPES and exports

Unit Move and wholesale sustainment information to JOPES.

– Unit Move Deployment Support Systems. (MDSS II/TC-AIMS II).

Logistical systems used to assign unit personnel, equipment and supplies to the operational requirements provided by JFRG

II.

– Sustainment Support Systems (War Reserve System). Logistical system operated by Marine Corps Logistics Command that calculates and plans for wholesale sustainment requirements in support of Operational requirements provided by JFRG II

• Supports approximately 400 users

• Originally fielded in 1991 under the name MAGTF II

System Technology

• JFRG II consists of the following components:

– Unique software components developed using PowerBuilder software development tool

– SyBase SQL Anywhere (Database)

– Shazam! (Ad-hoc report generation tool)

– DynaZip (Compression Utility)

– Adobe RoboHelp (Help Files)

– NullSoft Scriptable Install Software (Packaging)

• Software is distributed as an application as part of the

Joint Tactical Common Operational Picture (COP) workstation or via individual CD.

JFRG II Interface Data Flow Diagram

JOPES

DB

TPFDD

Management

Tool

JFRG II

MDSS II

TC-AIMS II

WRS

Deployment

Support

Wholesale Sustainment

Manpower Management Support Branch (MMSB)

Family of Systems (FoS):

Optical Digital Imaging-Records Management

System (ODI-RMS)

Performance Evaluation System (PES)

Automated Performance Evaluation System (APES)

Mr. Lawrence Quirindongo

Project Manager

System Description

• The Manpower Management Support Branch (MMSB)

Family of Systems (FoS) consist of Web and Client

Based applications which support HQ Marine Corps, Manpower and Reserve Affairs (M&RA), MMSB objectives.

– Automated Performance Evaluation System (APES): APES provides for periodic reporting, recording, and analysis of the performance and professional character of Marines in the grades of Sergeant through Major General. Its fundamental concepts are accuracy, accountability, simplicity, and consistency of policy and evaluation methods. APES supports the centralized selection, promotion, and retention of the most qualified Marines of the Active and Reserve Components of the USMC. APES is

Mission Assurance Category (MAC) III and was fully fielded

07/01/2002.

System Description (cont’d)

– Performance Evaluation System (PES): PES is used by HQMC

M&RA personnel to process client based fitness reports that must be submitted manually. PES also serves as a pass through and quality checkpoint for fitness reports that are submitted via

APES into ODI-RMS. PES is Mission Assurance Category (MAC)

III and was fully fielded 01/27/1999.

– Optical Digital Imaging-Records Management System (ODI-RMS):

ODI-RMS provides HQMC, M&RA, MMSB personnel a means for storing, requesting, viewing, correcting, retiring, and loaning

Official Military Personnel Files (OMPFs). OMPFs contain performance, administrative, and award information on each

Marine. ODI-RMS is Mission Assurance Category (MAC) II and was fully fielded 01/1/1998.

System Technology

• ODI-RMS and PES use PowerBuilder as a software platform and operate on the Marine Corps Enterprise

Network (MCEN)

• APES is written in JAVA and hosted at Defense

Information Systems Agency (DISA), St Louis, MO

• Software (Applications)

– GNU Project 8.71 – ImageMagic Studio LLC 6.6.6.2 Q16

– Microsoft O/S 2008R1 – Oracle12.1.1

– Red hat Enterprise 5.8 – VMware 3.5.0

– Jspell1.3 – Jspell1.3

– I text Software Corp 1.3 – The Eclipse Foundation Juno

– Apache3 – Software Sonar

– Oracle db. 11.2.0.3 – Sun O/S 8,9,10 & 11

– Sybase 9.0.3 – OCR Engine 5.2

MMSB FoS Architecture Diagram

MM`SB A

APES System Interface Data Flow Diagram

PES System Interface Data Flow Diagram

HQMC, Manpower & Reserve Affairs (M&RA)

Individual Marine

Performance Ev aluation Sy stem (PES)

Operational Data Store Enterprise (ODSE)

Performance Ev aluation Sy stem (PES) Windows

FrontEnd (WinFE)

Manpower Information (MI) Portal

Optical Digital Imaging - Records Management

Sy stem (ODI-RMS)

Of f icial Military Personnel File

- Online (OMPF-Online)

Automated Performance Ev aluation Sy stem (APES)

PES SV-2 (SV-02 Systems

Resource Flow Description

(DM2))

System Architect

Wednesday, September

POP

Unclassif ied

POP

Unclassif ied

Sy stem Entity

Marine Corps Internal Perf ormer

DRAFT

Performance Ev aluation Sy stem (PES) SV-2

WinFE - PES

Data

Manual

PES - MI Portal

Data

HTTPS

IETF RFC 2616

IETF RFC 4346

PES - OMPF Online

Data

HTTPS

IETF RFC 2616

IETF RFC 4346

PES - ODI-RMS

Data

HTTPS

IETF RFC 2616

IETF RFC 4346

ODSE - PES

Data

HTTPS

IETF RFC 2616

IETF RFC 4346

PES - APES

Text / Imag e

VPN

IETF RFC 4364

APES - PES

Text / Imag e

VPN

IETF RFC 4364

ODI-RMS System Interface Data Flow Diagram

HQMC, Manpower & Reserve Affairs (M&RA)

Department of Defense (DoD)

USMC Installation Personnel Administration Center (IPAC)

*Individual Marine

Optical Digital Imaging - Records Management

System (ODI-RMS)

Document Scanner

Web Browser (IPAC)

Web Browser (Individual Marine)

Performance Evaluation System (PES)

Official Military Personnel File

- Online (OMPF-Online)

Defense Personnel Records Information Retrieval System

(DPRIS)

electronic Military Records System (eMilRecs)

ODI-RMS SV-2 (SV-02

Systems Resource Flow

Description (DM2))

System Architect

Wednesday, September

POP

Unclassified

POP

Unclassified

POP

Unclassified

POP

Unclassified

* Certain situations may require that record updates be submitted by an Individual Marine's Family Member.

Marine Corps External Performer

Marine Corps Internal Performer

System Entity

Optical Digital Imaging - Records Management System (ODI-RMS) SV-2

DRAFT

OMPF - O DI-RMS

Data / Graphic

HTTPS

IETF RFC 2616

IETF RFC 4346

IPAC Scanner - ODI-RMS

Graphic

SMTP

IETF RFC 2821

IPAC Web Browser - O DI-RMS

Data / Graphic

HTTPS

IETF RFC 4346

Marine Web Browser - ODI-RMS

Data / Graphic

HTTPS

IETF RFC 4346

eMILRecs - O DI-RMS

Data

TCP/IP

IETF Standard 7 / RFC 793

ODI-RMS - eMILRecs

Data

TCP/IP

IETF Standard 7 / RFC 793

ODI-RMS - DPRIS

Graphic

VPN

IETF RFC 4364

ODI-RMS - O MPF

Data / Graphic

HTTPS

IETF RFC 2616

IETF RFC 4346

PES - ODI-RMS

Data / Graphic

HTTPS

IETF RFC 2616

IETF RFC 4346

Radio Frequency Identification

(RFID)

RFID Overview (DoD RFID OV-1)

RFID Total Asset Visibility

31 17 May 2012

RFID Suite of Technology

• Bar coding

• Radio Frequency ID (RFID) Tags

• Contact Memory Buttons

• Satellite Tracking

• RFID Software (middleware)

• RFID Readers (interrogators)

• RFID Portals (light stacks, motion systems)

RFID Interfaces

Radio Frequency In-Transit

Visibility Server (RF-ITV)

Interrogator

LAN

MCEITS

Server

(Kansas City)

National

RF ITV

Server

(Army)

SAVI Site

Manager aRFID Architecture:

http://www.google.com/aclk?sa=l&ai=CFMu2uXzIUZeFK8mh6QGBjoGYB9Hg5o4D2ZODxmTpjuimrgEIBhADKAhQ9tvMgvz_____AWDJtrCKpKSIEaAB4o2z_wPIAQeqBCVP0JhEz1nJR7e22qhHl128MUJD2tDsIZhKbQtc2DCPIE_zjMUAwAUFoAYmgAeG8kzgEq3Q1_2Z_r-uFw&sig=AOD64_15xVeLZnQ5tUDXNu9-0QhkOECNPg&ctype=5&ved=0CMUBEPMO&adurl=http://www.newegg.com/Product/Product.aspx?Item=N82E16859106336&nm_mc=KNC-GoogleAdwords&cm_mmc=KNC-GoogleAdwords-_-pla-_-Server/Workstation+Systems-_-N82E16859106336 http://www.google.com/aclk?sa=l&ai=CFMu2uXzIUZeFK8mh6QGBjoGYB9Hg5o4D2ZODxmTpjuimrgEIBhADKAhQ9tvMgvz_____AWDJtrCKpKSIEaAB4o2z_wPIAQeqBCVP0JhEz1nJR7e22qhHl128MUJD2tDsIZhKbQtc2DCPIE_zjMUAwAUFoAYmgAeG8kzgEq3Q1_2Z_r-uFw&sig=AOD64_15xVeLZnQ5tUDXNu9-0QhkOECNPg&ctype=5&ved=0CMUBEPMO&adurl=http://www.newegg.com/Product/Product.aspx?Item=N82E16859106336&nm_mc=KNC-GoogleAdwords&cm_mmc=KNC-GoogleAdwords-_-pla-_-Server/Workstation+Systems-_-N82E16859106336

Installed Reader

Reader

LAN Jack

Power

Benefits of the aRFID

Infrastructure - (ITV)

USMC Interrogator

Locations

(WEST COAST / 25)

MCLB Barstow, CA (2)

MCB Camp Pendleton, CA (8)

MCAS Miramar, CA (8)

March ARB, CA (1)

MC 29 Palms, CA (3)

MCAS Yuma, AZ (3)

(OCONUS / 25)

MCAS Kaneohe, HI (5)

MCAS Iwakuni, Japan (1)

MCB Okinawa, Japan (19)

(EAST COAST / 25)

MCAS Cherry Point, NC (4)

MCB Camp Lejeune, NC (11)

MCAS New River (1)

MCAS Beaufort, SC (3)

MCLB Albany, GA (3)

MCLB Blount Island, FL (1)

Camp Johnson (1)

Newport News (1)

There are currently over 2700 Fixed Interrogator installed and in use by the DoD World-Wide including 75 Fixed Interrogators installed USMC-Wide (50 CONUS / 25 OCONUS)

& 13 Reserve Site identified for installation

Secure Personnel Accountability

(SPA)

Mr. Danny Franco

SPA

High Level Operational Concept Graphic (OV-1)

6 Feb 2013 38

System Description

• Web Based, Mission Assurance Category II, Classified family of applications used across the Marine Corps for in-theater personnel accountability reporting that feeds

Joint Staff and DoD systems via web services.

• Fielded in 2008

• Over 400 users who provide daily updates to personnel accountability and allows Commanders to track and report near real time geo location and troop strength

• Program was initiated in 2007 under a Mission Need

Statement

System Technology

• Backend database instances are MS SQL Server 2008.

• Presentation layer on application server is .NET.

• Web services are SSL SOAP

• SQL Server Reporting Services provide reporting capability.

• All server instances run on Windows Server 2008 r2, 64bit.

• Application server also hosts the Web Based Training modules.

System Diagram

(SIPR)

Web-Based Manpower Assignment Support

System (WebMASS)

Mr. Danny Franco

WebMASS High Level Operational Concept Graphic (OV-1)

6 Feb 2013 43

System Description

• Web Based, Mission Assurance Category III, Sensitive application used by Manpower and Reserve Affairs for personnel assignment management.

• Fielded in 1995 as Manpower Assigment Support System

(MASS).

• Client-server version of MASS fielded in 2000

• The client-server version of MASS replaced by

WebMASS in 2005

• Over 300 users who manage assignments for over

180,000 active and active reserve Marines.

System Technology

• Backend database instances are Oracle.

• Middleware is .NET.

• Presentation layer on application server is .NET.

• Web and application server instances run on Windows

Server 2008 r2, 64bit.

• DB Server runs on Redhat Linux.

• Application server also hosts the Web Based Training modules.

Overview

• WebMASS System Architecture:

– 6 Servers:

• 4 for redundant web and app tiers

• 2 for Oracle 11g RAC

– Provides fully redundant, failover capacity

– Provides scalability

– Provides near 24X7 availability

Marine Corps Mobilization Assignment

System (MMAS)

Ms. Heather Leith

System Description

• Track, process Active/Reserve Component and retired Marines from the time they are issued orders to their arrival at the Initial

Deployment Processing Center (IDPC)

• Web Based, MAC III System consisting of (5) main modules supporting the Manpower and Reserve Affairs (M&RA) department:

– Manpower Requirement Tracking Module (MRTM) - Allows commands to enter manpower requests and provides the ability to track the processing of a request throughout its lifetime. The MRTM is designed to provide a tracking service for active duty and reservist requirements.

The tracking lifetime of an active duty requirement is from inception to designation as being related to active duty. Whereas, the tracking lifetime of a reservist requirement is from inception to the creation of orders, thus providing the ability to trace the requirement throughout the entire process.

System Description (cont’d)

– Individual Augmentation Management Module (IAMM) - Implemented as a result of the fiscal cap instituted on spending. Commands are allocated a share of the cap. As such, IAMM was implemented as a way to manage the individual needs identified by the commands. It provides a centralized database to manage all of the various needs.

– Processing Module (PM) - Used to capture, store, and retrieve information on each mobilized reservist and retired Marine from the time the Marine reports for duty through the time the Marine has completed processing at the DPC and is joined at the gaining command.

This module is also used to capture, store, and retrieve information during demobilization.

– Sourcing Module (SM) - Allows for the sourcing of manpower requirements to provide the Marine forces with the appropriate strength in support of the operational tempo. Daily augmentation sourcing activities are performed at HQMC. Three major activities are undertaken at the HQMC.

System Description (cont’d)

– Sourcing Module (SM) – cont’d

These functions are critical elements requiring visibility both at the HQMC and at the gaining force commands:

• Management of requirement sourcing, including tasking subordinate commands to provide manpower to identified requirement.

• Obtaining approval from the Assistant Secretary of Navy for member mobilization.

• Management of orders for mobilization, extension and early demobilization.

This module satisfies the need for automated data collection and dissemination for these three activities and the primary functions of

HQMC.

– Billet Advertising Module (BAM) - Allows reservists to search and apply for billet vacancies within the USMC. The module also allows USMC reviewers to administrate actions for interested applicants.

• All of these Modules are currently fielded in production.

System Description (cont’d)

• Two additional modules currently in development.

– Budget Forecasting Module

– Budget Tracking Module

These modules will automate the calculation and submission for each MARFOR requiring tracking of current requirements and semi-annual budget forecasting. The inclusion of these modules will reduce manpower currently spent on managing the budget, enabling MMFA personnel to focus on meeting the demands of

Individual Augments.

System Technology

• MMAS is written using the C# programming language using the Microsoft ASP.NET framework and is linked to a SQL database.

– MMAS Software (Applications):

• Microsoft Windows Server 2008

• Internet Information Services (IIS) 7.5

• ASP.NET 4.0

• Microsoft SQL Server 2008 R2

• Tumblweed 4.11 CAC Authentication

– MMAS Interfaces:

• ODSE: Retrieves Personnel and lookup table data

• MROWS: MMAS Orders are exported to MROWS

• ARTI: Requirement transfer from/to the US Navy

System Technology (cont’d)

• MMAS is integrated into the Manpower Information

Portal (MIP) and the Manpower Information Technology

(MIT) Data Center. The MIP and MIT Data Center support includes access control, common database, date storage and backups, physical security, and network connectivity.

• MMAS operates on the Marine Corps Enterprise Network

(MCEN) and the Marine Corps Base G-6 Service Network.

• Future MCEITS migration is planned.

MMAS Architecture Diagram

Manpower Models (MODELS)

Total Force Data Warehouse (TFDW)

Mr. Michael Wright

TFDW

Total Force Data Warehouse

Total Force Data Warehouse (TFDW) 4.0.3.0

• USMC system of record for historical manpower data and contains 37+ years of USMC pay and personnel data.

• Authoritative data source for USMC reported active duty end strength per the U.S. Code, Title 10.

• Provides a uniform structure for historical information used in forecasting manpower related issues (attrition, retention, continuation, and promotion) and ad hoc queries to answer data calls.

• Offers historical pay data used in formulating the military pay budget estimate submission.

• Provides tools for budget planners to develop and submit the USMC Program Objective Memorandum (POM) and budget estimate submission supporting Justification Books (JBooks) for NavCompt, OSD and the President's Budgets.

• Supports HQMC agencies such as Manpower & Reserve Affairs (M&RA) and Programs and Resources (P&R), used for internal analysis or to respond to external data calls from DOD, OSD, and Congress.

Mainframe Sources Client Server Sources Web Sources

TFDW

OLAP Cubes TFDW-Web Cognos BI, TM1

Client/Server Reporting and Analysis

Direct Cube Access

Direct Client Server Access

Cognos BI, TM1, SAS, SAS Enterprise Miner, Oracle SQL Plus

TFDW System View

& Info

Interfaces: MODELS, MCRISS, MCTIMS, ODSE, TFSMS, WebMASS (TFDW pulls from each interface).

Userbase: 200 users.

Database size: 2TB.

Hardware: Web/App servers for Dev, Test, and Prod are virtualized. All database servers are physical.

Software: Oracle 11gR2, IBM Cognos BI and TM1, RHEL 5, Windows Server 2008, VMWare, NetApp SAN, SAS, SQL Plus, Pervasive Data Junction ETL (Extract, Transform, Load), Micro Focus Star Team (Conf

Mgmt) and Caliber (Reqt Mgmt), HP Quality Center. *No custom code; ONLY configured COTS SW.

Hosted: Staging-Test-Production; James Wesley Marsh Center, Quantico VA. Development; vendor site.

Future: MCEITS transition begins Jul 2014; finished by Jan 2015.

Accreditation: Authority to Operate (ATO) valid through Feb 2015 (inclusive of all environments).

Development Env

MODELS

MODELS 1.0.8.0

• Provides decision support tools necessary for force structure and manpower scenario development on a daily basis throughout the Human Resources Development Processes (HRDP).

• MODELS elements provide decision makers with operational tools as well as the automated ability to view an array of force structure and manpower data sets in various ways.

• Forecasting and simulation capabilities are used to develop and present alternative courses of action, and to analyze impacts before decisions are made.

• Server/Algorithm language is Fortran 2003/2008

• Client language is C++

*Models and supported divisions within M&RA *MODELS System View

MODELS System

View & Info

Interfaces: MCTIMS (pull), ODSE (pull), WebMASS (push/pull), TFDW (push), TFSMS (manual pull).

Userbase: 25 max; located within the James Wesley Marsh Center, Quantico VA.

Database size: 250GB.

Hardware: 3 virtualized servers hosted on M&RA provided hardware.

Software: Windows Server 2008, Oracle 11gR2, Numara Footprints (Config Mgmt).

Hosted: James Wesley Marsh Center, Quantico VA.

Future: MCEITS migration is loosely scheduled for FY15.

Accreditation: Authority to Operate (ATO) valid through Sept 2014.

Total Force Structure Division (TFSD)

Total Force Structure Management System (TFSMS)

HQMC Manpower & Reserve Affairs (M&RA)

Manpower MODELS

Unit Diary / Marine Integrated Personnel System

(UD / MIPS)

Operational Data Store Enterprise (ODSE)

Web-enabled Manpower Assignment Support System

(WebMASS)

Total Force Data Warehouse

(TFDW)

Training and Education Command (TECOM)

Marine Corps Training Information Management

System (MCTIMS)

TFSMS – MODELS

Data Manual

MODELS – UD/MIPS

Data Manual

MCTIMS – MODELS

Data TCP/IP

IETF Standard 9

/RFC 959

ODSE – MODELS

Data TCP/IP

IETF Standard 9

/RFC 959

TFDW – MODELS

Data TCP/IP

IETF Standard 9

/RFC 959

MODELS – TFDW

Data Manual

MODELS – WebMASS Data Manual

MODELS SV-2 (SV-02 Systems Resource Flow Description [DM2]) System Architect

Thursday, August 09, 2012

Solid lines indicate an automated Data Exchange.

Dashed lines indicate a manual Data Exchange.

Marine Corps Internal Performer

System Entity

*Interface from MODELS to TFDW exists as-is, but is not currently utilized.

Total Force Structure Management System

(TFSMS)

Ms. Sheri Stefaniga

TFSMS Project Manager

Family of Systems Description

• Mission of Total Force Structure Management System

(TFSMS) Proper

– Provide integrated, accurate, synchronized, and timely force structure information by integrating force structure process participants in support of the Commandant’s Title 10 responsibilities to “organize, equip and train” forces in response to national military objectives providing the President/Secretary of Defense and combatant commanders with Marine Forces that are ready and sustainable over time.

• Mission of Marine Corps Global Force Management

Organization Servers (MCOS)

– Provide a method to standardize force structure representation, making it visible, accessible, and understandable across DOD and enabling electronic manipulation across multiple disparate systems. Based on the DOD policy, force structure is the central theme for integrating data within DOD.

Family of Systems Description (cont’d)

• Characteristics

– ACAT III Program; currently past MS C; MCOTEA oversight

– Enterprise system combining manpower and equipment data for managing the Total Force

– Primarily used in garrison with global accessibility for deployed forces

– COTS application consist of the Oracle Applications Suite, a

Decision Support System, a data-modeling tool, and a workflow application and Cognos for reporting

– High availability design uses hardware redundancy, failover, and clustering

– Migrating to the MCEITS hosting environment

– Web services provide TFSMS and GFM data to authorized users

System Technology

• TFSMS is a COTS solution; primarily based on Oracle’s

E-Business Suite and IBM’s Cognos.

• Software Applications Leveraged:

– JBoss Enterprise Application Platform with Management

– Red Hat Enterprise Linux AS

– EMC NetWorker Server

– EMC NetWorker Client

– IBM Cognos Business Intelligence User

– Oracle Enterprise 11g Database

– Oracle RAC

– Oracle WebLogic Suite

– Oracle Access Manager/ Identity Manager

– Oracle EBS (iSupport) (retiring)

– Oracle EBS (HR)

– Oracle EBS Self-Service HR

System Technology (cont’d)

• Software Applications Leveraged: (cont’d)

– Vmware, vSphere 5 Enterprise Plus

– Vmware, vSphere Client

– Vmware, vCenter Server

– Windows Server 2008 Standard Edition

• Currently transitioning to a Remedy based Help Desk.

System Architecture Production Environment

F5 F5

AS11g

MID

OAM

AS11g

OID

App

Linux / Oracle RAC

Transactional DB

Infra DB

External Users

RH Linux 5

Reporting DB

(MV)

GFM

NIPR DB

GFM

SIPR DB

RH Linux AS5

Oracle 11g

RH Linux 5

Oracle 11g

Oracle EBS R12

RH Linux AS5

Oracle 11g

RH Linux 5

Oracle 11g

RH Linux 5

Oracle 11g

RH Linux 5

Oracle EBS R12

Mid Mid

Web

Cache

Mid Mid

Web

Cache WEBP

WEBP

PPSP

TRANSP

RH Linux 5

RH Linux 5

JBOSS v5

RNP

W2K8

RH Linux 5

Cognos v10

W2K8

IIS

APM

OMS

RH Linux 5

DSS

RH Linux 5

Oracle 11g

EMC SAN

Reporting GFM-NIPR GFM-SIPR Oracle Authentication & E-Business Suite Admin

AS11g

Web Cache

Virtual Legend:

NIPR 4 Server ESX Cluster

Backup

Server

Tape Drive

SIPR 1 Server ESX

RH Linux 5

All NIPR virtual servers reside on 4 server

ESX cluster

All SIPR virtual servers reside on 1

ESX Server

Tape Drive

Physical vCenter

Win2K8

Oracle managed by

TFSMS

MCOS

(NIPRNet)

MCOS

(SIPRNet)

Web Services

GIG

TFSMS & MCOS System

Interface Data Flow Diagram

TFSMS

(Published)

Automated

Recurring Load

TFSD -

TFSMS Management

>14K TFSMS Users

SIPRNet

OSMT

Global Combat Support System

- Marine Corps (GCSS-MC)

Defense Readiness Reporting

System – Marine Corps

(DRRS-MC)

Marine Corps Logistics

Command (MCLC) Systems

Marine Corps Systems

Command (MCSC) Systems

Manpower and Reserve

Affairs (M&RA) Systems

Headquarters Marine Corps

(HQMC) Systems

20+

Interfaces

NIPRNet

OSMT

GFMIEDM

GFM-DI / MCOS

Marine Air Ground Task Force (MAGTF)

Deployment Support System (MDSS) II

Mr. Michael McAuliffe

Transportation Systems

Portfolio Manager

System Description

• Desktop application, Mission Assurance Category II, utilized by Marine Corps Operating Forces to plan, coordinate, manage and execute MAGTF deployments at the unit level. Functions include :

– Sourcing Time Phased Force Deployment Data (TPFDD) requirements

– Conducting deployment and movement planning

– Conducting embarkation planning

– Assigning RFID tags to cargo and reporting information to RF-

ITV servers

– Creating transportation requests

– Creating manifests and reporting to ITV systems

System Description (cont’d)

• MDSS II was developed and released in 1991 as an application in the LOGAIS Family of Systems.

• MDSS II is in the Operations and Support Phase of the acquisition process.

• Current fielded version is v7.4; version 7.4.1 is pending release to the Operating Forces

System Technology

• The current MDSS II application has been developed using Sybase SQLAnywhere, Java and PowerBuilder

• Software (Applications):

– PowerBuilder v12.1

– DynaZip v5.0.0.7

– Java JDK v1.6.0_23

– Shazam v3.5

– SQL Anywhere v12.0.1

– Visual Studio 2005 v8.0.50727.42

• MDSS II utilizes the MAGTF Data Library (MDL) for reference data

• MDSS II currently utilizes the Intermec CK-61 hand held barcode scanner and the PM4i barcode label printer

• MDSS II operates on NMCI platforms and on stand-alone computers

MDSS II Operational View

MDSS II System Interface Data Flow Diagram

File details come from the government source that posted it. Updated .