Attachment 7 - SBS SDP to ATC Automation and Service Monitoring User Subsystem_IRD_NAS-IR-82530001_Rev B.pdf
PDF 2 MB Posted
- Attached to
- Federal Aviation Administration (FAA) Surveillance and Broadcast Services Request for Information
- Solicitation number
- FAASBS-AAQ-210
View the file
Other files
On GovTribe
Work with this file
- Download the original file
- Contacts named in this file
- Similar government files
- Ask GovTribe AI about this file
Text version
U.S. Department of Transportation
Federal Aviation Administration
Interface Requirements Document
NAS-IR-82530001, Revision B
June 1, 2015
Surveillance and Broadcast Services (SBS)
Service Delivery Point (SDP) to ATC Automation and
Service Monitoring
User Subsystems
NAS-IR-82530001, Rev.B/ June 1,2015
Interface Requirements Document Approval Signature Page
Surveillance and Broadcast Services (SBS) Service Delivery Point (SDP) to ATC Automation and
Service Monitoring User Subsystems
Approval Signatures Participant
AJM-23
AJM-21
AJM-25
AJM-24
ANG-B1
Name Surveillance Services
Air Traffic Management Program
En Route and Oceanic 2n
Level Engineering Terminal 2nd Level
Engineering NAS Requirements and Interface Management
Group
Signature ikJj/
Date ikkt/r
NAS-IR-82530001, Rev.B/ June 1, 2015 iii
REVISION RECORD
Revision Date Description Approval
Rev.- 7/27/ 2010 NCP 32296 / ATO0E-SBS-1003 NAS CCB
Rev. A 2/23/2012 NCP 34095 / AJE06-SBS-1015 NAS CCB
Rev. B 06/01/2015 NCP 35618/ JM232-SBS-1007 NAS CCB iv
Table of Contents
1 SCOPE
1.1 SCOPE
1.2 SUBSYSTEM RESPONSIBILITY LIST
2 APPLICABLE DOCUMENTS
2.1 GOVERNMENT DOCUMENTS
2.2 NON-GOVERNMENT DOCUMENTS
2.3 DOCUMENTATION SOURCES
2.3.1 ELECTRONIC INDUSTRIES ALLIANCE DOCUMENTS
2.3.2 ISO/IEC DOCUMENTS
2.3.3 IEEE/ANSI DOCUMENTS
2.3.4 IETF STANDARD (RFC) DOCUMENTS
2.3.5 EUROCONTROL DOCUMENTS
3 INTERFACE REQUIREMENTS/CHARACTERISTICS
3.1 GENERAL CHARACTERISTICS
3.1.1 HUMAN SYSTEM INTERFACE REQUIREMENTS
3.2 FUNCTIONAL REQUIREMENTS /DESIGN CHARACTERISTICS
3.2.1 APPLICATION PROCESSES
3.2.1.1 Identification of Each Application Process
3.2.1.2 Category of Services Required by the Application Process
3.2.1.3 Information Units
3.2.1.4 Quality of Service
3.2.1.5 AP Error Handling
3.2.1.6 Interface Summary Table
3.2.2 PROTOCOL IMPLEMENTATION
3.2.2.1 Application Services
3.2.2.1.1 ADS-B Reports
3.2.2.1.2 TIS-B Reports
3.2.2.1.3 FIS-B Reports
3.2.2.1.4 Service Status Reports
3.2.2.1.5 ADS-R ACK/NACK Reports
3.2.2.1.6 TIS-B/ADS-R Service Status Reports
3.2.2.1.7 WAM Reports
3.2.2.1.8 WAM Service Status Reports
3.2.2.2 Network Services
3.2.2.2.1 Presentation Layer: Broadcast Services Data Unit (BSDU)
3.2.2.2.1.1 Identifier
3.2.2.2.1.2 Length
3.2.2.2.1.3 Application Element
3.2.2.2.1.4 CRC-32
3.2.2.2.2 Transport Layer and Network Services
v
3.2.2.3 Medium Services
3.2.3 SECURITY
3.2.4 INTERFACE DESIGN CHARACTERISTICS TABLE
3.3 PHYSICAL DESIGN CHARACTERISTICS
3.3.1 ELECTRICAL POWER AND ELECTRONIC REQUIREMENTS/CHARACTERISTICS
3.3.1.1 Connectors
3.3.1.1.1 Ethernet Connectors
3.3.1.1.2 Input Power Connectors
3.3.1.2 Wiring/Cabling
3.3.1.2.1 Cabling for Ethernet
3.3.1.3 Electrical Power Referencing (Grounding)
3.3.1.4 Fasteners
3.3.1.5 Electromagnetic Compatibility
3.3.1.6 Electrical Power Requirements
3.3.1.7 Seismic Requirements
3.3.2 PHYSICAL EQUIPMENT REQUIREMENTS
4 QUALITY ASSURANCE PROVISIONS
4.1 RESPONSIBILITY FOR VERIFICATION
4.2 SPECIAL VERIFICATION REQUIREMENTS
4.3 VERIFICATION REQUIREMENTS TRACEABILITY MATRIX
4.3.1 VERIFICATION LEVELS
4.3.1.1 First Article
4.3.1.1.1 Service Provider Qualification Tests
4.3.1.1.1.1 Factory Acceptance Test (FAT)
4.3.1.1.1.2 Service Integration Test (SIT)
4.3.1.1.1.3 Service Acceptance Test (SAT)
4.3.1.1.2 Government Qualification Tests
4.3.1.1.2.1 End-to-End System Test (EEST)
4.3.1.1.2.2 Operational Test and Evaluation (OT&E)
4.3.1.1.2.3 Independent Operational Test and Evaluation (IOT&E)
4.3.1.2 Implementation
4.3.1.2.1 Implementation Service Acceptance Test (ISAT)
4.3.1.2.2 Implementation System Test (IST)
4.3.1.3 Life Cycle
4.3.1.3.1 Service Re-Qualification Test (SRQT)
4.3.1.3.2 Service Performance Monitoring (SPM)
4.3.1.3.3 Government Performance Monitoring (GPM)
4.3.2 VERIFICATION METHODS
5 PREPARATION FOR DELIVERY
6 NOTES
6.1 DEFINITIONS
6.2 ABBREVIATIONS AND ACRONYMS
vi
Appendix A FAA Category 023 Format
A.1 Message Structure A.2 User Application Profile and Construction for the FAA CAT023 Service Status Report ... 28 A.3 Format and Encoding of FAA CAT023 (V 3) Data Items A.3.1 FRN 1: Service Volume Identifier (SVID) A.3.2 FRN 2: Version Number A.3.3 FRN 3: Time Of Status Report A.3.4 FRN 4: Transmitter/Receiver Location Identification (ID) Status A.3.5 FRN 5: Internal GPS Indicators of GPS System Health Status A.3.6 FRN 6: Latitude and Longitude A.3.7 FRN 7: ADS-B Reports Discarded A.3.8 FRN 8: TIS-B Messages Discarded A.3.9 FRN 9: UAT Ground Uplink Messages Discarded A.3.10 FRN 10: ADS-R/TIS-B Messages Transmitted A.3.11 FRN 11: UAT Ground Uplink Messages Transmitted A.3.12 FRN 12: ADS-B Messages Received and Sent to the SDP A.3.13 FRN 13: Service Status A.3.14 FRN 14: 1090ES Position Outlier Count A.3.15 FRN 15: TIS-B Sensor Status A.3.16 FRN 16: Data Source Qualifier A.3.17 FRN 17: ADS-R Messages Discarded A.3.18 FRN 18: SDP Status A.3.19 FRN 19: SDP Message Counts A.3.20 FRN 20: ADS-B Duplicate Reports Discarded A.3.21 FRN 21: WAM SDP Message Count
Appendix B – FAA Category 033 Format
B.1 Message Structure B.2 User Application Profile and Construction for the FAA CAT033 ADS-B Report B.3 Format and Encoding of FAA CAT033 Data Items B.3.1 FRN 1: Service Volume Identifier B.3.2 FRN 2: Version Number B.3.3 FRN 3: Link Technology Indicator B.3.4 FRN 4: Time of Applicability B.3.5 FRN 5: Target Address B.3.6 FRN 6: Integrity and Accuracy Parameters B.3.7 FRN 7: Latitude and Longitude B.3.8 FRN 8: Pressure Altitude B.3.9 FRN 9: Velocity (Airborne) B.3.10 FRN 10: Velocity (Surface) B.3.11 FRN 11: Mode 3/A Code B.3.12 FRN 12: Target Identification B.3.13 FRN 13: Emitter Category B.3.14 FRN 14: Target Status B.3.15 FRN 15: Geometric Altitude B.3.16 FRN 16: Modes and Codes B.3.17 FRN 17: TCAS RA Messages B.3.18 FRN 18: Time of Message Reception (TOMR) B.3.19 FRN 19: GPS Antenna Offset B.3.20 FRN 20: Target State Data B.3.21 FRN 21: ADS-B Data Quality Parameters vii
B.3.22 FRN 22: Data Source Qualifier B.3.23 FRN 23: Report Identifier B.3.24 FRN 24: Time of Origination
Appendix C – SBS SDP ADS-R ACK/NACK Format
C.1 Message Structure C.2 User Application Profile for the SBS SDP ADS-R ACK/NACK Report C.3 Format and Encoding of SBS SDP ADS-R ACK/NACK C.3.1 FRN 1: Service Volume Identifier C.3.2 FRN 2: Version Number C.3.3 FRN 3: Data Source Qualifier C.3.4 FRN 4: Report Identifier C.3.5 FRN 5: ACK Status C.3.6 FRN 6: Time of Message Arrival (TOMA) C.3.7 FRN 7: Latency C.3.8 FRN 8: Target Address
Appendix D – FAA Category 010 Format
D.1 Message Structure D.2 WAM Category 010 Report Type Definition D.3 Format and Encoding of WAM CAT010 Data Items D.3.1 FRN 1: Data Source Identifier D.3.2 FRN 2: Version Number D.3.3 FRN 3: Target Report Descriptor D.3.4 FRN 4: Time of Applicability D.3.5 FRN 5: Position in WGS-84 Coordinates D.3.6 FRN 9: Calculated Velocity in Cartesian Coordinates D.3.7 FRN 10: Track Number D.3.8 FRN 11: Track Status D.3.9 FRN 12: Mode 3/A Code in Octal Representation D.3.10 FRN 13: Target Address D.3.11 FRN 17: Flight Level in Binary Representation D.3.12 FRN 18: Corrected Flight Level D.3.13 FRN 22: Standard Deviation of Position D.3.14 FRN 23: Report Identifier D.3.15 FRN 26: Data Source Qualifier
Appendix E FAA Category 019 Format
E.1 Message Structure E.2 WAM Category 019 Report Type Definition E.3 Format and Encoding of WAM CAT019 Data Items E.3.1 FRN 1: Data Source Identifier E.3.2 FRN 2: Version Number E.3.3 FRN 3: Time of Status Message E.3.4 FRN 4: System Status E.3.5 FRN 5: Tracking Processor Detailed Status E.3.6 FRN 6: Remote Sensor Detailed Status E.3.7 FRN 7: Reference Transponder Detailed Status E.3.8 FRN 12: Data Source Qualifier
Appendix F – 1090-ES TIS-B/ADS-R Service Status Format
F.1 Message Structure F.2 User Application Profile for 1090-ES TIS-B/ADS-R Service Status Reports viii
F.3 Format and Encoding of TIS-B/ADS-R Service Status Report F.3.1 FRN 1: Service Volume Identifier F.3.2 FRN 2: Version Number F.3.3 FRN 3: Data Source Qualifier F.3.4 FRN 4: Report Identifier F.3.5 FRN 5: Service Status F.3.6 FRN 6: Aircraft Address #1 F.3.7 FRN 7: Aircraft Address #2 F.3.8 FRN 8: Aircraft Address #3 F.3.9 FRN 9: Time of Message Arrival (TOMA) F.3.10 FRN 10: Latency ix
List of Tables
Table 1-1: Report Summary Table 3-1: Interface Summary Table 3-2: BSDU ID Byte Values Table 3-3: Interface Requirements Table Table A-1: FAA CAT023 (v3) User Application Profile and Construction Table B-1: FAA CAT033 (v3) User Application Profile and Construction Table C-1: SBS SDP ADS-R ACK/NACK (v3) User Application Profile and Construction Table D-1: WAM CAT010 Report Definition Table E-1: WAM CAT019 Report Definition Table F-1: TIS-B/ADS-R Service Status Report User Application Profile and Construction
List of Figures
Figure 1-1 Application Level Summary (Notional SDPs) Figure 3-1: BSDU Construct
1 Scope
This Interface Requirements Document (IRD) establishes requirements for Surveillance and Broadcast Services (SBS) Service Delivery Points (SDP) interfaces to ATC automation systems and the SBS Monitor.
This IRD applies to the interfaces between SBS SDPs and user systems designated by the
FAA. Any other authorized users, proposed by the Service Provider and approved by the
FAA, may interface as agreed upon by the Service Provider and authorized user.
Surveillance and Broadcast Services is comprised of five distinct Services:
1. Automatic Dependent Surveillance-Broadcast (ADS-B),
2. Automatic Dependent Surveillance-Rebroadcast (ADS-R),
3. Traffic Information Service-Broadcast (TIS-B),
4. Flight Information Service-Broadcast (FIS-B), and
5. Wide Area Multilateration (WAM).
The Service requirements are documented in three separate specifications:
1. Surveillance and Broadcast Services Critical Services System Specification
Document (SSD),
2. Surveillance and Broadcast Services Essential Services System Specification
Document (SSD), and
3. Surveillance and Broadcast Services Wide Area Multilateration (WAM) Critical
Service Specification.
The ADS-B Service will support critical Air Traffic Control (ATC) Surveillance applications in the NAS. The ADS-R Service will support specified air-to-air applications involving aircraft which are equipped with different ADS-B links.
The TIS-B/FIS-B Services will provide traffic, weather, and NAS Status information to equipped aircraft/vehicles, supporting airborne applications.
The WAM Service will support critical ATC Surveillance applications in the NAS. The service will also provide a backup surveillance capability in the event of an ADS-B
Service outage.
1.1 Scope
SBS will provide data to automation systems and the SBS Monitor via Federal Aviation
Administration (FAA) defined Service Delivery Points (SDP). The SDPs are the physical demarcation points between the Services and the systems which ultimately use the data on the ground. SDPs associated with ATC automation systems will receive data only from SBS Services. SDPs associated with systems monitoring the performance of the Services, the SBS Monitor systems, will receive data from all Services. Table 1-1 summarizes the Report types provided by each of the Services and the associated formats.
The Report formats, FAA CAT033, FAA CAT023, FAA CAT010, and FAA CAT019, are based upon ASTERIX (see EUROCONTROL document SUR.ET1.ST05.2000-STD-
01-01) and are being harmonized with EUROCONTROL.
Note: Some automation systems will interface to SBS via a CD-2 interface in early implementations. The CD-2 interface is detailed in NAS-IR-
82530002.
Table 1-1: Report Summary
Report Type Format Services
Providing
Systems
Receiving
ADS-B Report FAA CAT033 (Appendix B) ADS-B
ATC
Automation, SBS Monitor
TIS-B Report FAA CAT033 (Appendix B) TIS-B SBS Monitor
FIS-B Report To be defined by the Service
Provider FIS-B SBS Monitor
Service Status Report FAA CAT023 (Appendix A) All Services
ATC
Automation, SBS Monitor
ADS-R ACK/NACK
Report
SBS SDP ADS-R
ACK/NACK (Appendix C) ADS-R SBS Monitor
TIS-B/ADS-R Service
Status Reports
TIS-B/ADS-R Service Status
Reports for 1090-ES (Appendix F)
TIS-B and
ADS-R
SBS Monitor
WAM Report FAA CAT010 (Appendix D) WAM
ATC
Automation, SBS Monitor
WAM Service Status Report
FAA CAT019 (Appendix E) WAM
ATC
Automation, SBS Monitor
Per Table 1-1, if all Services are provided, then all Report types may be sent to an SDP.
If a subset of the Services is provided, then only the corresponding Reports may be sent to an SDP. For example, if only ADS-B Services are provided, then the Reports transferred between SBS and an SDP are limited to ADS-B Reports and Service Status
Reports. SBS offers configurability for each SDP interface to identify the Report types that are sent to the SDP. Therefore, while Table 1-1 defines the maximum set of Report types that may be sent to the SDP, the configuration of the interface at the SBS ultimately determines which of the maximum set of Report types are sent.
The SBS SDP interface is a one-way interface, with data flowing from SBS SDP to the receiving systems. Figure 1-1 provides a notional set of SBS SDP interfaces and the application level data transferred between them. A given SDP may be provided data from Critical Services only, Essential Services only, or both Critical and Essential
Services.
Figure 1-1 Application Level Summary (Notional SDPs)
ADS-B Reports, WAM Reports, Service Status Reports
TIS-B Reports, Service Status Reports, FIS-B Reports, TIS-B/ADS-R Service Status Reports
Critical
SBS
SDP
SDP
Essential
SBS
ADS-B, WAM, Service Status, ADS-R ACK/NACK and TIS-B/ADS-R Service Status Reports
SBS Monitor
ATC
Automation
= Demarcation Point
1.2 Subsystem Responsibility List
NAS Subsystem Common Name Responsible FAA Organization
ASDE-X
Airport Surface Detection
Equipment
AJM-23
ASSC
Airport Surface
Surveillance Capability
AJM-23
ATOP
Advanced Technologies and Oceanic Procedures
AJM-25
SBS
Surveillance and
Broadcast Services
AJM-23
CARTS Common Automated Radar
Tracking System
AJM-24
STARS Standard Terminal
Automation Replacement
System
AJM-24
ERAM En Route Automation
Modernization
AJM-21
MEARTS Microprocessor En Route
Automated Radar Tracking
System
AJM-25
SBSM SBS Monitor AJM-23
2 Applicable Documents
2.1 Government Documents
FAA Documents: Title:
FAA-E-3011
Surveillance and Broadcast Services Critical Services
System Specification Document (SSD), Revision -, June
17, 2010
FAA-E-3006
Surveillance and Broadcast Services Essential Services
System Specification Document (SSD), Revision -, May
1, 2010.
FAA-E-3024
Surveillance and Broadcast Services Wide Area
Multilateration (WAM) Critical Service Specification, Revision -, February 8, 2012
FAA-G-2100H
U.S. Department of Transportation, Federal Aviation
Administration, Specification, Electronic Equipment, General Requirements, May 9, 2005
FAA-STD-019E
U.S. Department of Transportation, Federal Aviation
Administration, Standard, Lightning and Surge
Protection, Grounding, Bonding and Shielding
Requirements for Facilities and Electronic Equipment, December 2005
FAA-STD-025F
Administration, Standard, Preparation of Interface
Documentation, November 30, 2007
FAA-STD-039C
Administration, Standard Practice, National Airspace
System (NAS) Open System Architecture and Protocols, August 14, 2003
FAA SVDD SBS Service Volume Definition Document spreadsheet, Version 2.0, October 3, 2011
NAS-IR-82530002 Surveillance and Broadcast Services (SBS) Service
Delivery Point (SDP) Common Digitizer-2 (CD-2) to En
Route ATC Automation and Service Monitoring User
Subsystems Interface Requirements Document (IRD), Revision -, October 7, 2010
FAA Order 6030.20 Electrical Power Policy (Current Version)
FAA Order 6950.2 Electrical Power Policy Implementation at National
Airspace System Facilities (Current Version)
FCC Documents
Code of Federal Regulations Title 47 Part 15, for Class B digital devices for unintentional radiators, February 27,
2.2 Non-Government Documents
Other Documents: Title:
SUR.ET1.ST05.2000-
STD-01-01
Eurocontrol Standard Document for Surveillance Data
Exchange, Part 1: All Purpose Structured Eurocontrol
Surveillance Information Exchange (ASTERIX), Edition
1.29, February 2002
EIA-568-B.1
Commercial Building Telecommunications Cabling
Standard – Part 1: General Requirements, May 2001
Other Documents: Title:
IEEE Transactions on
Communications, Vol.
COM-30, No. 1
Fletcher, J.G., ―An Arithmetic Checksum for Serial
Transmissions,‖ IEEE Transactions on Communications, Vol. COM-30, No. 1, January 1982, pp. 247-252
IEEE 802.3 CSMA/CD Access Method (Ethernet), 26 December 2008
IETF STD 3 (RFC 1122)
Requirements for Internet Hosts – Communication
Layers, October 1989
IETF STD 3 (RFC 1123)
Requirements for Internet Hosts – Application and
Support, October 1989
IETF STD 5 (RFC 791) Internet Protocol (IPv4) Specification, September 1981
IETF STD 5 (RFC 792) Internet Control Message Protocol, September 1981
IETF STD 5 (RFC 919) Broadcasting Internet Datagrams, October 1984
IETF STD 5 (RFC 922)
Broadcasting Internet Datagrams in the Presence of
Subnets, October 1984
IETF STD 5 (RFC 950) Internet Standard Subnetting Procedure, August 1985
IETF STD 5 (RFC 1112) Extensions for IP Multicasting, August 1989
IETF STD 6 (RFC 768) User Datagram Protocol, August 1980
IETF STD 37 (RFC 826) Ethernet Address Resolution Protocol, November 1982
IETF STD 41 (RFC 894)
Standard for the Transmission of IP Datagrams over
Ethernet Networks, April 1984
IETF STD 43 (RFC 1042)
Standard for the Transmission of IP Datagrams over IEEE
802 Networks, February 1988
ISO-7498-1 Open System Interconnection Model, 1994
RFC 2460
Internet Protocol, Version 6 (IPv6) Specification, December 1998
RFC 2464
Transmission of IPv6 Packets over Ethernet Networks, December 1998
RFC 4291
Internet Protocol Version 6 Addressing Architecture, February, 2006
RFC 4443
Internet Control Message Protocol Version 6 for the
Internet Protocol Version 6 Specification, March 2006
2.3 Documentation Sources
2.3.1 Electronic Industries Alliance Documents
Copies of Electronic Industries Alliance (EIA) standards may be obtained from the
Electronic Industries Alliance, Technology Strategy and Standards Department, 2500
Wilson Boulevard, Arlington, VA 22201-3834, or by calling (703) 907-7500, or through their web site at http://www.eia.org .
http://www.eia.org/
2.3.2 ISO/IEC Documents
Copies of International Standards Organization documents may be obtained from
American National Standards Institute, 11 West 42 nd
Street, 13 th Floor, New York City, NY 10036. Telephone: (212) 642-4900, Telefax: (212) 398-0023, Email: info@ansi.org , web site: http://www.ansi.org or http://www.iso.org .
2.3.3 IEEE/ANSI Documents
Copies of IEEE/ANSI documents may be obtained from IEEE Computer Service, 445
Hoes Lane, P.O. Box 1331, Piscataway, NJ 08855-1331, or by calling (800) 701-4333 (in the U.S. and Canada), or (732) 981-0060 (outside of the U.S. and Canada), or through their standards web site at: http://www.ieee.org/web/standards/home/index.html
2.3.4 IETF Standard (RFC) Documents
Copies of the RFC documents may be obtained through the web site:
http://www.rfc-editor.org/rfc-index2.html
2.3.5 Eurocontrol Documents
Copies of Eurocontrol documents may be obtained through the web site:
http://www.eurocontrol.int/asterix/public/standard_page/documents.html mailto:info@ansi.org http://www.ansi.org/ http://www.ieee.org/web/standards/home/index.html http://www.rfc-editor.org/rfc-index2.html http://www.eurocontrol.int/asterix/public/standard_page/documents.html
3 Interface Requirements/Characteristics
3.1 General Characteristics
3.1.1 Human System Interface Requirements
This IRD provides requirements for the SBS SDP interface to automation systems and the SBS Monitor, a service to system interface. Therefore, no human system interface requirements are specified herein.
3.2 Functional Requirements /Design Characteristics
3.2.1 Application Processes
SBS will have an application that provides for the transmission of the Reports to the receiving system via the SDP. The receiving system must have an application that receives those reports.
3.2.1.1 Identification of Each Application Process
a. The SBS shall [1] output Reports to the receiving system via the SDP, per the SBS configuration.
b. The receiving system shall [2] receive and process all Reports from the SBS SDP.
3.2.1.2 Category of Services Required by the Application Process
The Category of Service requirements are specified within the SBS Specifications as
Service level performance requirements that are measured at the SDP and thus include interface contributions. Each SDP will be designated as either an essential or a critical level SDP. See the Surveillance and Broadcast Services Critical Services SSD Section
§3.3.2.2.5, the Surveillance and Broadcast Services Essential Services SSD Sections
§3.3.2.9 for TIS-B and §3.3.3.4 for FIS-B, and the Surveillance and Broadcast Services
WAM Critical Service SSD §3.3.2.16.
3.2.1.3 Information Units
a. The ADS-B Reports sent from the SBS SDP shall [3] contain the fields specified in the FAA CAT033 Report format defined in Appendix B.
b. The TIS-B Reports sent from the SBS SDP shall [4] contain the fields specified in the FAA CAT033 Report format defined in Appendix B.
c. The Service Status Reports sent from the SBS SDP shall [5] contain the fields specified in the FAA CAT023 Report format defined in Appendix A.
d. The FIS-B Reports sent from the SBS SDP shall [6] contain the fields specified in the format provided by the Service Provider and approved by FAA.
e. The ADS-R ACK/NACK Reports sent from the SBS SDP shall [7] contain the fields specified in the ACK/NACK format defined in Appendix C.
f. The WAM Reports sent from the SBS SDP shall [73] contain the fields specified in the FAA CAT010 Report format defined in Appendix D.
g. The WAM Service Status Reports sent from the SBS SDP shall [74] contain the fields specified in the FAA CAT019 Report format defined in Appendix E.
h. The TIS-B/ADS-R Service Status Reports for 1090-ES sent from the SBS SDP shall
[80] contain the fields specified in the TIS-B/ADS-R Service Status Reports format defined in Appendix F.
3.2.1.4 Quality of Service
The Quality of Service requirements, including integrity, latency, etc., are specified within the SBS Specifications as Service level requirements that are measured at the SDP and thus include interface contributions.
3.2.1.5 AP Error Handling
As receiving systems could host an array of applications with different error handling needs, the following represent desired characteristics of the application AP Error
Handling, rather than requirements.
a. The receiving system should verify that the Data Source Qualifier provided in the
Report is from a valid list of assigned Data Source Qualifiers.
b. The receiving system should compare the Time of Applicability (TOA) in the
Report to an adapted acceptable elapsed time parameter.
c. The receiving system should verify that the Integrity and Accuracy parameters
(NIC/NAC/SIL) are within an adapted threshold.
3.2.1.6 Interface Summary Table
Table 3-1 summarizes the data flow between the Surveillance Broadcast Services System
(SBSS) and the ATC Automation and SBS Monitor Systems.
Table 3-1: Interface Summary
SBSS Reports Direction Receiving
Systems
Data Provider
ADS-B Reports
TIS-B Reports
FIS-B Reports
Service Status Reports
ADS-R ACK/NACK Reports
TIS-B/ADS-R Service Status Reports
WAM Reports
WAM Service Status Reports
Data User
3.2.2 Protocol Implementation
All protocols developed shall [8] be in accordance with FAA-STD-039C.
3.2.2.1 Application Services
The application layer shall [9] support the transfer of the following application services from the SBS to receiving systems, via the SDP:
ADS-B Report, TIS-B Report, FIS-B Report, Service Status Report
ADS-R ACK/NACK Reports, TIS-B/ADS-R Service Status Reports
WAM Report, WAM Service Status Report
3.2.2.1.1 ADS-B Reports
a. The SBS shall [10] send ADS-B Reports to the receiving system per the
Configuration parameters associated with the interface.
b. The ADS-B Reports shall [11] be in the FAA CAT033 encoding structure as detailed in Appendix B.
3.2.2.1.2 TIS-B Reports
a. The SBS shall [12] send TIS-B Reports to the receiving system for each radar sensor report update with a minimum time interval between updates of no less than 1 second, per the Configuration parameters associated with the interface.
Note 1: One or more Reports may be sent in accordance with the ASTERIX data block definition documented in Appendix B.
Note 2: Two types of TIS-B Reports are defined, Type A and Type B. Type A Reports provide the source data for generating TIS-B Messages. This data is based on inputs from all sensors (including radar and ADS-B) and provide a complete picture of air traffic in a Service Volume. A TIS-B Type A Report is sent each time a radar report is received, whether or not the TIS-B Message is transmitted. Bit 1 of FRN 3, Link Technology, indicates whether or not the TIS-
B Message was actually transmitted. Type B Reports provide a view of the as-broadcast TIS-B Messages. A TIS-B Type B Report is sent each time a radio acknowledges successful transmission of a TIS-B message. Details of both types of these reports are provided in Appendix B.
b. The TIS-B Reports shall [13] be in the FAA CAT033 encoding structure as detailed in Appendix B.
3.2.2.1.3 FIS-B Reports
a. The SBS shall [14] send FIS-B Reports to the receiving system per the
Configuration parameters associated with the interface.
b. The FIS-B Reports shall [15] be in the format defined by the Service Provider.
Note: The FAA will review and approve the formats defined by the Service
Provider.
3.2.2.1.4 Service Status Reports
a. The SBS shall [16] send Service Status Reports to the receiving system per the
Configuration parameters associated with the interface.
b. The Service Status Reports shall [17] be in the FAA CAT023 encoding structure as detailed in Appendix A.
c. Each CAT023 SDP Status Report shall [18] be reported to the SBS Monitor with an update interval every 5 sec ± 2 sec.
d. A CAT023 SDP Status Report shall [19] be generated for each Automation SDP and sent to the SBS Monitor for each Service Volume in which the SDP is located.
3.2.2.1.5 ADS-R ACK/NACK Reports
a. The SBS shall [20] send ADS-R ACK/NACK Reports to the receiving system per the Configuration parameters associated with the interface.
b. The ADS-R ACK/NACK Reports shall [21] be in the SBS SDP ADS-R
ACK/NACK format defined in Appendix C.
3.2.2.1.6 TIS-B/ADS-R Service Status Reports
a. The SBS shall [81] send TIS-B/ADS-R Service Status Reports for 1090-ES to the receiving system per the Configuration parameters associated with the interface.
b. The 1090-ES TIS-B/ADS-R Service Status Reports shall [82] be in the report format defined in Appendix F.
3.2.2.1.7 WAM Reports
a. The SBS shall [75] send WAM Reports to the receiving system per the
Configuration parameters associated with the interface.
b. The WAM Reports shall [76] be in the FAA CAT010 encoding structure as detailed in Appendix D.
3.2.2.1.8 WAM Service Status Reports
a. The SBS shall [77] send WAM Service Status Reports to the receiving system per the Configuration parameters associated with the interface.
b. The WAM Service Status Reports shall [78] be in the FAA CAT019 encoding structure as detailed in Appendix E.
3.2.2.2 Network Services
3.2.2.2.1 Presentation Layer: Broadcast Services Data Unit (BSDU)
The Broadcast Services Data Unit (BSDU) serves the following functions:
Delimit Application Elements or to aggregate for transmission elements of like type
Identify Application Elements
Provide error detection of the Application Elements that may occur in transmission between the SBS SDP and the receiving system.
a. The format of the BSDU shall [22] be as described in Figure 3-1.
b. All Application Elements shall [23] be encapsulated in a Broadcast Services Data
Unit
Broadcast Services
Data Unit (BSDU) (Presentation Layer)
Identifier
(1 byte)
Length
(2 bytes)
Application Element
(one or more of same type)
CRC-32
(4 bytes)
Transmission Order
Figure 3-1: BSDU Construct
3.2.2.2.1.1 Identifier
This byte is used to distinguish between the different BSDU types indicated in Table 3-2 below. Since ADS-B Reports and Service Status Reports use the ASTERIX construction, the BSDU identifier is synonymous with the ASTERIX Category.
a. The SBS shall [24] assign an Identifier value per Table 3-2.
Table 3-2: BSDU ID Byte Values
Application Elements Value
(decimal)
Direction
(To/From SBS)
ADS-B Reports 033 From
TIS-B Reports 033 From
FIS-B Reports To Be Assigned From
Service Status Reports 023 From
ADS-R ACK/NACK Reports To Be Assigned From
TIS-B/ADS-R Service Status
Reports
To Be Assigned From
WAM Report 010 From
WAM Service Status Report 019 From
3.2.2.2.1.2 Length
This is a two-byte field that gives the length in bytes of the BSDU components including, the Identifier, the Length, the Application Element, and the CRC field.
a. The SBS shall [25] encode the length in bytes of the BSDU components including the Identifier, Length, Application Element, and CRC field as a 16 bit binary integer with the Most Significant Byte transmitted first and the Least Significant Byte transmitted last.
3.2.2.2.1.3 Application Element
The encoding for each Application Element is given in Appendices to this document.
The BSDU supports the packing of multiple Application Elements of the same type per
ASTERIX construction rules in the EUROCONTROL document SUR.ET1.ST05.2000-
STD-01-01 available on the EUROCONTROL website. ASTERIX based Application
Elements contain the ASTERIX CAT and LEN fields and one or more ASTERIX records of the same CAT.
3.2.2.2.1.4 CRC-32
The CRC-32 algorithm has been derived from: Fletcher, J.G., ―An Arithmetic Checksum for Serial Transmissions,‖ IEEE Transactions on Communications, Vol. COM-30, No. 1, January 1982, pp. 247-252.
The following symbols are used:
C0, C1, C2, C3 are variables used by the algorithm;
―i‖ is the number (i.e., position) of an octet within the BSDU;
―L‖ is the Length of the BSDU, as described in Section 3.2.2.2.1.2; and
―Xj‖ is the value of the ―jth‖ octet of the Extended 32-bit Checksum Parameter (in transmission order)
Arithmetic Conventions:
a. Addition shall [26] be performed in modulo 255.
b. The Extended 32-bit Checksum shall [27] be created by the following algorithm:
1. The Extended 32-bit Checksum Parameter value field set to ZERO will be set up
2. Initialize C1, C1, C2 and C3 to ZERO;
3. Process each octet in the BSDU sequentially from i=1 to ―L‖ -4 (as defined in
Section 3.2.2.2.1.2, but exclude the CRC) by:
a. adding the value of the octet to C0; then
b. adding the value of C0 to C1, C1 to C2, and C2 to C3;
4. Set the octets of the Extended 32-bit Checksum parameter as follows:
a. X0 = 255-(C0 + C1 + C2 + C3)-1;
b. X1 = C1 + 2*C2 + 3*C3;
c. X2 = 255-(C2 + 3*C3)-1; and
d. X3 = C3;
c. The Extended 32-bit Checksum shall [28] be validated as follows:
1. Initialize C0, C1, C2 and C3 to ZERO;
2. Process each octet in the BSDU sequentially from i=1 to ―L‖ (see Section
3.2.2.2.1.2) by:
a. adding the value of the octet to C0, then
b. adding the value of C0 to C1, C1 to C2, and C2 to C3;
3. If, when all the octets have been processed, one or more of the variables C0, C1, C2 or C3 do not have the value ZERO, then the Checksum validation has failed.
3.2.2.2.2 Transport Layer and Network Services
a. All transport and network layer protocols shall [29] be in accordance with IETF STD
3 (RFC 1122 and RFC 1123).
b. User Datagram Protocol (UDP) shall [30] be implemented for the transport layer in accordance with IETF STD 6 (RFC 768).
Note: The choice of UDP is consistent with the nature of a broadcast services / broadcast receipt system and with existing surveillance sensor backhaul protocols.
c. The SBS shall [31] support both IP Versions 4 and 6 as a configuration item for the network layer in accordance with IETF STD 5 (RFC 791), as well as IETF RFC
2460, 2464, 4291, and 4443.
d. The SBS shall [32] support IP multicasting to conformance level 2 as per IETF STD
5 (RFC 1112).
Note: This requires mandatory support of IP multicasting in IP Version 4.
Support for IP multicasting in IPv6 is inherent to the IPv6 specification.
e. The SBS/SDP shall [33] utilize a predefined transport layer port number and the network layer broadcast IP address of the subnet for each Application Element type supported.
f. The predefined transport layer port number shall [34] take the form of one of the following mutually exclusive configuration options:
1. Each Application Element is sent on its own unique transport layer port.
2. All Application Elements are sent on one common transport layer port.
Note: The SBS and SDP need not establish a Transport Layer connection since
UDP is a connectionless unacknowledged protocol.
g. The network shall [35] support Internet Control Message Protocol (ICMP) in accordance with IETF STD 5 (RFC 792).
h. Address Resolution Protocol (ARP) shall [36] be implemented in accordance with
IETF STD 37 (RFC 826).
i. The network shall [37] support IETF STD 5 (RFC 922), broadcasting internet datagrams.
j. The network shall [38] support IETF STD 5 (RFC 950), internet standard subnetting procedure.
k. The SBS/SDP shall [79] utilize a unique multicast group IP address for each type of service provided when IP multicasting is used (e.g., ADS-B Service or WAM
Service).
3.2.2.3 Medium Services
a. The data link layer shall [39] utilize the industry standard Ethernet in accordance with IEEE 802.3.
b. The data link layer implementation shall [40] be in accordance with IETF STD 41
(RFC 894) and IETF STD 43 (RFC 1042).
c. The physical layer shall [41] provide the bandwidth necessary to provide Reports to the SDP while meeting all performance requirements for the Service Volume.
3.2.3 Security
The SBS to SDP transmission security follows the IPsec standards, using authentication, encryption, and integrity to deliver an Encapsulated Security Payload (ESP) to the SDP.
The interface from the SDP to the receiving system shall [42] be within a physically secured government facility staffed by cleared personnel. Protection for the interface is provided through the physical and personnel security measures.
3.2.4 Interface Design Characteristics Table
Table 3-3: Interface Requirements Table
Report Type Format Type
Application
Level Maximum
Size without
Buffering (bytes)
Transmission
Frequency
(peak)
ADS-B Report FAA CAT033 Packed Binary 52
A function of the particular
Service Volume
(SV) or CTV
TIS-B Report FAA CAT033 Packed Binary 51
A function of the particular
SV
FIS-B Report
To be provided by the Service
Provider
Packed Binary
To be provided by the Service
Provider
A function of the particular
SV
Service Status
Report FAA CAT023 Packed Binary Variable
A function of the particular
SV or CTV
ADS-R
ACK/NACK
Report
SBS SD ADS-R
ACK/NACK
Packed Binary 19
A function of the particular
SV
TIS-B/ADS-R
Service Status
Report
TIS-B/ADS-R
Service Status for 1090-ES
Packed Binary 25
A function of the particular
SV
WAM Report FAA CAT010 Packed Binary 44
A function of the particular
SV
WAM Service
Status Report FAA CAT019 Packed Binary Variable
A function of the particular
SV
3.3 Physical Design Characteristics
The physical requirements for the SBS SDP interface will be as described below.
3.3.1 Electrical Power and Electronic Requirements/Characteristics
Electrical connection requirements for the Ethernet interfaces shall [43] be as specified in
IEEE 802.3.
3.3.1.1 Connectors
The connectors used for the interfaces are described below.
3.3.1.1.1 Ethernet Connectors
a. For Ethernet connections, the SBS SDP shall [44] provide jacks for the attachment of standard RJ-45 connectors.
b. The Ethernet connectors shall [45] be secured by means of a tab on the connector which mates with the jack, thereby preventing improper attachment and preventing detachment during normal movement of the unit.
c. Connector wiring shall [46] be as specified by EIA/TIA connector wiring specification T568B.
Note: Specification T568B is part of standard TIA/EIA-568-A.
d. Each SBS SDP shall [47] provide a minimum of 10 Ethernet port connections.
3.3.1.1.2 Input Power Connectors
Power connectors shall [48] be compliant with FAA-G-2100H, §3.1.1.1.1.
3.3.1.2 Wiring/Cabling
Wiring and cabling used for the SBS SDP is described below. All cables located in the plenum area must be plenum rated.
3.3.1.2.1 Cabling for Ethernet
All cabling shall [49] be Cat 5e and conform to the specifications of IEEE-802.3.
3.3.1.3 Electrical Power Referencing (Grounding)
Within the electrical interfaces, grounding shall [50] comply with FAA-STD-019E, FAA-G-2100, and the respective IEEE specification.
3.3.1.4 Fasteners
All fasteners shall [51] be in accordance with FAA-G-2100.
3.3.1.5 Electromagnetic Compatibility
a. Electromagnetic emission and susceptibility of the SBS SDP equipment shall [52] be in accordance with Code of Federal Regulations Title 47 Part 15, for Class B digital devices for unintentional radiators.
3.3.1.6 Electrical Power Requirements
The following electrical power requirements apply only to the critical power bus connection in the facility. The SBS SDP power supply is up to the service provider, but must be implemented such that the availability requirements are met.
a. Power for the SBS SDP shall [53] be in accordance with FAA-STD-019E and FAA-
G-2100.
b. Power consumption for the SBS SDP shall [54] not exceed 800 watts.
3.3.1.7 Seismic Requirements
The SBS SDP equipment seismic requirements shall [55] be in accordance with FAA-G-
2100H.
3.3.2 Physical Equipment Requirements
a. All equipment used to implement the SBS SDP shall [56] be rack mountable in a single standard 19 inch rack that is 72 inches in height.
Note: This includes all primary and any redundant equipment.
4 Quality Assurance Provisions
4.1 Responsibility for Verification
The test program will include both Service Provider and Government verification tests.
The Government may delegate its verification activities to other organizations, independent contractors, and/or the Service Provider.
a. The Service Provider shall [57] develop and execute a quality assurance program that ensures all services provided meet all requirements specified in section 3, as modified by the contract, and continue to meet the specified requirements on an ongoing basis.
b. The Service Provider shall [58] execute a testing program that verifies the achievement of the requirements specified in section 3.
c. Upon successful completion of Service Provider and Government qualification tests, the service implementation provided by the Service Provider shall [59] be an approved baseline configuration.
d. Additional service volumes provided by the Service Provider shall [60] be of the same baseline configuration.
4.2 Special Verification Requirements
There are no special verification requirements.
4.3 Verification Requirements Traceability Matrix
The Service Provider shall [61] develop a VRTM to illustrate the compliance to all
Section 3 requirements in this specification.
Note: The Service Provider is required by contract to deliver a VRTM (CDRL
SV-1).
4.3.1 Verification Levels
There are three test phases defined in the following sections. Each phase include tests events for which the Service Provider is responsible. The Service Provider‘s verification tests will include Service Provider Qualification Tests, Implementation Service
Acceptance Tests, Life Cycle Tests (in the event of configuration changes from the approved baseline) and Service Performance Monitoring.
In the event that changes to the baseline configuration are required, the Service Provider shall [62] perform Government approved Service Re-qualification tests as defined below.
4.3.1.1 First Article
a. Upon successful completion of Service Provider and Government Qualification
Tests, the service implementation provided by the Service Provider shall [63] be an approved baseline configuration.
b. Additional service volumes provided by the Service Provider shall [64] be of the same baseline configuration.
4.3.1.1.1 Service Provider Qualification Tests
4.3.1.1.1.1 Factory Acceptance Test (FAT)
a. The Service Provider shall [65] perform Factory Acceptance Tests to verify the functional and performance requirements of the service at the Service Provider‘s facility. The FAT may be conducted at the Service Provider‘s facility or some other
Service Provider designated facility approved by the Government.
4.3.1.1.1.2 Service Integration Test (SIT)
a. The Service Provider shall [66] perform Service Integration Tests at the Government designated integration key site(s) to verify the hardware, software, and/or functional requirements necessary to integrate with each unique automation platform designated within the National Airspace System (e.g., SBS Monitor, ERAM, MEARTS, STARS and CARTS).
4.3.1.1.1.3 Service Acceptance Test (SAT)
a. The Service Provider shall [67] perform Service Acceptance Tests at key sites prior to independent testing and assessment by the Government. The SAT will be utilized in the implementation phase defined in section §4.3.1.2.
4.3.1.1.2 Government Qualification Tests
The Government may determine to utilize some of the results obtained during FAT, SIT and SAT to support the independent evaluation of the services.
4.3.1.1.2.1 End-to-End System Test (EEST)
a. At the completion of each key site SAT, the Government will conduct a performance assessment of the end-to-end services. The Service Provider will be required to provide assistance to the government in the conduct of this testing.
4.3.1.1.2.2 Operational Test and Evaluation (OT&E)
a. Upon the completion of EEST, the Government will conduct an operational user assessment of the services at the key site. The Service Provider will be required to provide assistance to the government in the conduct of this testing.
4.3.1.1.2.3 Independent Operational Test and Evaluation (IOT&E)
a. Tests conducted by the FAA Office of IOT&E after the service achieves Initial
Operating Capability (IOC). The Service Provider will be required to provide assistance to the government in the conduct of this testing.
4.3.1.2 Implementation
4.3.1.2.1 Implementation Service Acceptance Test (ISAT)
a. The Service Provider shall [68] perform Implementation Service Acceptance Tests at each post-key site installation prior to independent testing and assessment by the
Government.
4.3.1.2.2 Implementation System Test (IST)
a. At the completion of each ISAT, the Government will conduct a performance assessment of the End-to-End ADS-B and ADS-R services. The Service Provider will be required to provide assistance to the government in the conduct of this testing.
4.3.1.3 Life Cycle
4.3.1.3.1 Service Re-Qualification Test (SRQT)
a. The Service Provider shall [69] perform Service Re-Qualification Tests whenever the service baseline is modified.
b. The SRQT shall [70] verify that the service performance is maintained whenever changes are implemented by the Service Provider.
4.3.1.3.2 Service Performance Monitoring (SPM)
a. The Service Provider shall [71] perform Service Performance Monitoring Tests once a service volume is certified and operational.
b. SPM tests shall [72] verify the system continues to meet section 3 requirements on an ongoing basis.
4.3.1.3.3 Government Performance Monitoring (GPM)
a. The Government will independently monitor the performance of each service volume to ensure the service remains certified and operational.
4.3.2 Verification Methods
The acceptable methods for verifying each requirement are the following:
a. Inspection: This method is used to determine compliance without using special laboratory equipment, procedures, or services and consists of a nondestructive static-state examination of hardware, software, and/or technical data and documentation.
b. Demonstration: This is a method in which qualitative determination of properties is made for a configuration item, including software and/or the use of technical data and documentation. The items being verified are observed, but not quantitatively measured, in a dynamic state.
c. Analysis: This is a method in which hardware or software designs are compared with known scientific and technical principles, procedures, and practices to estimate the capability of the proposed design to meet the mission and system requirements.
d. Test: This is a method in which performance is measured during or after the controlled application of functional and/or environmental stimuli. Quantitative measurements are analyzed to determine the degree of compliance. The process uses standardized laboratory equipment, procedures, and/or services.
5 Preparation for Delivery
Not applicable as this is a service to system interface and no equipment will be delivered.
Contractor equipment will reside in the FAA facility.
6 Notes
6.1 Definitions
Broadcast Services Data Unit (BSDU) – The BSDU is at the Presentation Layer and serves the following functions:
Delimit Application Elements or to aggregate for transmission elements of like type
Identify Application Elements
Provide error detection of the Application Elements that may occur in transmission between the SBS SDP and the receiving system.
Composite Traffic Volume (CTV) – A collection of Service Volumes from which the data from each SV is aggregated and duplicate targets are filtered. The CTV can employ a geographic filter to select the desired area within which data will be provided.
Demarcation Point – The demarcation point is the point at which operational control or ownership of communications changes from one organizational entity to another.
Service – One of the five distinct services provided as part of SBS: ADS-B, TIS-B, FIS-
B, ADS-R, and WAM.
Service Provider – The vendor or entity providing the SBS.
Service Volume (SV) – This is a geographically defined volume of airspace within which ADS-B services are provided.
6.2 Abbreviations and Acronyms
ADS-B Automatic Dependent Surveillance – Broadcast
ADS-R Automatic Dependent Surveillance-Rebroadcast
ASDE-X Airport Surface Detection Equipment – Model X
ASR Airport Surveillance Radar
ATC Air Traffic Control
ATCRBS Air Traffic Control Radar Beacon System
A/V Aircraft/Vehicle
BSDU Broadcast Services Data Unit
CARTS Common Automated Radar Terminal System
CD Common Digitizer
CRC Cyclic Redundancy Check
EEST End-to-End System Test
EPU Estimated Position Uncertainty
ERAM En Route Automation Modernization
FAA Federal Aviation Administration
FAT Factory Acceptance Test
FIS-B Flight Information Service - Broadcast
FRN Field Reference Number
FSPEC Field Specification (ASTERIX)
FX Field Extension
GNSS Global Navigation Satellite System
GPM Government Performance Monitoring
GPS Global Positioning System
HAE Height Above Ellipsoid
HDOP Horizontal Dilution of Position
HFOM Horizontal Figure of Merit
HPL Horizontal Protection Limit
IOT&E Independent Operational Test and Evaluation
in. Hg. Inches of mercury
IP Internet Protocol
IRD Interface Requirements Document
ISAT Implementation Service Acceptance Test
IST Implementation System Test
LSB Least Significant Bit
MEARTS Microprocessor En Route Automated Radar Tracking System
MSB Most Significant Bit
MST Multi Sensor Tracker
NAC Navigation Accuracy Categories
NACp Navigation Accuracy Categories for position
NACv Navigation Accuracy Categories for velocity
NAS National Airspace System
NIC Navigation Integrity Categories
OT&E Operational Test and Evaluation
PDOP Percent Dilution of Position
RNP Required Navigational Performance
Rpt Report
SA Selective Availability
SAC System Area Code
SAT Service Acceptance Test
SBS Surveillance and Broadcast Services
SBSS Surveillance and Broadcast Services System
SDA System Design Assurance
SDP Service Delivery Point
SIC System Identification Code
SIL Surveillance Integrity Levels
SIT Service Integration Test
SPM Service Performance Monitor
SRQT Service Re-Qualification Test
STARS Standard Terminal Automation Replacement System
TIS-B Traffic Information Service-Broadcast
TOA Time of Applicability
TOMR Time of Message Reception
TPM Technical Performance Measure
UAT Universal Access Transceiver
UDP User Datagram Protocol
UTC Universal Coordinated Time
VFOM Vertical Figure of Merit
VHP Very High Power
VPL Vertical Protection Limit
VRTM Verification Requirements Traceability Matrix
WAAS Wide Area Augmentation System
WAM Wide Area Multilateration
Appendix A FAA Category 023 Format
A.1 Message Structure
The ASTERIX CAT023 Report is an Application Element in the BSDU. ASTERIX based Application Elements contain the ASTERIX CAT and LEN fields and one or more
ASTERIX records (FSPEC and the specified Field Reference Numbers (FRN)) of the same Report type (i.e., Service Status Report) (See SUR.ET1.ST05.2000-STD-01-01, Figure 2).
The FRN establishes the order of the items in the FSPEC, and along with the Category code, serves to uniquely identify each data item. The FSPEC is the first byte(s) of the
Report and indicates which FRNs are present in the Report (1=FRN is included, 0=FRN is not included). Within each data item, byte 1 is transmitted first. ―FX‖ is the Field
Extension bit. A one in this bit indicates that the field extends into the next byte. As twenty FRNs are identified for the Service Status Report, up to three bytes are required for the FSPEC depending on the information to be reported.
Service Status Report Construction Example (Equipment Context)
Time
FSPEC FRN 1
Service
Volume
Identifier
FRN 2
Version
Number
FRN 3
Time of
Status
Report
FRN 4
Transmitter
/ Receiver
Status
FRN 5
Internal
GPS
Integrity and
Accuracy
Parameters
FRN 6
Latitude/
Longitude
F1 F2 F3 F4 F5 F6 F7 FX
1 1 1 1 1 1 0 0
A.2 User Application Profile and Construction for the FAA CAT023 Service
Status Report
The FAA CAT023 format is used to report service-related status in one of 5 distinct contexts: 1) an equipment (transmitter/receiver) context on a periodic basis, 2) a service volume context on a periodic basis, 3) a TIS-B sensor/tracker context only when a fault condition exists, 4) a ADS-B SDP context on a periodic basis for each Automation SDP, to be delivered to the SBS Monitor, and 5) a WAM SDP context on a periodic basis for each Automation SDP. Each FAA CAT023 report will address only one context. The
FRNs included in the FAA CAT023 vary depending on the context being reported. Table
A-1 identifies the FRNs and also when they are included in the Report. The Data Source
Qualifier identifies either equipment (transmitter, receiver, transmitter/receiver combination or a single SDP.
Table A-1: FAA CAT023 (v3) User Application Profile and Construction
FRN Data Item
Length in Bytes (when present)
Criteria for Inclusion: A=Always; x=Never
Equipment Context (Tx/Rx)
SV/CTV
Context
TIS-B
Sensor
Context
SDP
(ADS-B)
Context
SDP
(WAM)
Context
1 Service Volume Identifier (§A.3.1) 2 A A A A A
2 Version Number (§A.3.2) 1 A A A A A
3 Time of…
This is the start of the file's text. The full file is on GovTribe.
File details come from the government source that posted it. Updated .