HC101321R0011 AMD 0004.docx
DOCX document 185 KB Posted
- Attached to
- DISA VISP Federal contract opportunity
- Solicitation number
- HC101321R0011
- Issued by
- Defense Information Systems Agency
About this file
This solicitation requests proposals for the Defense Information Systems Agency's Voice Internet Service Provider program. Offerors must provide commercially available network solutions and services to support on-net and off-net calling for Department of Defense mission partners connected to the Non-classified Internet Protocol Routed Network. Proposals are due by June 17, 2021 for one of four regions: Hawaii, Indo-Pacific Command excluding Hawaii, Europe-Africa-Central Command, and North-South America Command. The solicitation identifies required services including access arrangements, IP voice services, DIDs, and emergency calling support. Pricing templates tailored for each region must be completed using the Appendix D attachments. The technical proposal is limited to 40-45 pages with additional region-specific addendums. Past performance and references for three relevant contracts from the last five years are also required.
View the file
Other files for this federal contract opportunity
Show all 33
On GovTribe
Work with this file on GovTribe
- Download the original file
- Contacts named in this file
- Similar government files
- Ask GovTribe AI about this file
Text version
HC101321R0011
HC101321R0011
SECTION SF 30 BLOCK 14 CONTINUATION PAGE
SUMMARY OF CHANGES
SECTION SF 1449 - CONTINUATION SHEET
SOLICITATION/CONTRACT FORM
The required response date/time has changed from 12-Jul-2021 10:00 AM to 27-Jul-2021 10:00 AM.
The following have been modified:
SECTION C
Section C - Descriptions and Specifications
PWS
Defense Information Systems Agency (DISA) Voice Internet Service Provider (VISP) Telephony Service
PERFORMANCE WORK STATEMENT (PWS)
As of February 16, 2021 Contract Number:
Contractor Name:
Tracking Number:
Follow-on to Previous Contract and Task Order Number:
1. Contracting Officer’s Representative (COR) Name:
Organization:
Department of Defense Activity Address Code (DODAAC):
Address:
Phone Number:
Fax Number:
E-Mail Address:
1. Contract Title DISA VISP Program Session Initiation Protocol (SIP) Trunking and Telephony Services
1. Background Department of Defense (DoD) Mission Partners (MP) with a Non-classified Internet Protocol (IP) Routed Network (NIPRNET) connection use DISA’s VISP telephony services for on-net calls and access the Public Switched Telephone Network (PSTN) for off-net calls. DISA uses its soft switch backbone to distribute the calls globally to any NIPRNET-connected site.
Currently DISA maintains redundant VISP PSTN gateways (PSTN-GW) at multiple worldwide locations (Reference Appendix A, Transport Site List, for details). Within the existing environment these PSTN-GWs interconnect through a private Multi-Protocol Label Switched (MPLS) Layer 3 Virtual Private Network (L3VPN), dedicated to DISA’s VISP program traffic. These PSTN-GWs allow for the establishment of commercial phone service and VISP intra-network connectivity. Dynamic routing protocols allow for automatic re-routing of traffic between geo-diverse sites in the event of a circuit or network failure.
1. Objectives:
3. Establish competitive prices for SIP trunking circuits and services and Direct Inward Dial number (DID) procurement and ongoing related services.
3. VISP PSTN-GW Connectivity: To obtain and establish new SIP Trunks and services.
3. DISA Subscriber requirements: The contractor shall port all telephony services and DID blocks from the existing provider to their network with minimal down time.
3. All billing shall occur in alignment with the billing processes and procedures defined in Appendix E, Additional Billing Requirements.
1. Scope The Government intends to award Indefinite Delivery Indefinite Quantity (IDIQ) contracts for each region, United States Indo-Pacific Command excluding Hawaii, Africa and Europe, Hawaii, and Continuous United States. The contractor delivering services under this contract shall provide the DISA VISP program with an IP based networking and telephony infrastructure and services to support intra-net and inter-net calling and regional DID blocks for DISA VISP subscribers, and application layer telephony services.
1. DISA VISP Program Services
The DISA VISP program CLINs fall into two main categories: CLINs used to establish the centralized access and trunking that all VISP MPs share, and CLINs used to support the telephony services for each MP site that leverages the centralized access.
DISA VISP Centralized Access and Transport Points of Presence (POP) – Applicable CLIN Types
The DISA VISP program office plans to establish a centralized, enterprise level transport and SIP trunking service at selected DISA-managed sites using the following CLIN descriptions. These services will provide the shared access mechanism used by all DISA VISP program subscribers to obtain per-site telephony services:
Access Arrangement (AA): Dedicated Ethernet (billed per circuit) Virtual Private Network Service (VPNS): Ethernet (billed per circuit) VPNS: Quality of Service (QoS) (billed per circuit) National Security Emergency Preparedness (NS/EP): NS/EP (multiple CLINs) (billed per circuit) Internet Protocol Voice Services (IPVS): SIP Trunk: Bandwidth QoS Management (billed per Trunk) IPVS: SIP Trunk: Trunk Bursting (billed per Trunk)
Within this contract, each of the previously listed CLIN types will be used multiple times since the DISA VISP program consists of multiple POPs and hundreds of subscribing DoD entities. For each occurrence of the CLIN corresponding to a particular site, a unique Case Number will be assigned so as to allow each instance of usage at a particular site for a particular CLIN to be uniquely identified by the contractor. The CLIN’s Case Number is defined for each site and instance of a CLIN under Appendix A. Appendix A also specifies whether the CLIN is “Required,” meaning it is included for service delivery immediately under this task order, or “Optional” meaning it is to be priced but a SO may occur later to incorporate the site into the service.
DISA VISP Customer/MP Site Telephony Services - Applicable CLIN Types:
For any MPs subscribing to DISA VISP program services, MPs will order services covered as described by the following CLIN descriptions:
IPVS: SIP Trunk: Basic Service (billed in units of concurrent call) IPVS: SIP Trunk: Automatic call routing (billed in units of concurrent call) IPVS: SIP Trunk: Single DID Number Assignment and Maintenance (billed in units of single phone number) IPVS: SIP Trunk: Block of 10 DID Numbers Assignment and Maintenance (billed in units of phone number block) IPVS: SIP Trunk: Block of 100 DID Numbers Assignment and Maintenance (billed in units of phone number block) IPVS: SIP Trunk: Block of 1000 DID Numbers Assignment and Maintenance (billed in units of phone number block) IPVS: SIP Trunk: DID Number Capture (billed in units of single phone number) IPVS: SIP Trunk: On-Net to Off-Net Calling (billed in units of 6 second increments) IPVS: SIP Trunk: Burstable Call Path (billed in units of concurrent call)
The case number corresponding to each instance of these CLINs is defined for each DISA MP subscribing site and instance of a CLIN under Appendix B. Similar to Appendix A, Appendix B also specifies whether the CLIN is “Required,” meaning it is included for service delivery immediately under this solicitation, or “Optional” meaning it is to be priced but a SO may occur later to incorporate the site into the service. CLINs may occur in any quantity required by the MP, and the quantity for each CLIN will be specified in the SO. For example, if a site requires 3500 DIDs, this requirement would result in an SO including a quantity of 3 “SIP Trunk: 1000 DID Block” CLINs and a quantity of 5 “SIP Trunk: 100 DID Block” CLINs.
The following section defines the CLINs in additional detail. For all CLINs within this PWS, all taxes and fees for any services rendered must be incorporated into one of the CLINs identified as this is a firm fixed price contract.
5. AA CLIN Summary Overview The CLINs in the following table shall be used to implement an AA and provide optional Telecommunications Service Priority (TSP) (https://www.fcc.gov/general/telecommunications-service-priority) when requested. The AA service shall be delivered in accordance with the requirements in Section 6.17. The contractor shall price the service based on the following CLINs.
The TSP services shall be delivered in accordance with the requirements in Section 6.19.
The CLIN definitions are as follows:
Table 6.1 AA and TSP CLIN Summary
| CLIN |
| Service ID |
| Description |
| Unit/Increment |
| Frequency |
| x001 |
| AA |
| Dedicated Ethernet 1 Gbps |
| CIRCUIT |
| NRC |
| x002 |
| AA |
| Dedicated Ethernet 10 Gbps |
| CIRCUIT |
| NRC |
| x003 |
| AA |
| Dedicated Ethernet 1 Gbps |
| CIRCUIT |
| MRC |
| x004 |
| AA |
| Dedicated Ethernet 10 Gbps |
| CIRCUIT |
| MRC |
| x010 |
| NS/EP |
| TSP Provisioning – No Local Access Coordination |
| CIRCUIT |
| NRC |
| x011 |
| NS/EP |
| TSP Provisioning – One Local Access Coordination |
| CIRCUIT |
| NRC |
| x012 |
| NS/EP |
| TSP Provisioning – Additional Local Access Coordination |
| CIRCUIT |
| NRC |
| x013 |
| NS/EP |
| TSP Restorations – No Local Access Coordination |
| CIRCUIT |
| NRC |
| x014 |
| NS/EP |
| TSP Restorations – One Local Access Coordination |
| CIRCUIT |
| NRC |
| x015 |
| NS/EP |
| TSP Restorations – Additional Local Access Coordination |
| CIRCUIT |
| NRC |
| x016 |
| NS/EP |
| TSP Priority Level for Design Change – No Local Access Coordination |
| CIRCUIT |
| NRC |
| x017 |
| NS/EP |
| TSP Priority Level for Design Change – Local Access Coordination |
| CIRCUIT |
| NRC |
| x018 |
| NS/EP |
| TSP Restorations – No Local Access Coordination |
| CIRCUIT |
| MRC |
| x019 |
| NS/EP |
| TSP Restorations – One Local Access Coordination |
| CIRCUIT |
| MRC |
| x020 |
| NS/EP |
| TSP Restorations – Additional Local Access Coordination |
| CIRCUIT |
| MRC |
The contractor shall deliver all AA and TSP services in accordance with all technical requirements defined within in this PWS. As previously mentioned, the quantity of each of the CLINs above procured under this contract will vary and will be specified in subsequent SOs during service order activation and based on the number of sites the Government requires for access services.
5. MPLS VPN Service CLIN Summary Overview The CLINs in the following table shall be used to implement a MPLS VPN. MPLS VPN service delivered in accordance with the requirements in Section 6.15. The contractor shall price the service based on and as defined by the following CLINs. These CLINs are paired with an appropriate AA:
Table 6.2 VPNS Service CLIN Summary
| CLIN |
| Service ID |
| Description |
| U/I |
| Frequency |
| x005 |
| VPNS |
| Ethernet - 1 Gbps |
| PORT |
| MRC |
| x006 |
| VPNS |
| Ethernet - 2 Gbps |
| PORT |
| MRC |
| x007 |
| VPNS |
| Ethernet - 3 Gbps |
| PORT |
| MRC |
| x008 |
| VPNS |
| Ethernet - 10 Gbps |
| PORT |
| MRC |
| x009 |
| VPNS |
| QoS |
| PORT |
| MRC |
The contractor shall deliver all VPN services in accordance with all other technical requirements defined within in this PWS. As previously mentioned, the quantity of each of the CLINs above procured under this contract will vary and will be specified in subsequent SOs during service order activation and based on the number of sites the Government requires for VPN services.
5. SIP Trunking CLIN Summary Overview The SIP trunking service provided under this task shall meet all requirements in this contract. The service will be priced and defined by the following CLINs. While it is of no impact to the contractor, the DISA VISP program office will centrally order and maintain services associated with the “TRUNK” unit CLINs, while DISA MPs will be required to order the other non “TRUNK” unit CLINs in the table below (with NUMBER / BLOCK CLINs ordered when needed to achieve the desired quantities of DIDs) to successfully order services:
Table 6.3 IPVS CLIN Summary
| CLIN |
| Service ID |
| Description |
| Unit/Increment |
| Frequency |
| x021 |
| IPVS |
| SIP Trunk: Basic Service |
| CONCURRENT CALL PATH |
| NRC |
| x022 |
| IPVS |
| SIP Trunk: Automatic call routing |
| CONCURRENT CALL PATH |
| NRC |
| x023 |
| IPVS |
| SIP Trunk: Bandwidth QoS Management |
| TRUNK |
| NRC |
| x024 |
| IPVS |
| SIP Trunk: Trunk Bursting |
| TRUNK |
| NRC |
| x025 |
| IPVS |
| SIP Trunk: Single DID Number Assignment and Maintenance |
| NUMBER |
| NRC |
| x026 |
| IPVS |
| SIP Trunk: Block of 10 DID Numbers Assignment and Maintenance |
| BLOCK |
| NRC |
| x027 |
| IPVS |
| SIP Trunk: Block of 100 DID Numbers Assignment and Maintenance |
| BLOCK |
| NRC |
| x028 |
| IPVS |
| SIP Trunk: Block of 1000 DID Numbers Assignment and Maintenance |
| BLOCK |
| NRC |
| x029 |
| IPVS |
| SIP Trunk: DID Number Capture (Porting) |
| NUMBER |
| NRC |
| x030 |
| IPVS |
| SIP Trunk: Basic Service |
| CONCURRENT CALL PATH |
| MRC |
| x031 |
| IPVS |
| SIP Trunk: Automatic call routing |
| CONCURRENT CALL PATH |
| MRC |
| x032 |
| IPVS |
| SIP Trunk: Bandwidth QoS Management |
| TRUNK |
| MRC |
| x033 |
| IPVS |
| SIP Trunk: Trunk Bursting |
| TRUNK |
| MRC |
| x034 |
| IPVS |
| SIP Trunk: Single DID Number Assignment and Maintenance |
| NUMBER |
| MRC |
| x035 |
| IPVS |
| SIP Trunk: Block of 10 DID Numbers Assignment and Maintenance |
| BLOCK |
| MRC |
| x036 |
| IPVS |
| SIP Trunk: Block of 100 DID Numbers Assignment and Maintenance |
| BLOCK |
| MRC |
| x037 |
| IPVS |
| SIP Trunk: Block of 1000 DID Numbers Assignment and Maintenance |
| BLOCK |
| MRC |
| x038 |
| IPVS |
| SIP Trunk: On-Net to Off-Net Calling |
| 6 SECONDS |
| Usage |
| x039 |
| IPVS |
| SIP Trunk: Burstable Call Path |
| CONCURRENT CALL PATH |
| Usage |
As previously mentioned, the quantity of each of the CLINs above procured under this contract will vary and will be specified in subsequent SOs during service order activation and based on the amount of telephony services required for a particular site.
The IPVS CLINs shall include unlimited on-net to on-net and on-net to CONUS off-net calling. The IPVS shall support off-net calling to CONUS, Outside Contiguous United States (OCONUS), and non-domestic locations. For service implementations located in an OCONUS country/jurisdiction, unlimited off-net calling within the same OCONUS country/jurisdiction shall also be included. Additional detail and pricing requirements are reflected in Section B.2 of Appendix E. The contractor shall provide capabilities that enable IPVS users to establish and receive telephone calls between both on-net locations and the PSTN.
5. Application Layer SIP Trunking Requirements
3. The contractor shall provide IP-enabled voice telephone services utilizing SIP trunking over a contractor-provided IP network that interfaces with DISA’s IP backbone at defined demarcation points.
3. The contractor’s SIP trunking service shall provide an application layer connection between a SIP-enabled Session Border Controller (SBC) on DISA’s VISP gateway environment and the contractor’s SIP-compliant telephony network. SIP trunking shall be fully integrated within the contractor’s service infrastructure to support calling to on-net and off-net locations. The network and its management will be provided by the underlying network service.
5. SIP Infrastructure Standards
4. The contractor’s SIP trunking infrastructure shall comply with the standards listed in Table 6.5.1 Table 6.5.1 SIP Infrastructure Standards
| Standard |
| Description |
| ITU-T E.164 |
| The International Public Telecommunication Numbering Plan |
| ITU-T G.711 |
| Pulse Code Modulation of Voice Frequencies |
| ITU-T G.729 and G.729A |
| Coding of Speech at 8 Kilobits per Second Using Conjugate-Structure Algebraic-Code-Excited Linear Prediction |
| ITU-T T.38 |
| Procedures for Real-Time Group 3 Facsimile Communication over IP Networks |
| Internet Engineering Task Force (IETF) Request for Comments (RFC) 2833 or RFC 4733 (Obsoletes RFC 2833) Provided Backwards Compatibility with RFC 2833 is Maintained |
| Real-Time Transport Protocol (RTP) Payload for Dual Tone Multi-Frequency (DTMF) Digits, Telephony Tones and Telephony Signals |
| ETF RFC 3550 |
| RTP |
| IETF RFC 3261 |
| SIP |
| IETF RFC 3264 |
| An Offer/Answer Model with the Session Description Protocol |
| SIP Connect 2.0 |
| SIP-PBX (Session Initiation Protocol Private Branch Exchange) / Service Provider Interoperability, "SIPconnect 2.0 Technical Recommendation", SIP Forum Document Number: TWG (Technical Working Group)-11 (NOTE: Implementation of the entire SIP Connect 2.0 recommendation is not required. *See section 6.13 for additional details)*. |
| IETF RFC 768 |
| User Datagram Protocol |
| IETF RFC 793 |
| Transmission Control Protocol |
5. Connectivity
5. The contractor’s infrastructure shall connect to and interoperate with:
The PSTN, including on-net and off-net locations, wireline and wireless networks, and United States domestic CONUS, OCONUS, and non-domestic locations.
5. Technical Capabilities
6. The contractor shall provide capabilities that enable users to establish and receive telephone calls between both on-net locations and the PSTN.
6. The contractor shall fully comply with emergency service requirements for the geographic area, including 911/ Enhanced 911 (E911) services (Local and National) in identifying the location of originating stations and routing them to the appropriate Public Safety Answering Point (PSAP).
6. The contractor’s infrastructure and services shall comply with the Federal Communications Commission’s (FCC) Local Number Portability (LNP) requirements.
6. The contractor shall specify the per-minute charges to each of the countries or territories listed in Appendix C utilizing pricing tables in Appendix D, Pricing Template. These appendices are tailored based on the AOR requiring coverage under this VISP contract.
6. Table 6.7.5 Mandatory Features Table 6.7.5 Mandatory Features
Local, Long Distance, and International calls for a given region.
Real time transport of voice, facsimile, and Text Telephone communications.
Real time delivery of Automatic Number Identification (ANI) information (when provided from the originating party).
Interoperate with public network dial plans to include North American Numbering Plan and ITU-E.164.
Interoperate with private network dial plans and support direct dialing.
Support dialing of local numbers that do not have E.164 equivalents such as 0, 311, 411, etc. when available in a given geographic region.
Provide access to public directory and operator assistance services when available in a particular geographic region.
Provide unique directory numbers for all on-net Government locations, including support for existing Government numbers.
Support 3-way calling.
Support Blind Call Transfer.
Support Attended Call Transfer.
Automatic call routing.
Bandwidth QoS management.
Call forward.
Call hold.
Early media (media sent after an INVITE but prior to receipt of a 200 OK).
Early Offer (Session Description Protocol negotiation in the INVITE / 200 OK). Delayed offer usage is not desirable however the contractor must not terminate a session when delayed offer INVITEs are received.
Support calls with privacy requested and anonymous caller ID (to meet the needs of DoD entities that do not want to share caller ID information).
DTMF transmission / receipt both inbound and outbound in either calling direction.
Telephone number blocks of DIDs.
5. Codecs
7. The contractor shall support the following codecs and standards in Table 6.8.1.
Table 6.8.1 Mandatory CODECs
G.711 (mu-law at minimum, a-law is optional but desirable) without silence suppression.
Modem Pass-through applications transported over G.711 such as G3 fax, modems and secure telephones that begin with clear voice and then go secure with a modem (i.e. Secure Terminal Equipment, vIPers, and other DoD secure phones).
G.729A
T.38
RFC 2833 (or RFC 4733 when implemented in a backwards compatible manner to comply with RFC 2833) for carrying DTMF digits to include for second dial tone applications. No other method for transporting DTMF shall be used.
RTP/RTCP – The contractor shall support RTP, however support for the companion Real-Time Transport Control protocol is desirable but not required.
The contractor shall support use of the RFC 3261 and RFC 3264 Session Description Protocol Offer/Answer model to negotiate the allowed codecs available for session. The contractor shall support the use of the re-INVITE mechanism for renegotiating codecs during a session. The early offer (INVITE / 200 OK exchange) mechanism shall be used to negotiate codecs for a session.
5. Caller Identification (ID) requirements Incoming calls from the contractor’s infrastructure to DoD shall include the calling number and Caller Identification Name when provided by the calling party.
8. Signature-based Handling of Asserted information using toKENs (SHAKEN) Secure Telephony Identity Revisited (STIR); the contractor shall support the SHAKEN/STIR framework to make use of public key cryptography to provide SHAKEN/STIR described in FCC publication FCC 19-51 paragraph 21 to reduce Caller ID spoofing.
5. DIDs
9. The contractor shall provide DIDs at the user location or in the geographic area specified in an order received from DISA in the agreed upon order receipt format.
9. The contractor shall coordinate and ensure completion of DID portability Letters of Authorization, as required.
9. The contractor shall be capable of providing local DIDs, if requested, within 90 days to a given percentage of locations specified in the respective regional spreadsheet.
9. The contractor shall enable and support basic emergency calling location services.
9. The contractor shall enable and support advanced IP based emergency calling services.
9. The contractor shall supply DIDs and network services to DoD customers. The contractor is required to support all existing transport site locations in Appendix A and VISP MP site locations listed in Appendix B, Customer Site List, to include porting existing numbers, support emergency call routing services, and have the ability to provide new DIDs when needed. DISA is awarding this contract to cover a specific geographic Area of Responsibility (AOR) (reference https://www.acq.osd.mil/dpap/pacc/cc/areas_of_responsibility.html for a definition of the AOR regions). The PWS Appendices are tailored to reflect the AORs that are in scope of this contract. The vendor shall have the ability to deliver DIDs to at least the percentage of sites specified or as required on each tab in Appendix C, Coverage Requirements, within 90 days of an order.
9. The contractor shall provide DID coverage requirements and associated emergency calling services as listed in Appendix C, DID Coverage Requirements, within 90 days of contract award.
5. Emergency caller ID and location service requirements.
10. Description, emergency calling and location services capabilities and types vary by location and are governed by local jurisdiction. For this contract the following categories will be established.
1. The United States Territories and Possessions emergency calling and location services are, E911, and Next Generation 911 (NG911). The contractor shall comply with the local PSAP requirements to route a 911 call to the registered PSAP for the location in question. The format of the routed 911 call shall be compatible with the registered PSAP for the calling location. The calling party information presented to the PSTN shall remain intact from the calling location to the registered PSAP.
1. Non-domestic locations, since the capability and type of emergency calling and location services differ from one country to the country the contractor shall interoperate with the local jusridiction on a case by case basis.
10. Emergency calling and location services database update services
1. For services delivered within the United States Territories and Possessions, the contractor shall provide a service that allows DISA VISP MPs to provide real-time updates to E911 NG911 location service databases used by PSAPs. The service shall meet the requirements in table 6.11.2.
| Task # |
| Table 6.11.2 911 Database Requirements |
| 1 |
| Allow updates to automatic location identifier (ALI) information associated with any of the DIDs assigned to the VISP customer under the service agreement. |
| 2 |
| Allow VISP customers to upload a formatted file supporting bulk updates to the ANI/ALI information on a per-DID basis. The contractor’s site shall provide a downloadable template and clear instructions for populating the template file. |
| 3 |
| The upload file format shall support standard file formats such as Comma Separated Values, Microsoft (MS) Excel, National Emergency Number Association. |
| 4 |
| Provide a secure web portal for making updates to the ANI/ALI mappings utilizing Hypertext Transfer Protocol Secure (HTTPS) with username and password authentication at a minimum with a preference for two-factor authentication. |
| 5 |
| Support role-based access control with the web portal such that DISA VISP customer administrators can only access user and ANI/ALI information associated with their DIDs and not have access to information associated with other VISP customer domains. |
| 6 |
| Allow for generation of exportable reports in an open standard exportable file format detailing the current status of all ANI/ALI mapping associated with the VISP customer account. |
| 7 |
| Provide a helpdesk and trouble ticket support for resolving issues with the web portal. |
1. For non-domestic locations contractors shall provide this service based on the limitations and capability of the jurisdiction of the requested location.
5. SIP Routing Requirements
11. The contractor shall provide SIP Trunks to the VISP PSTN-GWs. The contractor shall route both internal calls and global PSTN calls to and from all VISP PSTN-GW locations supporting services delivered to the AOR covered under this contract. The contractor shall establish and maintain primary and alternate PSTN-GW Hub sites for each region and enable intra-regional configurable failover.
11. The contractor shall provide off-net calling and Mobile Termination services. The contractor shall develop and maintain an online catalog of pricing based on the pricing tables in Appendix D for MPs to use when determining off-net calling charges.
11. Incoming and outgoing calls to the PSTN-GW shall be able to search all PSTN-GW SIP trunks in the region. The contractor shall support the ability to route calls to a minimum of 6 trunks in any region homed to 6 different DISA SBC gateways with a configurable failover behavior specified in Table 6.12.3 Table 6.12.3 SIP Failover Behaviors
Round Robin where the carrier cycles traffic sequentially and evenly through all available provisioned trunks.
Primary, Secondary, Tertiary, and continuing, in a deterministic ordering specified by DISA
Weighted Load-Balancing i.e. 60% on trunk 1, 10% on trunk 2 per DISA requirements
11. DISA may elect to deploy fewer than 6 trunks in a given region depending on mission need.
11. The Government requires the contractor provided SIP trunks to comply with the local PSAP requirements to route a 911 call to the registered PSAP for the calling. The format of the routed 911 call shall be compatible with the registered PSAP for the calling location. The calling party information presented to the PSTN shall remain intact from the calling location the registered PSAP.
5. SIP Signaling Requirements
12. The contractor shall also be capable of upgrading its infrastructure to the latest SIPconnect profiles as they are approved.
12. SIPconnect 2.0 (located here: https://www.sipforum.org/activities/technical-wg-overview-and-charter/sipconnect-2-0-task-group) serves as the basis for the signaling requirements in this PWS and Table 6.13.2 identifies the mandatory and optional components of the protocol.
Table 6.13.2 SIP Signaling Requirements
| SIPconnect 2.0 Reference |
| Feature |
| Requirement Under this PWS |
| Section 7 |
| Static Mode |
| Mandatory |
| Section 8 |
| TCP |
| Mandatory |
| Section 8 |
| UDP |
| Optional |
| Section 8,1 |
| TLS |
| Optional Note: Calls will be signal over a closed, L3VPN |
| Section 9 and All Subsections |
| E.164 |
| Mandatory |
| Section 10 and All Subsections |
| Basic 2-Way Calls |
| Mandatory |
| Section 11, 11.1 |
| Call Forwarding |
| Mandatory |
| Section 12 |
| Call Transfer with re-INVITE |
| Mandatory |
| Section 12.1.1 |
| Blind Transfer |
| Mandatory |
| Section 12.1.2 |
| Attended Transfer |
| Mandatory |
| Section 12.2 |
| Re-INVITE with no offer During Transfer |
| Mandatory |
Section 13, 13.1, 13.2 Section 14.1, 14.2, 14.3, 14.5, 14.6, 14.7, 14.8, 14.9 Emergency Services Session Description Protocol Offer/Answer Mandatory Mandatory
Section 14.4 Section 14.4 Secure Real-time Transport Protocol (SRTP)
SRTP
Optional Note: Calls will be signal over a closed, L3VPN Optional Note: Calls will be signal over a closed, L3VPN
| Section 14.10 |
| Hold “sendonly” method |
| Mandatory |
| Section 14.10 |
| Hold “sendonly” method |
| Mandatory |
| Section 14.10 |
| Hold “0.0.0.0” method |
| Mandatory |
| Section 15 |
| Support the ability to establish IPv6 signaling and media when required by DISA |
| Mandatory (NOTE: Initially DISA expects to establish trunks using IPv4 but reserves the right to migrate to IPv6 in the future) |
| Section 17: Annex B |
| Static Mode |
| Mandatory |
| Section 17.1.1.1 |
| Locating SIP Servers (DISA Side) - Manual Configuration |
| Mandatory |
| Section 17.1.2.1 |
| Locating SIP Servers (Contractor Side) - Manual Configuration |
| Mandatory |
| Section 17.2 |
| Signaling Security |
| Optional |
| Section 17.3 |
| Firewall and NAT Traversal |
| Mandatory |
| Section 17.4 |
| Failover and Recovery, OPTIONS ping requests |
| Mandatory |
| Section 17.5 |
| Authentication |
| Optional |
| Section 17.6 |
| Routing Inbound Requests to the SIP-PBX |
| Mandatory |
5. Cyber Security
13. The contractor shall ensure that security practices and safeguards are provided to minimize susceptibility to security issues and prevent unauthorized access. The contractor shall also ensure that security practices and policies are regularly updated and audited. The contractor’s infrastructure used to deliver services shall provide perimeter defense mechanisms including application aware firewalls or SBCs and Intrusion Detection/Prevention Systems. In addition, the contractor shall prevent direct internet access and provide layered internal and external defenses designed to prevent unauthorized access to the L3VPN. The contractor shall ensure that the service infrastructure is private and that unauthorized third parties cannot eavesdrop or intercept communication media, numbers, IP addresses or URLs. All media traffic transmitted towards and received from the DISA environment shall be anchored on a SIP-aware device such as a session border controller that dynamically permits only authorized signaling and media sessions into the contractor’s provided infrastructure
13. The contractor shall provide 24x7 Cybersecurity-focused monitoring of all infrastructure used to deliver services and upon request through the COR, make available to DISA, reports and metrics related to any recent Cybersecurity concerns affecting infrastructure used to deliver services to DISA. Any critical Cybersecurity incidents directly affecting the L3VPN and SIP trunks supporting DISA VISP services shall be promptly reported to a DISA COR-designated authorized representative within 24 hours.
13. The contractor shall employ routine automated scanning of all infrastructure provided in support of services delivered to DISA to automatically identify and expeditiously patch newly discovered vulnerabilities. In addition, the contractor shall also continually replace and refresh end of support and end of life components so as to avoid operating any infrastructure that is no longer receiving Cybersecurity patches from the product manufacturer.
13. As part of the response to this PWS, theThe contractor shall provide written evidence, within 10 days of award, of an established and comprehensive Cybersecurity program which addresses all of the functional categories identified in Table 6.14.4 of the National Institute of Standards and technology (NIST) “Framework for Improving Critical Infrastructure Cybersecurity” version 1.1 posted at this reference https://nvlpubs.nist.gov/nistpubs/CSWP/NIST.CSWP.04162018.pdf. Specifically, the contractor shall provide information explaining how it either already meets the requirements within the Table 1 Cybersecurity categories or, in cases where a gap exists, explains the contractors proposed approach for resolving the gap and meeting the requirement within 18 months of contract award.
Deliverable:
Table 6.14.4 Cyber Security Program Requirements
| Category Unique Identifier |
| NIST Category |
| ID.AM |
| Asset Management |
| ID.BE |
| Business Environment |
| ID.GV |
| Governance |
| ID.RA |
| Risk Assessment |
| ID.RM |
| Risk Management Strategy |
| ID.SC |
| Supply Chain Risk Management |
| PR.AC |
| Identity Management and Access Control |
| PR.AT |
| Awareness and Training |
| PR.DS |
| Data Security |
| PR.IP |
| Information Protection Processes and Procedures |
| PR.MA |
| Maintenance |
| PR.PT |
| Protective Technology |
| DE.AE |
| Anomalies and Events |
| DE.CM |
| Security Continuous Monitoring |
| DE.DP |
| Detection Processes |
| RS.RP |
| Response Planning |
| RS.CO |
| Communications |
| RS.AN |
| Analysis |
| RS.MI |
| Mitigation |
| RS.IM |
| Improvements |
| RC.RP |
| Recovery Planning |
| RC.IM |
| Improvements |
| RC.CO |
| Communications |
13. With respect to telephony-based Cybersecurity threats, the contractor shall employ measures to prevent application layer VoIP protocol specific threats and describe how the contractor either meets or plans to meet the mitigation of Cybersecurity threats listed in Table 6.14.5 Table 6.14.5 Cybersecurity Threats
SIP message storms and Telephony Denial of Service attacks - provide safeguards to prevent hackers, worms, or viruses from denying legitimate users from accessing awarded services.
Protocol fuzzing attacks.
Spam over Internet Telephony.
Call flooding.
Call looping.
SIP-based scanning and username / password enumeration attacks.
5. Network Layer Requirements The contractor shall ensure this L3VPN is reachable from all contractor POP in the region. The contractor shall support the use of routing protocols to exchange routes for specific subnets and allow DISA to control which paths are used for primary, secondary, tertiary, etc. circuit failover in given region and minimize the distance the traffic travels. The private L3VPN shall remain isolated from the internet at all times and shall support no traffic other than DISA VISP’s services. The contractor shall meet the performance metrics specified in PWS section 7.1 when delivering these services.
14. Standards The contractor’s network infrastructure shall comply with the following standards listed in table 6.15.1 and all subsequent IETF and Institute of Electrical and Electronic Engineers (IEEE) revisions:
Table 6.15.1 Network Layer Standards
| Standard |
| Description |
| IEEE 802.3 Family |
| 10 / 100 / 1000 / 10000 Mbps Ethernet Standards |
| IETF RFC 791 |
| Internet Protocol (Version 4) |
| ITEF RFC 4271 |
| A Border Gateway Protocol (BGP) 4 |
| IETF RFC 4594 |
| Guidelines for DiffServ Service Classes |
| IETF RFC 5880 |
| Bidirectional Forwarding Detection (BFD) |
| IETF RFC 8200 |
| Internet Protocol, Version 6 (IPv6) Specification |
14. BGP requirements
1. BGP: The contractor shall implement this protocol at a minimum at the edge of contractor’s L3VPN environment as a means to exchange routes with DISA and provide the subnets required to access SIP trunking services. The contractor shall work with DISA IP engineers to exchange BGP authentication credentials and other parameters as appropriate to successfully activate and sustain circuits at all service delivery points in the region. When loss of a circuit occurs due to physical or logical infrastructure issues, the contractor shall leverage the BGP protocol to determine the best and most optimal means for the network to converge and continue successful processing of traffic. All network convergence due to circuit failure and circuit re-activations shall occur in an automated manner, in real-time, without the need for human, manual intervention. Application layer SIP signaling and RTP media traffic shall have the capability to seamlessly switch over to use alternative paths as the network dynamically updates to “self-heal” following network disruptions and changes. The contractor shall integrate BGP with the BFD protocol as described in paragraph B, which follows, to expedite network convergence.
1. BFD: The contractor shall support the use of BFD, peered to DISA routers at the demarc, to minimize the amount of time required to detect and respond to failures. BFD allows for detection of failures when multiple components exist between the connection of the contractor’s router and DISA’s router at the demarc, and detects outages faster than the standard timeout settings used within BGP. When BFD is used in conjunction with BGP, the contractor’s network shall detect circuit failures and re-route all traffic to alternative geo-redundant paths within 6 seconds or less, in order to minimize disruption for active signaling and media traffic—avoid dropped calls for DISA VISP subscribers.
14. QoS
1. The contractor shall support QoS within their environment and implement expedited forwarding per hop behaviors to forward DISA VISP media traffic within the contractor’s network. The contractor shall provision its infrastructure to ensure DISA’s traffic receives prioritized treatment over other lower priority, best effort data traffic operating within the contractor’s environment. The contractor shall provide DISA with the required DiffServ Code Points (DSCP) that the contractor expects to see marked on all signaling and media traffic. The DSCP values used within the contractor network shall align to the IETF industry standard DSCP values for denoting inelastic / real-time traffic service class traffic. DISA’s SBCs have the flexibility to apply DSCP markings to traffic exiting a particular SIP trunk in a configurable manner. The contractor shall ensure that all traffic entering the DISA network conforms to the agreed upon DSCP marking scheme.
1. The contractor shall, throughout the life of this contract, manage and maintain the DSCP marking schemes and accomodate future changes in industry standards with respect to DSCP markings and configurations.
5. AAs AAs Description
15. The contractor shall provide AAs, which connect the Service Delivery Point (SDP) at the agency location to a POP on the contractor’s network.
15. Diversity: AAs shall provide diversity options that include:
1. Physically disparate, diverse paths from the SDP to the POPs of two diverse contractors where possible.
1. Physically disparate, diverse paths from the SDP to the contractor’s POP where possible.
1. Redundant paths from an SDP to the contractor’s POP where possible.
1. There shall be no single point of failure or blockage on the contractor’s network which would block all service to and from DISA’s managed network. This includes both equipment and path. The contractor can propose to use infrastructure and additional products as needed to deliver the services and performance standards required in the PWS. However, the pricing of all components of the proposed solution shall be included in the evaluation of the proposal and shall follow the billing model in Appendix E.
15. Special construction may involve providing a special service or facility related to the delivery and/or performance of a service requirement. This may include the following situations:
1. An AA does not exist or does not have sufficient capacity, and the contractor has to provide special construction through the implementation, rearrangement or relocation of physical plant solely for the Government requested AAs.
1. The contractor uses special construction to implement a different route (Government premises to a Physical Concentration Location (PCL), PCL to an alternate contractor’s POP, or some other type of route) than that which the contractor would otherwise use to provide an AA for the Government.
15. All costs for special construction, site surveys, cabling, equipment rentals, permits, designs, engineering, and another services required to establish the AA shall be billed under the billing model defined within this PWS Appendix E.
15. AA Responsibility The contractor shall provide all AA services ordered for the duration of the contract. This includes services provided by the contractor's network, the Local Exchange Carrier and any other service, component, equipment, device, wiring, repeater; driver etc. installed by the vendor to deliver service to the SDP, regardless of how they were initially funded. Once the service is installed and operational, it is the contractor's responsibility to continue providing that service to the SDP for the life of the contract including troubleshooting, repairing or replacing any components used for delivering the service to the SDP at no additional expense to the customer. DISA VISP requires the contractor to provide an Ethernet Interface. Any equipment, wiring or cabling used to provide the Ethernet Interface will be considered as being on the contractor side of the demark and shall always be the contractor’s responsibility in case of service failure.
15. Interfaces Table 6.16.6 lists the required interface at the circuit demarc Table 6.16.6 Demarc Interface Standards
| Interface Type and Standard |
| Payload Data Rate or Bandwidth |
Ethernet The curent IEEE 802.3 standard capable of meeting the required service delivery via copper or fiber interfaces at the discretion of the Gov’t Based on DISA requirements.
5. Management and Network Operations
16. The contractor shall provide a web-based management portal that allows DISA and VISP program customers to perform the capabilities listed in Table 6.17.1 and 6.17.2:
Deliverable:
Table 6.17.1 Management and Network Operations (OPS) Contractor Portal Requirements
| Line Item |
| Description |
| 1 |
| Open and track the status of helpdesk trouble tickets |
| 2 |
| Manage service-related features and settings |
| 3 |
| Obtain training and service documentation materials. |
| 4 |
| Provide a Dashboard where Application and Network status and health can be viewed |
| 5 |
| Inventory Management, and SLA Management |
16. Call Detail Records (CDR) and service usage reports.
Deliverable:
Table 6.17.2 CDR Report
| Line Item |
| Description |
| Frequency |
| Format |
| 1 |
| Peak busy hour concurrent calls |
| Last business day of the month * Note 1 |
| Agreed Upon MS Office Document |
| 2 |
| Total number of dropped calls |
| 3 |
| Total number of successful calls |
| 4 |
| Total blocked calls |
Note 1 As determined by the COR and available via the contractor Portal
5. Transition Project Management Transition project management is the planning, staffing, executing and controlling of all aspects of transition activity to achieve the Government's objectives. The contractor shall conduct transition planning and provide advice on strategies to minimize the transition time and have completed transitioning of services prior to the expiration of the existing GSA contracts. The contractor shall execute the transition of networking and telephonic services in an expeditious manner. The transition plan shall minimize impact to existing DISA VISP program customers all cut-over action shall be conducted during established maintenance windows.
17. An Agency-Level Transition Plan (ALTP) The contractor shall provide a draft ALTP with their proposal that will be finalized with the customer after award. This plan describes the contractor's general approach to Program Management, the Project Management process, procedures, and set of transition activities in support of DISA. The plan must ensure transition is completed on time. Requirements of the ALTP are outlined in Table 6.18.1.
Deliverable:
Table 6.18.1 APLT Requirements
| Deliverable Title |
| Format |
| Due Date |
| Distribution/Copies |
| Frequency and Remarks |
| ALTP |
| Agreed upon format |
| Within 30 days after award |
| COR |
| Email to COR |
*Standard Distribution: 1 copy of the transmittal letter without the deliverable to the Contracting Officer; 1 copy of the transmittal letter with the deliverable to the COR.
17. Program Review Meetings The contractor shall attend in person an initial contract kick-off meeting at a location to be determined by the customer within 30 days of contract award. The contractor Program Manager (PM) shall attend monthly program review meetings (via teleconference or VTC and twice per year in person) with the DoD PM and the COR. The meetings shall be held beginning one month after award. The agenda for these meetings shall be finalized and distributed five business days prior to their scheduled date to the COR and the DoD PM for distribution to appropriate personnel. These meetings shall include both formal presentations and working session formats. The contractor shall provide the formats for presentations and the hardcopy packages. Table 6.18.2 outlines the requirements.
Table 6.18.2 Program Review Meetings Requirements
| Deliverable Title |
| Format |
| Due Date |
| Distribution/Copies |
| Frequency and Remarks |
| Activation Status Report |
| Agreed upon format |
| Within 5 business days of following month |
COR
**Monthly / Email to COR
*Standard Distribution: 1 copy of the transmittal letter without the deliverable to the Contracting Officer; 1 copy of the transmittal letter with the deliverable to the COR.
**Monthly if there are any applicable changes to the data for the customer
17. The contractor shall also support smaller, less formal weekly teleconference calls to review the status of open orders, critical issues and risks, and discuss overall issues affecting the delivery of services for DISA and its MPs.
Table 6.18.3
| Deliverable Title |
| Format |
| Due Date |
| Distribution/Copies |
| Frequency |
| Program Review Meeting Agenda |
| Agreed upon format |
| Five business days prior to meeting |
| COR |
| Weekly / Email to COR |
*Standard Distribution: 1 copy of the transmittal letter without the deliverable to the Contracting Officer; 1 copy of the transmittal letter with the deliverable to the COR.
17. Web Interface Within one month after award the contractor shall provide a web interface for the purpose of gathering information during and after transition. The web interface shall provide the capability for management of awarded services. The web interface shall provide Pricing Catalog, Trouble Ticketing, Inventory Management, SLA Management and Billing. In addition, the web interface shall support common industry products. The web interface shall support current versions of MS browsers, Google Chrome, Mozilla Firefox, and Apple Safari. All interfaces shall work on both desktop and mobile platforms.
17. The web-based management portal shall support role-based access control, allowing for a minimum of two tiers of role-based access:
A) DISA VISP Program Administrator Tier – Users in this role will be designated by DISA and have access to all DISA-related service information within the portal and have access to all information related to any DISA VISP MPs and customers utilizing the services through DISA-managed access and SIP trunks. DISA VISP program administrators shall have access to all available settings and parameters associated with the SIP trunks and the underlying L3VPN transport environment.
B) DISA VISP Customer Tier – Users in this role will be designated by DISA or DISA VISP customer administrators, and will only have access to service information and trouble tickets applicable to their DIDs and particular “domain” within the portal. Users in this role shall not have the ability to access user information outside of their assigned role or domain. The portal shall preclude users in this role from operating or changing higher level settings that could cause adverse impacts to services for other DISA VISP program customers such as changing global network or SIP trunk level settings affecting DISA’s overall ability to deliver VISP program services.
C) The contractor shall maintain an audit log of each user access of the portal and any actions performed while logged into the portal and provide the log to DISA VISP program administrator staff upon request. The COR will provide a list of users and access privileges to the contractor 30 days after award.
5. NS/EP
The contractor shall ensure that services delivered are in compliance with NS/EP requirements, which include a wide range of Executive Orders (EOs), Presidential Directives as promulgated by the Executive Office of the President, the Director of Homeland Security, the Office of Emergency Communications and other Government entities.
The TSP System (FCC 88-341) provides a framework for telecommunications services contractors to initiate, restore, or otherwise act on a priority basis to ensure effective NS/EP telecommunication services. The TSP System applies to common carriers, to Government, and to private systems that interconnect with commercially provided services or facilities. The TSP System is intended to apply to all aspects of end-to-end NS/EP telecommunication services. The TSP system allows five (5) levels of priorities for restoration (5, 4, 3, 2, or 1) and provisioning (5, 4, 3, 2, 1, or E).
The contractor shall fully comply and interoperate with the TSP system for priority provisioning (i.e., installation of new circuits), restoration of previously provisioned circuits, and priority level for design change of circuits, including coordination between local access providers and the transport segment. The contractor shall fully comply and interoperate with any future TSP replacement system.
Should the contractor’s network experience significant degradation or failure, the contractor shall provide priority restoration of affected services in accordance with the TSP system five levels of priorities. In addition, the contractor shall ensure that the restored circuits retain the property of the original circuits (i.e., TSP levels).
TSP Authorization Codes are active for three (3) years, at which point the service user will need to revalidate them. Service users must request TSP restoration priority before a service outage occurs.
The contractor shall provide assistance for services associated with the TSP system of NS/EP, to include registering for priority installation, priority restorations, and priority level for design changes. The support will include registering for priority installation, priority restorations, and priority level for design changes. It shall also include maintaining priority restoration.
NS/EP shall also include maintaining priority restoration. The contractor shall ensure that services delivered are in compliance with national policy directives that apply to the national telecommunications infrastructure. Specific national policy requirements include, but are not limited to, PL 93-288 (Disaster Preparedness Assistance dated May 22, 1974), PPD-1 (Organization of the National Security Council System dated February 13, 2009), PPD-21 (Critical Infrastructure Security and Resilience, dated February 12, 2013), NSDD-97, NSDD-145 and its successors, and other applicable laws, regulations, and directives. EOs 12472 and 13618 and its successors shall also be considered in the design and operations of services provided under this contract. The contractor shall provide an NS/EP Functional Requirements Implementation Plan within 10 days of award the proposal and update it annually. The contractor shall notify DISA immediately when events arise that may have major consequences to its network. This notification is similar to the “abnormal report” currently furnished to the DHS National Coordinating Center. The contractor shall be solely responsible for network operations.
Table 6.19 – NS/EP Deliverables
| Deliverable Title |
| Format |
| Due Date |
| Distribution/Copies |
| Frequency |
NS/EP
Functional Requirement Implementation Plan
| MS Word (Emailed) |
| Required in proposal submission |
| Distribution List TBD the COR |
| 1x annually after award. |
5. Post Award Installation Moves, Add, Changes, Deletions (IMACDs) and monitoring:
19. Monitoring service availability, performance, initiating IMACDs, and creating trouble tickets shall be accomplished via a contractor provided Web based portal.
19. The services awarded under this contract will support continued delivery of commercial SIP-trunking services, associated network access and DID requirements in support of DoD telephony requirements.
5. Network Technology Refresh Proposals
The contractor shall notify the Government when a technology refresh is deemed necessary. The Contractor may submit unsolicited technology insertion proposals as technology evolves.
1. Performance Metrics
6. Transport Network Performance Threshold, Acceptable Quality Level (AQL), and of Key Performance Indicator (KPI) for the contractor’s services listed in Table 7.1 are mandatory unless marked optional.
The contractor shall utilize their own infrastructure to measure…
This is the start of the file's text. The full file is on GovTribe.
File details come from the government source that posted it. Updated .