MORA_V2.5_Training_ Session_Three_March_2023_CCDC_C5ISR_Center_DLB_Rev25_DIST_A_APPROVED-23-319.pdf
PDF 8 MB Posted
- Solicitation number
- FY22-C5ISR-CMOSS
About this file
This document is a training syllabus for the MORA (Modular Open RF Architecture) 2.5 training course, specifically focusing on Session Three which covers Signal Resource Interactions and Networks. The key details are:
The MORA architecture is a suite of standards developed by the U.S. Army C5ISR Center to support interoperability and flexibility for C5ISR and EW systems. Session Three of the MORA 2.5 training course covers the following topics: VDB (VICTORY Data Bus) Management Interactions, ML2B (MORA Low Latency Bus) RF Layer Data/Context/Command Interactions, Operations Interactions, and Network Environments (VDB and ML2B). The training provides a detailed overview of the MORA Device Component Type and MORA Signal Resource Manager Component Type, including the various management parameters and operations that can be performed. The document includes diagrams and extensive technical details on the MORA architecture and interfaces.
View the file
Other files
Show all 27
On GovTribe
Work with this file
- Download the original file
- Contacts named in this file
- Similar government files
- Ask GovTribe AI about this file
Text version
APPROVED FOR PUBLIC RELEASE
U.S. ARMY COMBAT CAPABILITIES
DEVELOPMENT COMMAND –
C5ISR CENTER
MORA Architecture Working Group (AWG)
RTI Directorate / CT Division / ITA Branch
MORA V2.5 Training Course: Session Three – Message Interactions and Environments
09 March 2023
DISTRIBUTION STATEMENT A. Approved for Public Release. Distribution is unlimited.
Approved for Public Release on
23 MAR 2023 under C5ISR
Center DRAS # 23-319
Session One: Introduction to MORA (DIST A): (2 Hours)
▪ Part 1: Introduction to MORA (Motivation, Objectives, Foundation, Core Features, History/Future)
▪ Part 2: MORA Formal Definitions (Devices, Resources, Ports)
▪ Part 3: MORA Client Control Structure (Device Level, Processing Resource and Signal Resource)
Session Two: Signal Resource Overview (DIST A): (2 Hours)
▪ Part 4: Signal Resource Component Types (Key Interactions)
▪ Part 5: MORA Signal Resource Profile (MSRP) (Electronic RF Datasheet)
▪ Part 6: Summary for the MORA Implementation of VITA 49.2 (limitations, clarifications, additions)
Session Three: Signal Resource Interactions and Networks (DIST A): (4 Hours)
▪ Part 7: VDB Management Interactions (MORA Device, MORA Signal Resource Manager)
▪ Part 8: ML2B RF Layer Data, Context and Command Interactions (MDM Type 1)
▪ Part 9: Operations interactions (MDM Types 2-7)
▪ Part 10: Network Environments (VDB and ML2B)
Session Four: (DIST C): (2 Hours)
▪ Part 11: (DIST C)
▪ Part 12: (DIST C)
▪ Part 13: (DIST C)
Session Five: (DIST C): (2 Hours)
▪ Part 14: MORA Processing Resources (DIST A)
▪ Part 15: (DIST C)
▪ Part 16: (DIST C)
MORA TRAINING SYLLABUS
▪ Part 7: VDB Management Interactions
▪ MORA Device Component Type
▪ MORA Signal Resource Manager Component Type
▪ Part 8: ML2B RF Layer Data, Context and Command Interactions
▪ MORA Signal Port Manager Component Type
▪ MDM Type 1 (MORA implementation of VRT V49.2)
▪ Command Packet
▪ Context Packet
▪ Signal Data Packet
▪ Part 9: Operations Interactions
▪ MDM Types 2-7
▪ Part 10: Network Environments
▪ VICTORY Data Bus (VDB)
▪ MORA Low Latency Bus (ML2B)
MORA TRAINING COURSE
SESSION THREE
MORA BIGGER PICTURE REVISIT
MORA Training
Course Session
Three will focus on these signal resource interactions and network environments
MORA SW CT REVISIT
Part 7: VDB
Management
Interactions
Part 8: ML2B
RF Layer
Data, Context and
Command
Interactions
Part 9:
Operations
Interactions
Part 10:
Network
Environments
Part 7: VDB Management
Interactions
MORA DEVICE COMPONENT TYPE
ATLAS REQUEST RESPONSE
MESSAGE LEGEND
The ATLAS template includes “required” [R] and “conditionally required” [CR] indicators for simple and complex types and indicates inclusive lower and upper bounds within <> symbols for the length of lists.
The MSRP feeds values from the device profile for return values of the request / response interactions of the MD and MSRM SW Component Types. There are instances where there are correlations to the MSPM
Component Type and MDM Type 1 VRT control and context fields indicated within │ │ symbols.
“Within the specification data type definitions, data formats primarily include restricted string, restricted URI, integer (32-bit), unsigned integer (32-bit), long (64-bit integer), float (32-bit real), double (64-bit real), and Boolean.
The ATLAS template includes valid data value ranges in ( ), data value units in [ ] and other description information or notes in { }.
Version Information Management Parameters (Operations):
Interface Type (get)
Interface Standard Version (get)
Interface SOAP Components (get)
Needs high res
Version Information Management Parameters for MORA (49102-20220307):
Device Information Management Parameters (Operations):
Manufacturer (get)
Model (get)
Equipment Identifier (get)
Generic End Node Management Parameters (Operations):
Ethernet Interfaces (get)
DHCP Enabled (get)
Generic End Node Management Parameters (Operations):
Host Name (get / set)
Date Time (get / set)
Generic End Node Management Parameters (Operations):
Auto-Discovery Enabled (get / set)
Display Blackout Enabled (get / set)
Generic End Node Management Parameters (Operations):
Generic End Node (restart / standby / purge)
Device Management Parameters (Operations):
Device Description (get)
Device Status (get)
Device Management Parameters (Operations):
File (push / pull / get list)
MORA DEVICE COMPONENT TYPE
Device Management Parameters (Operations):
File (delete)
Current MORA Configuration (get available / get / set)
Device Management Parameters (Operations):
Built-In Test Results (run / get)
Command (send)
Waveform Management Parameters (Optional) (Operations):
Waveforms (get available)
Waveform Operations (get available)
Waveform Management Parameters (Optional) (Operations):
Waveform Operations (get current / set current)
Syslog-Based Health Publishing Management Parameters (Operations):
Data Transport Configuration (get, set)
Syslog-Based Health Publishing Management Parameters (Operations):
Data Transport Configuration (add, remove)
Update Period (get fault)
Syslog-Based Health Publishing Management Parameters (Operations):
Update Period (set fault, get status, set status)
Fault Severity Level (get, enable)
Syslog-Based Health Publishing Management Parameters (Operations):
Fault Severity Level (disable)
Status Enabled (get, set)
Acknowledge Fault (get)
Syslog-Based Health Publishing Management Parameters (Operations):
Acknowledge Fault (set)
Resume Fault (set)
Active Fault (get)
Syslog Protocol Data Parameters:
PRI
VERSION
TIMESTAMP
HOSTNAME
APP-NAME
PROCID
MSGID
SD-ID: healthParameters@41192
SD-PARAM:
id acknowledgeable suggestedAction state
MSG
Syslog Protocol Data Parameters for MORA:
SD-ID: moraDevice@41192
SD-PARAM:
deviceState waveform
SPM_errors
SPM_out_of_sequence
SPM_ACKs
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
Version Information Management Parameters (Operations):
Interface Type (get)
Interface Standard Version (get)
Interface SOAP Components (get)
See MORA Device Component Type (above) for Health Publishing and SYSLOG messaging
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
SOAP
Version Information Management Parameters
Version Information
Management Parameters for MORA 49102-20220307
Version Information Management Parameters for MORA (49102-20220307):
MORA Signal Resource Management Parameters (Operations):
Signal Port (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters
MoraSignalResource.wsdl
Signal Port
<49014-20221221> getSignalPorts( ), return value = List "Signal Port"
List "Signal Port" [R] <1:127>
ID [R] Value from Profile Integer (1 to 127) |Stream ID|
Type [R] Value from Profile Restricted String (ARX, ATX, ATR, DRX, DTX, DTR, ARI, ARO, DRI, DRO)
Sub Type [R] Value from Profile Restricted String (RSC, ISC, BSC, RMC, IMC, BMC, RFS, IFS, BBS, OSC, CLK)
Role [R] Value from Profile Restricted String (PRODUCER, CONSUMER, BOTH)
RX Delay [RC] Value from Profile Long [Femtoseconds] {Required for signal port types ARX, ATR, DRX, and DTR}
TX Delay [RC] Value from Profile Long [Femtoseconds] {Required for signal port types ATX, ATR, DTX, and DTR}
Min Power Value from Profile Integer [dBm]
Min Voltage Value from Profile Integer [Volts]
Max Power Value from Profile Integer [dBm]
Max Voltage Value from Profile Integer [Volts]
RX Frequency Range [RC] "Frequency Range" |RF Reference Frequency| {Required for signal port types ARX, ATR, DRX, and DTR}
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
TX Frequency Range [RC] "Frequency Range" |RF Reference Frequency| {Required for signal port types ATX, ATR, DTX, and DTR}
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
Antenna Resources List of Restricted Strings <1:N>
Antenna Resource [R] Value from Profile Restricted String (xxEyyyyy) |Reference Point Identifier| {xx is Antenna Array ID and yyyyy is Array Element ID}
MORA Transport Configuration [R] "MORA Resource Transport Configuration"
Control Transport Configuration [R] "Data Transport Configuration"
Unique Name [R] Value from Profile Restricted String (minimally includes MAC address in first 17 characters) {Statically assigned (locally administered) e.g. 02:C0:ED:12:34:56}
Index Value from Profile Integer
URI [R] Value from Profile Restricted URI (RFC 3986 shall minimally include IPv4/6 address, port, and MUI in the path) {e.g. udp://192.168.0.1:50000/50100}
Signal Data Transport Configuration [RC] "Data Transport Configuration" {Shall be provided for digital signal port “PRODUCER” or “BOTH” role use cases. Shall not be provided for all analog signal port, digital signal port “CONSUMER” role, and all switch group use cases.}
Unique Name [R] Value from Profile Restricted String (minimally includes MAC address in first 17 characters) {Statically assigned (locally administered) e.g. 03:C0:ED:12:34:56}
Index Value from Profile Integer
URI [R] Value from Profile Restricted URI (RFC 3986 shall minimally include IPv4/6 address, port, and MUI in the path) {e.g. multicast://224.0.0.6:50001/50100}
Context Transport Configuration [R] "Data Transport Configuration"
Unique Name [R] Value from Profile Restricted String (minimally includes MAC address in first 17 characters) {Statically assigned (locally administered) e.g. 03:C0:ED:12:34:56}
Index Value from Profile Integer
URI [R] Value from Profile Restricted URI (RFC 3986 shall minimally include IPv4/6 address, port, and MUI in the path) {e.g. multicast://224.0.0.6:50002/50100}
Test Source "Test Source"
Frequency Range [R] "Frequency Range" |Aux Frequency|
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
Injected Power Range [R] "Injected Power Range" |Aux Gain|
Min Injected Power [R] Value from Profile Float (-2^8 to 2^8 - (1/2^7)) [dBm] {fractional resolution is 1/2^7 dB (0.0078125 dB)}
Max Injected Power [R] Value from Profile Float (-2^8 to 2^8 - (1/2^7)) [dBm] {fractional resolution is 1/2^7 dB (0.0078125 dB), Max ≥ Min}
Resolution [R] Value from Profile Float ( 1/2^7 to 2^8 - (1/2^7)) [dBm] {fractional resolution is 1/2^7 dB (0.0078125 dB)}
Test Source Waveforms [R] List of Integers <1:64>
Test Source Waveform [R] Value from Profile Integer (0 to 63) |Discrete IO 32| {unmodulated continuous wave signal has been defined as waveform number 0}
Required Control Fields [R] List of Integers <0:62>
Required Control Field [R] Value from Profile Integer (1 to 31,101 to 131) {1 to 31 maps to CIF0 bit fields, 101 to 131 maps to CIF1 bit fields}
Client Inactivity Timeout [R] Value from Profile Long (≥0) [Nanoseconds] {applies to control transport configuration only, when = 0 indicates not implemented}
Command Execution Time [R] Value from Profile Long (>0) [Nanoseconds]
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types 49016-20221221
SOAP
MORA Signal Resource Management Parameters (Operations):
Signal Port (reserve)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Signal Port (release)
Signal Port Reservations (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Signal Port Description (get) (1 of 2)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters
MoraSignalResource.wsdl
Signal Port Description
<49014-20221221> getSignalPortDescription(ID), return value ="Signal Port Description"
ID [R] Integer (1 to 127) |Stream ID| {ID corresponding to a "Signal Port"}
"Signal Port Description" [R]
Signal Port ID [R] Value from Profile Integer (1 to 127) |Stream ID|
RF Conditioning "Radio Frequency Conditioning" (Shall not be empty)
Gain Stages List "Gain Stage" <1:2>
Stage Number [R] Value from Profile Integer (1 to 2) |Gain|
Signal Direction [R] Value from Profile Restricted String (TX, RX)
Gain Type [R] Value from Profile Restricted String (AUTOMATIC, MANUAL, SELECTABLE) |Discrete IO 32|
Manual Gain [RC] "Manual Gain" {Shall be provided as part of Gain Stage when Gain Type is MANUAL or SELECTABLE, shall not be provided as part of Gain Stage when Gain Type is AUTOMATIC}
Minimum Gain [R] Value from Profile Float (-2^8 to 2^8 - (1/2^7)) [dBm] {fractional resolution is 1/2^7 dB (0.0078125 dB)}
Maximum Gain [R] Value from Profile Float (-2^8 to 2^8 - (1/2^7)) [dBm] {fractional resolution is 1/2^7 dB (0.0078125 dB), Max > Min}
Resolution [R] Value from Profile Float (>0 to 2^8 - (1/2^7)) [dBm] {fractional resolution is 1/2^7 dB (0.0078125 dB)}
Output Level [RC] List of Floats <1:N> {Shall be provided as part of Gain Stage when Gain Type is AUTOMATIC or SELECTABLE, shall not be provided as part of Gain Stage when Gain Type is MANUAL}
Level Value from Profile Float (-28 to 28 - (1/27)) [dBm] |1 dB Compression Point| {fractional resolution is 1/27 dB (0.0078125 dB)}
Filter Banks List "Filter Bank" 8 <1:3>
ID [R] Value from Profile Integer (1 to 3) |Discrete IO 64|{unique identifier of the filter bank for a signal port within a MORA device}
Filters [R] List "Filter" <2:32>
ID [R] Value from Profile Integer (0 to 31) |Discrete IO 64| {bypass FL0 / select FL1-FL30 / FL31 is for tunable filters}
Signal Direction [R] Value from Profile Restricted String (TX, RX, TOR)
Filter Logic [R] Value from Profile Restricted String (FIXED, SELECTABLE, TUNABLE)
Filter Type [R] Value from Profile Restricted String (BAND_PASS, BAND_REJECT, HIGH_PASS, LOW_PASS, BYPASS)
Gain Delta [R] Value from Profile Float [dB]
Delay Delta [R] Value from Profile Long [Femtoseconds]
Frequency Range [R] "Frequency Range" |Aux Frequency| {Aux frequency at the -3 dB amplidute response points for tunable filters FL31}
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
Bandwidth Value from Profile Double (>0) [Hz] {fractional resolution is 1/2^20 Hz; used with tunable filter logic}
RF Translation "Frequency Translation"
IF Center Frequencies [R] List of Doubles <1:N>
Frequency Value from Profile Double (>0 to 2^43 - (1/2^20)) [Hz] |IF Reference Frequency| {fractional resolution is 1/2^20 Hz}
IF Bandwidths [R] List of Doubles <1:N>
Bandwidth Value from Profile Double (>0 to 2^43 - (1/2^20)) [Hz] |Bandwidth| {fractional resolution is 1/2^20 Hz}
RF Range [R] "Frequency Range" |RF Reference Frequency|
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
RF Bandwidths [R] List of Doubles <1:N>
Bandwidth Value from Profile Double (>0 to 2^43 - (1/2^20)) [Hz] |Bandwidth| {fractional resolution is 1/2^20 Hz}
Tuning Speed [R] Value from Profile Long (>0) [Femtoseconds]
Sub Port RF Translations List "Sub Port Frequency Translation" <1:N>
Sub Port ID [R] Value from Profile Integer (1 to 65,535) |Stream ID|
Sub Tuning Range [R] "Frequency Range" |RF Reference Frequency Offset|
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Signal Port Description (get) (2 of 2)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
Signal Domain Conversion "Signal Domain Conversion" (Shall not be empty)
Signal Port Signal Domain Conversion Description "Signal Domain Conversion Description"
ID [R] Value from Profile Integer (1 to 127)
Signal Direction [R] Value from Profile Restricted String (TX, RX, TOR)
Supported Signal Data Formats [R] (Shall not be empty)
Time Domain Packet Formats <1:N>
Time Domain Packet Format Description [R] Value from Profile Restricted String (Human Readible)
Time Domain Packet Format Value [R] Value from Profile Hexadecimal 16 Character String {Hexadecimal representation of the binary V49.2 Signal Data Payload Packet Field} |Signal Data Packet Payload Format|
Frequency Domain Packet Formats <1:N>
Frequency Domain Packet Format Description [R] Value from Profile Restricted String (Human Readible)
Frequency Domain Packet Format Value [R] Value from Profile Hexadecimal 104 Character String {Hexadecimal representation of the binary V49.2 Spectrum Field} |Spectrum|
Sample Bandwidths and Sample Rates [R] List "Sample Bandwidth and Sample Rate" <1:N>
Sample Bandwidth [R] Value from Profile Double (>0 to 2^43 - (1/2^20)) [Hz] |Bandwidth| {fractional resolution is 1/2^20 Hz}
Sample Rate [R] Value from Profile Double (>0 to 2^43 - (1/2^20)) [samples per second] |Sample Rate| {fractional resolution is 1/2^20 samples per second}
TX Buffer Size [R] Value from Profile Long (≥ ) [Bytes] {0 if DRX Port}
RX Buffer Size [R] Value from Profile Long (≥ ) [Bytes] {0 if DTX Port}
Sub Port Signal Domain Conversion Descriptions List "Signal Domain Conversion Description" <1:N>
ID [R] Value from Profile Integer (1 to 65,535)
Signal Direction [R] Value from Profile Restricted String (TX, RX, TOR)
Supported Signal Data Formats [R] (Shall not be empty)
Time Domain Packet Formats <1:N>
Time Domain Packet Format Description [R] Value from Profile Restricted String (Human Readible)
Time Domain Packet Format Value [R] Value from Profile Hexadecimal 16 Character String {Hexadecimal representation of the binary V49.2 Signal Data Payload Packet Field} |Signal Data Packet Payload Format|
Frequency Domain Packet Formats <1:N>
Frequency Domain Packet Format Description [R] Value from Profile Restricted String (Human Readible)
Frequency Domain Packet Format Value [R] Value from Profile Hexadecimal 104 Character String {Hexadecimal representation of the binary V49.2 Spectrum Field} |Spectrum|
Sample Bandwidths and Sample Rates [R] List "Sample Bandwidth and Sample Rate" <1:N>
Sample Bandwidth [R] Value from Profile Double (>0 to 2^43 - (1/2^20)) [Hz] |Bandwidth| {fractional resolution is 1/2^20 Hz}
Sample Rate [R] Value from Profile Double (>0 to 2^43 - (1/2^20)) [samples per second] |Sample Rate| {fractional resolution is 1/2^20 samples per second}
TX Buffer Size [R] Value from Profile Long (≥ ) [Bytes] {0 if DRX Port}
RX Buffer Size [R] Value from Profile Long (≥ ) [Bytes] {0 if DTX Port}
Sub Ports List "Sub Port" <1:65,535>
ID [R] Value from Profile Integer (1 to 65,535)
Type [R] Value from Profile Restricted String (DDC, DUC, NCH)
Channel Coherency [R] Value from Profile Restricted String (PHASE_COHERENT, LO_COHERENT)
Required Control Fields [R] List of Integers <0:62>
Required Control Field [R] Value from Profile Integer (1 to 31,101 to 131) {1 to 31 maps to CIF0 bit fields, 101 to 131 maps to CIF1 bit fields}
Error Type Error Text
GENERIC_FAULT "Invalid signal port id"
OUT_OF_RANGE
List of "Frequency Domain Packet Format"
List of "Time Domain Packet Format"
"Signal Data Formats"
"Signal Data Formats"
List of "Frequency Domain Packet Format"
List of "Time Domain Packet Format"
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Signal Port Default Performance Data (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Static External Connection Map (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Static Internal Connection Map (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Internal Reference Connections (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
MORA Signal Resource Management Parameters (Operations):
Antenna Arrays (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
Signal Resource Management Parameters
MoraSignalResource.wsdl
Antenna Arrays
<49014-20221221> getAntennaArrays( ), return value = List "Antenna Array"
<0:N> {RHD Device Type shall contain at least one item, others device types return empty}
ID [R] Value from Profile Integer (0 to 31) |Reference Point Identifier| {ID of 0 shall be used for unlike elements not part of a true array}
Type [R] Value from Profile Restricted String (CIRCULAR, DISCRETE, CONFORMAL, LINEAR_2D, LINEAR_3D, COLUMN)
Steering Control [R] Value from Profile Restricted String (FIXED, MECHANICAL, BEAMFORMER)
Array Field of View [R] "RF Field of View"
Azimuth Range [R] "Azimuth Range" {beginning at Azimuth Start and moving clockwise to Azimuth Stop}
Azimuth Start [R] Value from Profile Float (0 to <360) [Arc Degrees]
Azimuth Stop [R] Value from Profile Float (0 to <360) [Arc Degrees]
Elevation Range "Elevation Range" {beginning at Elevation Start and moving towards zenith to Elevation Stop}
Elevation Start [R] 0 Float (-90 to +90) [Arc Degrees]
Elevation Stop [R] Value from Profile Float (-90 to +90) [Arc Degrees]
Elements [R] List "Array Element" <1:65,535>
ID [R] Value from Profile Integer (1 to 65,535) |Reference Point Identifier|
Type [R] Value from Profile Restricted String (MONOPOLE, DIPOLE, SPIRAL, OTHER)
Polarizations [R] List "Polarization" <1:N>
Orientation Angle [R] Value from Profile Float (0 to π) [Radians] {corresponding to tilt angle in VITA 49.2 polarization field}
Ellipticity Angle [R] Value from Profile Float (>-π/ to +π/ ) [Radians]
Frequency Range [R] "Frequency Range"
Start [R] Value from Profile Double (-2^43 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
End [R] Value from Profile Double (- ^ 3 to ^ 3 - ( / ^ )) [Hz] {fractional resolution is / ^ Hz, End ≥ Start}
Resolution [R] Value from Profile Double (0 to 2^43 - (1/2^20)) [Hz] {fractional resolution is 1/2^20 Hz}
Location [R] "Relative Cartesian Coordinates" {Relative to platform center}
X [R] Value from Profile Double [Meters] {positive x-axis shall point forward down the centerline of the platform}
Y [R] Value from Profile Double [Meters] {positive y-axis shall point 90 degrees left of forward}
Z [R] Value from Profile Double [Meters] {positive z-axis shall be orthogonal to the x-axis and y-axis and shall point upward from the platform}
Boresight Gain [R] Value from Profile Float [dBi]
Beamwidth [R] "RF Field of View" {relative to element boresight}
Azimuth Range [R] "Azimuth Range" {beginning at Azimuth Start and moving clockwise to Azimuth Stop}
Azimuth Start [R] Value from Profile Float (0 to <360) [Arc Degrees]
Azimuth Stop [R] Value from Profile Float (0 to <360) [Arc Degrees]
Elevation Range "Elevation Range" {beginning at Elevation Start and moving towards zenith to Elevation Stop}
Elevation Start [R] Value from Profile Float (-90 to +90) [Arc Degrees]
Elevation Stop [R] Value from Profile Float (-90 to +90) [Arc Degrees]
List "Antenna Array" [R]
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
ANTENNA ARRAY AND ARRAY
ELEMENT ENUMERATION
Antenna Array:
An antenna array shall be defined as a collection of two or more “like” antenna elements. “Like” antenna elements share the same type, polarization, frequency range, boresight gain, and beamwidth. For single unique antenna element implementations, the Antenna Array ID shall be set to zero. The enumeration of ARRAY ID for antenna arrays implementations shall be assigned starting at “1” and increasing numerically in accordance with increasing array minimum frequency.
Array Element:
An element shall be defined as a single antenna that captures or radiates electromagnetic energy in support of receive and/or transmit operations. Zero (0) is not a valid antenna element ID, but this value shall be used to reflect context or implement command fields at the whole array level. The enumeration for ELEMENT ID in array implementations shall be assigned starting at “1” and increasing numerically in accordance with the guidance below.
• Circular Arrays: Element #1 shall be assigned to the element phase center positioned closest to 0.000 degrees (sensor forward) azimuth and increase numerically, in accordance with clockwise rotation in azimuth, ending at 359.999 degrees.
• Linear Arrays: For a single row, linear array (2D), element #1 shall be assigned to the left most element as one faces the array boresight and increase numerically from left to right. If the linear array has multiple rows (3D), element #1 shall be assigned to the upper row (row one) leftmost element as one faces the array boresight. The row one element enumeration shall continue from left to right until the last element, and then monotonically increases from row one downward to row two, in that the first (numerically lowest) element number for row two is the element under element number one, and shall continue to increase numerically from left to right, and shall repeat in this fashion for all additional rows.
• Discrete Arrays: Element #1 shall be assigned to the element phase center positioned closest to 0.000 degrees azimuth
(platform forward) and increase numerically in accordance with clockwise rotation in azimuth, ending at 359.999 degrees.
The enumeration for ELEMENT ID in single unique element implementations (ARRAY ID set to 0) shall be assigned starting at
“1” and increase numerically in accordance with increasing element minimum frequency.
MORA Signal Resource Management Parameters (Operations):
Manifold Bands (get)
MORA SIGNAL RESOURCE
MANAGER COMPONENT TYPE
Manifold Band:
It is important to note that MORA also supports the concept of manifold bands for antenna resources where combinations of elements from one or more arrays are used to develop an aperture manifold over a specific frequency range for the purpose of processing signal data for direction finding or receive beamforming (e.g., co-channel mitigation) as well as generating signal data for transmit beamforming. Manifold bands convey critical information on which antenna arrays and elements are to be used in forming the aperture manifold at a specified frequency. In some cases, the manifold might specify elements from two different array numbers, especially in cross over frequency regions. Manifold band enumeration shall be assigned starting at "00000000001" (1) and increase numerically in accordance with increasing manifold band minimum frequency.
MORA Signal Resource Management Parameters 49014-20221221
MORA Common Complex Types
Radio Frequency Distribution Management Parameters (optional) (Operations):
Switch Groups (get)
Radio Frequency Distribution Management Parameters (optional) (Operations):
Switch Groups (reserve)
Radio Frequency Distribution Management Parameters (optional) (Operations):
Switch Groups (release)
Switch Group Reservations (get)
Part 8: ML2B RF Layer Data, Context and Command
Interactions
MORA SIGNAL PORT MANAGER
COMPONENT TYPE
▪ MORA Signal Port Manager Component Type consists of the following interfaces and the MORA Signal Resource Profile:
▪ The RF Layer Analog Data Interface is a hardware specification.
▪ The other four RF Layer interfaces are accomplished with the use of seven types of binary level MORA Data Messages
(MDMs).
▪ The RF Layer Command, RF Layer Context and RF Layer Digital
Data interfaces are implemented using the MDM Type 1 VRT
Messages.
▪ The RF Layer Command Interface and the RF Layer Operations
Interface are unicast. The RF Layer Context and RF Layer
Digital Data interfaces are multicast.
▪ The unicast RF Layer Command and RF Layer Operations interfaces can request a receipt acknowledge response in the form of an MDM Type 2 message.
▪ The MDM Type 1 Message payload construct is based on the
MORA implementation of the V49.2 specification defined in chapter 6 of the MORA specification. A summary of the MORA limitations, clarifications and additions to V49.2 are summarized in another part of this MORA training course.
▪ RF Layer Command Interface:
▪ RF Layer Context Interface:
▪ RF Layer Digital Data Interface
▪ RF Layer Operations Interface:
▪ The RF Layer Operations interface is accomplished with the use of six types of MDMs (Types 2-7).
▪ MDM Encoding: Big-Endian
▪ MDM Encapsulation: UDP
▪ MDM on ML2B: UDP / IP / Ethernet
▪ MDM Structure / Header
▪ MDM Body Number of Data Messages / Data Message Size
MDM DATA ENCODING AND
ENCAPSULATION
MDM Header
MDM Body
▪ Version callouts by MDM Version by Type table
MDM VERSION COMPATIBILITY
▪ MDM Networking Specifications:
MORA SIGNAL PORT MANAGER
(detailed in separate part of this training course)
MDM Type 1 Message
VITA Radio Transport (VRT)
MDM TYPE 1 – VITA RADIO
TRANSPORT (VRT) MESSAGE
Originating MUI /
Destination MUI
VITA Radio
Transport Message is MDM TYPE 1
Number of Data
Messages will always = 1
Data Message Length will be variable in length
VRT Message Structure
MDM TYPE 1 MORA V49.2
IMPLEMENTATION
MORA VITA 49.2 Limited Packet Types Supported (VRT Header Bits 31 - 28)
– Signal Data with Stream ID (V49.2 Packet Type 0001)
– Context (V49.2 Packet Type 0100)
– Command (V49.2 Packet Type 0110)
MORA VITA 49.2 Timestamp Format Limitation and Definition
– Timestamp Integer (TSI) Format is real time UTC seconds only (VRT Header Bits 23, 22)
– Timestamp Fractional (TSF) Format is real time UTC picoseconds only (VRT Header Bits 21, 20)
– Timestamp Definition Table - mapped to Packet Type and Sub Type
MORA VITA 49.2 Definitions within the VRT General Prologue
– Stream ID (SID) Field Definition
• Mandatory for all MORA Packets
• Specific Bit Field definition
– Class ID (CID) Field Definition
• Clarified Use of Pad Bit Count
• Specific Bit Field definition for Information Class and Packet Class
MORA VITA 49.2 Limited Context/Control Fields and Context/Control Indicator
Fields (CIFs)
– MORA/VITA 49.2 Matrix
• MORA utilizes 33 VITA 49.2-defined fields within CIF words 0 and 1 only
MORA VITA 49.2 Context/Control Field Clarifications/Limitations/Definitions
– Reference Point Identifier Definition
• Specific Bit Field definition that associates Stream ID with an Antenna Resource
– State/Event Indicator Field Definition
• Specific Bit Field definition for Test Source On bits
– Signal Data Payload Format Field Limitations
• Specific Limitation in Data Sample and Data Item Formats
– Spectrum Field Clarifications
• Resolution Subfield
• Weighting Factor Subfield
• Window-Time Delta Subfield
– Sector Scan/Step Field Clarifications
• Bitmapping of Indicators in Header Field
• F2 Stop Frequency Subfield
• Resolution Bandwidth Subfield
• Threshold Subfield
– Discrete I/O 32-Bit Field Definition (Word 1)
• Specific Bit Field Definition for describing and setting Gain Control Mode, Reference Source, Coherency, Test Source, Triggers, and RF Mode
– Discrete I/O 64-Bit Field Definition (Words 2 and 3)
• Specific Bit Field Definition for describing and setting RF Filters and RF Switches
– Buffer (Size) Status Field
• Clarified Field Name
• Specific Definitions for Level and Status Subfields
MDM TYPE 1 MORA V49.2
IMPLEMENTATION (CON’T)
MORA VITA 49.2 Signal Data Packet Limitations/Definitions
– Limited Signal Data Packet Type (signal data with Stream ID ONLY)
– Limited Signal Data Item Formats (5 of 19 formats – including 4 formats in V49.a)
– Timestamp and Trailer Always Required
– Trailer State and Event Indicator Definition for Test Source On bits
MORA VITA 49.2 Context Packet Limitations/Definitions
– Limited Timekeeping Modes - Precision Only (Packet Header TSM Field always = zero)
– Limited Matrix of VITA 49.2 Context Fields
– Context Packet Generation Rule - includes a modified version of rule 7.1.5-1 from VITA 49.0
MORA VITA 49.2 Command Packet Limitations/Definitions
– Limited Matrix of VITA 49.2 Control Fields
– Support optional use of Controller/Controllee ID fields only (NO UUID fields)
– Limited Acknowledge Functions
• Support Validation Acknowledge (ReqV/AckV) functionality for all Sub Types
• NO support for Execution Acknowledge (AckX) or Query Status Acknowledge (AckS) packet variants since they are primarily redundant to context packet functions
» AckX packets are primarily redundant to context packet generated as required upon execution of controls for any persistent field
• Support control packet ReqV and ReqS ONLY
» ReqS results in a full context message being sent (with controls implemented if action is to execute) and not an AckS packet
• Revised CAM Bit Field Figures for Control, Acknowledge, and Control-Cancellation Packets
MDM TYPE 1 MORA V49.2
IMPLEMENTATION (CON’T)
MDM TYPE 1 – VRT
(HEADER AND STREAM ID)
If Class ID Present
C = 1
MDM TYPE 1 – VRT
(CLASS ID)
The Pad Bit Count (PAD BIT
COUNT) subfield shall be a 5-bit, unsigned-integer containing the pad bit value minus one, only when the pad bit count is equal to or greater than the item packing field size. Otherwise, the Pad Bit Count subfield value shall be set to
"00000" (0).
The MDM Version fields (VERSION
MAJ and VERSION MIN) shall contain the implementation’s version for the MDM Type 1.
MDM TYPE 1 – VRT
(CONTEXT & COMMAND FIELDS)
(FIELD DEFINITIONS)
(FIELD DEFINITIONS)
MDM Type 1 – Signal Data Packet
(SIGNAL DATA PACKET)
MDM TYPE 1 – VRT
(SIGNAL DATA HEADER)
Trailer Required so this bit always = 1
“S”pectrum bit: for time domain (=0) or for frequency domain (=1)
Bit 25 should be considered a “not V49.0 packet bit
(Nd0)” and shall be set to 0 for V49.0 compliant packets and set to 1 for packets not compliant with V49.0 (uses
V49.2 expansions). THERE IS SOME LACK OF
CLARITY IN THE V49.2 SPECIFICATION in that Figure
6.1-2 shows bit 25 as “r” while Table 5.1.1.1.1-1 requires bit 25 to be “Nd0” (not a V49.0 compliant packet).
Note that TSI/TSF timestamp is required for all signal data packets
(SIGNAL DATA TRAILER)
(SIGNAL DATA PACKING)
MDM TYPE 1 – VRT
(DATA PACKET PAYLOAD FORMAT)
MORA limitation on data item formats from 19 types to 5 types
(Includes same 4 types from V49.a limitation)
MORA limitation on data sample formats from 3 types to 2 types
(“Complex, Polar” disallowed)
THIS IS A CONTEXT / CONTROL FIELD CONTAINED IN A PAIRED (SAME SID)
CONTEXT STREAM OR APPLICABLE CONTROL MESSAGE
V49.2 rules are P=1 when link-efficient packing is used and P=0 when processing-efficient packing is used
MDM TYPE 1 – VRT
(DATA PACKET PAYLOAD FORMAT)
V49.2 allows sample component repeating
(“Sample Component Repeat Indicator bit 23 =
1) such as I, I, I, I, Q, Q, Q, Q or channel repeating (“Sample Component Repeat
Indicator bit 23 = 0). The repeat count equals the sample component repeat count or channel repeat count minus 1
V49.2 rules are actual size minus 1 for these values
Used to express actual number of fractional bits for MORA data item formats “00000” and
“10000”.
V49.2 supports multiple channel streams with the use of vector size where this value equals actual size minus 1
(e.g. 8 Channel Stream would be = 7)
Used to express actual number of event tag and channel tag bits
MDM TYPE 1 – VRT
(SPECTRUM CONTEXT FIELD)
The V49.2 Signal Data Packet Payload Format and “Spectrum” context fields provide a comprehensive description for frequency domain signal data streams
(SPECTRUM CONTEXT FIELD CON’T)
MDM Type 1 - Context Packet
MDM TYPE 1 – VRT
(CONTEXT PACKET)
MDM Type 1 – Context (VRT Packet Type 04)
MDM TYPE 1 – VRT
(CONTEXT PACKET HEADER)
Timestamp Mode “TSM” always high precision = 0
The Not V49.0 packet bit “Nd0” shall be set to 0 for V49.0 packets and set to 1 for packets not compliant with V49.0 (uses
V49.2 expansions)
Reserved = 0 for all VITA 49.2
Packets
MDM Type 1 - Command Packet
MDM TYPE 1 – VRT
(COMMAND PACKET)
MDM Type 1 – Command (VRT Packet Type 06)
MDM TYPE 1 – VRT
(COMMAND PACKET)
MORA Limitations on Acknowledge Packet Responses to Control / Control-Cancellation Packets
MDM TYPE 1 – VRT
(COMMAND PACKET HEADER)
Control Packets A = 0
Acknowledge Packets A = 1
Reserved = 0 for all VITA 49.2
Packets
L = 1 for Control Cancellation Packets
Otherwise L = 0
(COMMAND/ACKNOWLEDGE MODE)
(COMMAND/ACKNOWLEDGE MODE)
(COMMAND PACKET CIFS)
Part 9: Operations Interactions
(MDM Types 2-7)
MDM TYPE 2 –
ACKNOWLEDGEMENT MESSAGE
See next slides for MDM Acknowledgement Response Meaning
Matches original message MDM
Sequence Number
Originating MUI /
Destination MUI
Acknowledgement
Message is MDM Type 2
Number of Data
Messages will always = 0.
There is no data message
MDM TYPE 2 –
ACKNOWLEDGEMENT MEANING
MDM TYPE 2 – ACKNOWLEDGE
MEANING (CON’T)
MDM TYPE 3 – TIME OF DAY
MESSAGE
Originating MUI /
Destination MUI
Time of Day
Message is MDM
TYPE 3
Number of Data
Messages will always = 1
Data Message Length will be one word MDM Time of Day Field
(same as VITA 49.2 Timestamp
Integer Field)
MDM TYPE 4 – SIGNAL PORT
USER ID MESSAGE
Originating MUI /
Destination MUI
Signal Port User ID
Message is MDM
TYPE 4
Number of Data
Messages will always = 1
Data Message Length will be twenty-two words.
MDM TYPE 5 – HEALTH
MESSAGE
Originating MUI /
Destination MUI
Health Message is MDM TYPE 5
Number of Data Messages will always = 1 be two words.
MDM TYPE 6 – COMMAND
MESSAGE
Originating MUI /
Destination MUI
Command Message is MDM TYPE 6
Number of Data
Messages will always = 1
Data Message Length will be three words.
MDM TYPE 6 – COMMAND
MESSAGE (CON’T)
MDM TYPE 7 – SWITCH GROUP
USER ID MESSAGE
Originating MUI /
Destination MUI
Switch Group
User ID Message is MDM TYPE 7
Number of Data
Messages will always = 1 be fifteen words.
Part 10: Network Environments
REVISIT NOTIONAL SYSTEM
VICTORY Data Bus (VDB)
VICTORY DATA BUS (VDB)
MORA Device CT
MORA Signal
Resource Manager CT
Authentication Security Specifications
VT50440-V1.9
Authentication and
Authorization Security Specifications
VT50400-V1.9
Authorization Architecture Entrypoints
Authentication Entrypoints
Authorization
Security Specifications
VT50430-V1.9
Data Confidentiality & Integrity for Management Interfaces 10018-20221221
Data Authentication for Management Interfaces 10019-20150331
Transport Layer
Security
VICTORY DATA BUS (VDB)
VICTORY DATA BUS (VDB)
Transport Layer Security:
• Session based protection (confidentiality and integrity) of data-in-transit over TCP connections
• 1-way (client evaluates trust of the service)
• 2-way [a.k.a. mutual] (client and service evaluate trust of each other)
• Key/Trust Stores may be configured ad-hoc, or with a chain-of-trust (certificate authorities)
• A client and service enter a multi-step handshake to negotiate the connection
• Asymmetric keys are used for establishing trust, negotiating TLS version and algorithms, and setting up a symmetric session key
VICTORY DATA BUS (VDB)
VICTORY
V1.10 RELEASE
PENDING
Auto-Discovery Interface VT59930-V1.6
Zero Configuration Networking (01044-20140630)
Zero Configuration Networking (Zeroconf) was originally designed as a replacement for the “Apple Talk” protocol for use on modern and future networks. It is primarily an extension to the existing DNS IETF standard, although it uses some lower-level technologies for the node IP address auto-assignment.
Zeroconf primarily consists of three technologies:
• Link-Local Addressing: All end node components in a VDB shall support automatic assignment of IP addresses as specified in:
• IETF RFC 3927: Dynamic Configuration of IPv4 Link-Local Addresses
• IETF RFC 4862: IPv6 Stateless Address Autoconfiguration
• Multicast DNS (mDNS): All end node components in a VDB shall support mDNS as specified in:
• IETF RFC 6762: Multicast DNS, February 2013
• DNS Service Discovery (DNS-SD): All end node components in a VDB shall support DNS-SD, the DNS SRV record, and the DNS TXT record as specified in:
• IETF RFC 6763: DNS-Based Service Discovery, February 2013
• IETF RFC 2782: A DNS Resource Record (RR) for specifying the location of services (DNS SRV)
• IETF RFC 1035: Domain Names - Implementation and Specification
VICTORY DATA BUS (VDB)
SUMMARY: Zero Configuration Networking (Zeroconf) is a mechanism to dynamically share and discover nodes and services on a network.
Works without additional infrastructure services:
Domain Name System (DNS) Server
Dynamic Host Configuration Protocol (DHCP) Server
Supports both static and dynamic IP/hostname configuration
Utilizes Multicast DNS (mDNS) for information exchange
Utilizes four DNS record types:
Pointer Records (PTR)
Queries - PTR query by <service>.<domain>
Responses - PTR response points to SRV and TXT records
Service Records (SRV)
Should include related address records
Service level information:
Instance name
Service Type
Service Sub-type
Domain
Hostname
Port
Text Records (TXT)
Textual (key/value) information
E.g. Path, TLS (Boolean), etc.
Address Records (A/AAAA – IPv4/IPv6 respectively) - IP address
All services will respond to relevant queries in a series of PTR records to the requestor
Services announce themselves with PTR+SRV+TXT records
The IETF defined multicast address for IPv4 is: 224.0.0.251:5353
VICTORY DATA BUS (VDB)
SEE UPCOMING SLIDE …..
It is required that a VDB or security enclave (whichever is smaller) shall have at least one subnet. In addition, it is required that a single subnet shall not encompass more than one VDB or security enclave.
The VDB shall support Transmission Control Protocol (TCP) by conforming to the following core TCP standard:
• IETF RFC 793: Transmission Control Protocol
The VDB shall conform to the following standard for TCP congestion control mechanisms:
• IETF RFC 2581: TCP Congestion Control
The VDB shall support User Datagram Protocol (UDP) by conforming to the following core UDP standard:
• IETF RFC 768: User Datagram Protocol
One of the core tenets of the VICTORY concept is that data will be shared between applications and components across a common bus.
The data will be shared in a way that network traffic is kept to the minimum possible set.
VICTORY DATA BUS (VDB)
Both the TCP and UDP transport layer protocols specified for use by
VICTORY use a value called a port to differentiate one type of network traffic from another. A port value is used in conjunction with an IP address to create a unique address for a service or data stream. The Internet Assigned Numbers Authority (IANA) currently divides the range of ports into three categories:
• Well-known ports: 0 – 1023
• Registered ports: 1024 – 49151
• Ephemeral ports: 49152 – 65535
Most well-known ports require administrative access to an operating system. In addition, the IANA requests, but does not require, that most registered ports be known to them. Therefore, for VICTORY-developed data streams, it is recommended that ephemeral ports be used when possible, though the use of registered ports for
VICTORY-developed data streams is allowed as long as there is no conflict. In all other cases, it is recommended that predefined and well-known port ranges be used as specified in the IANA port database available at: http://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xml. In all cases, care should be taken to avoid port resource conflicts.
Components in a VDB that support QoS shall support the Differentiated Services (DiffServ) standards as specified in:
• GTP–0009: GIG Technical Profile (GTP) – Quality of Service (QoS) (primary standard)
• IETF RFC 2474: Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers
• IETF RFC 2597: Assured Forwarding of PHB (Per Hop Behavior) Group
• IETF RFC 3140: Per Hop Behavior Identification Codes
• IETF RFC 3246: An Expedited Forwarding PHB (Per Hop Behavior)
Static host addressing involves the assignment of IP addresses to hosts a priori. When static addressing is used, it is necessary for each individual network host to be manually configured with a unique IP address. The particular method required to configure a host’s IP address statically is unique to the host. Ensuring that each IP address allocated statically is unique and non-conflicting is the responsibility of the network implementer. It can be advantageous for a network to be designed with a static allocation of IP addresses. This can particularly be the case when boot-up time is at a premium.
SEE UPCOMING SLIDE …..
VICTORY DATA BUS (VDB)
The VDB shall support the frame structure, field definitions, and Media Access Control (MAC) conventions as specified in
IEEE 802.3–2008.
• Data link frames shall support 48-bit locally and universally administered addresses in a manner consistent with IEEE
802.3–2008.
• Data link frame structures shall support type-encapsulated and length-encapsulated frames as specified in IEEE
802.3–2008.
The VDB shall support the Media Access Control (MAC) protocols as specified in IEEE 802.3–2008, Clauses 2, 3 and 4.
• The MAC protocols shall convey type- and length-encapsulated frames to support IP network layer protocols.
The VDB shall support the Logical Link Control (LLC) protocols as specified in IEEE 802.2–1998 to the extent necessary to support IP network layer protocols.
The VDB shall conform to the requirements set forth in IEEE
802.1D–2004 for transparent bridging and Rapid Spanning
Tree Protocol (RSTP) functionality.
Those VDB implementations that support full-duplex Ethernet shall support flow control “PAUSE” frames as specified in IEEE
802.3–2008, Clause 31.
In order to support VLANs on the VDB, a device shall implement the IEEE 802.1Q standard.
MORA Low Latency Bus (ML2B)
MORA LOW LATENCY BUS (ML2B)
MORA LOW LATENCY BUS (ML2B)
The ML2B shall support the frame structure, field definitions, and Media Access Control (MAC) conventions as specified in
IEEE 802.3–2008.
• Data link frames shall support 48-bit locally and universally administered addresses in a manner consistent with IEEE
802.3–2008.
• Data link frame structures shall support type-encapsulated and length-encapsulated frames as specified in IEEE
802.3–2008.
The ML2B shall support the Media Access Control (MAC) protocols as specified in IEEE 802.3–2008, Clauses 2, 3 and 4.
• The MAC protocols shall convey type- and length-encapsulated frames to support IP network layer protocols.
The ML2B shall support the Logical Link Control (LLC) protocols as specified in IEEE 802.2–1998 to the extent necessary to support IP network layer protocols.
The ML2B shall conform to the requirements set forth in IEEE
802.1D–2004 for transparent bridging and Rapid Spanning
Tree Protocol (RSTP) functionality.
Those ML2B implementations that support full-duplex Ethernet shall support flow control “PAUSE” frames as specified in IEEE
802.3–2008, Clause 31.
NOTE: The MORA Specification
Document’s reference documents section cites the IEEE 802.3-2018 version (vice -2008). These references occur in the 48001, 48102, 48103, 48112, 48113 and 48114 specifications.
MORA LOW LATENCY BUS (ML2B)
In order to support VLANs on the ML2B, a device shall implement the IEEE 802.1Q standard.
SEE NEXT SLIDE FOR MDM TRAFFIC
MARKING SPECIFICATION
MORA LOW LATENCY BUS (ML2B)
MORA Session Three Complete
Session One: Introduction to MORA (DIST A): (2 Hours)
▪ Part 1: Introduction to MORA (Motivation, Objectives, Foundation, Core Features, History/Future)
▪ Part 2: MORA Formal Definitions (Devices, Resources, Ports)
▪ Part 3: MORA Client Control Structure (Device Level, Processing Resource and Signal Resource)
Session Two: Signal Resource Overview (DIST A): (2 Hours)
▪ Part 4: Signal Resource Component Types (Key Interactions)
▪ Part 5: MORA Signal Resource Profile (MSRP) (Electronic RF Datasheet)
▪ Part 6: Summary for the MORA Implementation of VITA 49.2 (limitations, clarifications, additions)
Session Three: Signal Resource Interactions and Networks (DIST A): (4 Hours)
▪ Part 7: VDB Management Interactions (MORA Device, MORA Signal Resource Manager)
▪ Part 8: ML2B RF Layer Data, Context and Command Interactions (MDM Type 1)
▪ Part 9: Operations interactions (MDM Types 2-7)
▪ Part 10: Network Environments (VDB and ML2B)
Session Four: (DIST C): (2 Hours)
▪ Part 11: (DIST C)
▪ Part 12: (DIST C)
▪ Part 13: (DIST C)
Session Five: (DIST C): (2 Hours)
▪ Part 14: MORA Processing Resources (DIST A)
▪ Part 15: (DIST C)
▪ Part 16: (DIST C)
MORA TRAINING SYLLABUS
Wrap-Up Discussions
| MORA Training Course Session Three |
| Slide 1 |
| Slide 2 |
| Slide 3 |
| Slide 4 |
| Slide 5 |
| VDB Management Interactions |
| Slide 6 |
| Slide 7 |
| Slide 8 |
| Slide 9 |
| Slide 10 |
| Slide 11 |
| Slide 12 |
| Slide 13 |
| Slide 14 |
| Slide 15 |
| Slide 16 |
| Slide 17 |
| Slide 18 |
| Slide 19 |
| Slide 20 |
| Slide 21 |
| Slide 22 |
| Slide 23 |
| Slide 24 |
| Slide 25 |
| Slide 26 |
| Slide 27 |
| Slide 28 |
| Slide 29 |
| Slide 30 |
| Slide 31 |
| Slide 32 |
| Slide 33 |
| Slide 34 |
| Slide 35 |
| Slide 36 |
| Slide 37 |
| Slide 38 |
| Slide 39 |
| Slide 40 |
| Slide 41 |
| Slide 42 |
| Slide 43 |
| Slide 44 |
| Slide 45 |
| Slide 46 |
| Slide 47 |
| Slide 48 |
| Slide 49 |
| Slide 50 |
| Slide 51 |
| Slide 52 |
| Slide 53 |
| Slide 54 |
| Slide 55 |
| Slide 56 |
| Slide 57 |
| Slide 58: MDM Type 1 Message VITA Radio Transport (VRT) |
| Slide 59 |
| Slide 60 |
| Slide 61 |
| Slide 62 |
| Slide 63 |
| Slide 64 |
| Slide 65 |
| Slide 66 |
| Slide 67 |
| Slide 68: MDM Type 1 – Signal Data Packet |
| Slide 69 |
| Slide 70 |
| Slide 71 |
| Slide 72 |
| Slide 73 |
| Slide 74 |
| Slide 75 |
| Slide 76 |
| Slide 77: MDM Type 1 - Context Packet |
| Slide 78 |
| Slide 79 |
| Slide 80: MDM Type 1 - Command Packet |
| Slide 81 |
| Slide 82 |
| Slide 83 |
| Slide 84 |
| Slide 85 |
| Slide 86 |
| Slide 87 |
| Slide 88 |
| Slide 89 |
| Slide 90 |
| Slide 91 |
| Slide 92 |
| Slide 93 |
| Slide 94 |
| Slide 95 |
| Slide 96 |
| Slide 97 |
| Slide 98 |
| Slide 99: VICTORY Data Bus (VDB) |
| Slide 100 |
| Slide 101 |
| Slide 102 |
| Slide 103 |
| Slide 104 |
| Slide 105 |
| Slide 106 |
| Slide 107 |
| Slide 108 |
| Slide 109 |
| Slide 110 |
| Slide 111 |
| Slide 112 |
| Slide 113: MORA Low Latency Bus (ML2B) |
| Slide 114 |
| Slide 115 |
| Slide 116 |
| Slide 117 |
| Slide 118: MORA Session Three Complete |
| Slide 119 |
| Slide 120: Wrap-Up Discussions |
File details come from the government source that posted it. Updated .